Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24726 - Firefox and Thunderbird segfault when opening a file dialog

Attached to Project: Arch Linux
Opened by Andrej Podzimek (andrej) - Tuesday, 14 June 2011, 18:08 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 15 June 2011, 14:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When trying to save, open or look up a file (attachment, upload, associated application) in Firefox | Thunderbird, these programs crash immediately.

Additional info:
* package version(s)
firefox 4.0.1-1
thunderbird 3.1.10-3

* config and/or log files etc.

(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GAppLaunchHandlerBamf'.
(thunderbird-bin:20882): GLib-GObject-CRITICAL **: g_type_add_interface_dynamic: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(thunderbird-bin:20882): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-desktop-app-info-launch-handler. Expected type is GDesktopAppInfoLaunchHandler.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GDaemonVfs'.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GDaemonVolumeMonitor'.
(thunderbird-bin:20882): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-volume-monitor. Expected type is GVolumeMonitor.
(thunderbird-bin:20882): GLib-GObject-WARNING **: cannot add interface type `GLoadableIcon' to type `GVfsIcon', since type `GVfsIcon' already conforms to interface
(thunderbird-bin:20882): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-vfs. Expected type is GVfs.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GVfsUriMapper'.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GVfsUriMapperSmb'.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GVfsUriMapperHttp'.
(thunderbird-bin:20882): GLib-GObject-WARNING **: invalid cast from `GDaemonVfs' to `<invalid>'
(thunderbird-bin:20882): GLib-GObject-WARNING **: invalid cast from `GDaemonVfs' to `<invalid>'
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyDrive'.
(thunderbird-bin:20882): GLib-GObject-CRITICAL **: g_type_add_interface_dynamic: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyMount'.
(thunderbird-bin:20882): GLib-GObject-CRITICAL **: g_type_add_interface_dynamic: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyShadowMount'.
(thunderbird-bin:20882): GLib-GObject-CRITICAL **: g_type_add_interface_dynamic: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyVolume'.
(thunderbird-bin:20882): GLib-GObject-CRITICAL **: g_type_add_interface_dynamic: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyVolumeMonitor'.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyVolumeMonitorGdu'.
(thunderbird-bin:20882): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-native-volume-monitor. Expected type is GNativeVolumeMonitor.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyVolumeMonitorAfc'.
(thunderbird-bin:20882): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-volume-monitor. Expected type is GVolumeMonitor.
(thunderbird-bin:20882): GLib-GObject-WARNING **: Two different plugins tried to register 'GProxyVolumeMonitorGPhoto2'.
(thunderbird-bin:20882): GLib-GIO-WARNING **: Tried to register an extension of the type (null) to extension point gio-volume-monitor. Expected type is GVolumeMonitor.
(thunderbird-bin:20882): GLib-GObject-WARNING **: invalid class cast from `GProxyVolumeMonitorGdu' to `<invalid>'
(thunderbird-bin:20882): GLib-GObject-WARNING **: invalid class cast from (NULL) pointer to `<invalid>'
(thunderbird-bin:20882): GLib-GObject-CRITICAL **: g_type_class_peek_parent: assertion `g_class != NULL' failed
(thunderbird-bin:20882): GLib-GObject-WARNING **: invalid class cast from (NULL) pointer to `GObject'
Neoprávněný přístup do paměti (SIGSEGV)

Steps to reproduce:

Try to save/open a file in Firefox/Thunderbird.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 15 June 2011, 14:06 GMT
Reason for closing:  Not a bug
Additional comments about closing:  at least not in our packages
Comment by Ionut Biru (wonder) - Tuesday, 14 June 2011, 18:18 GMT
paste pacman -Qm, DAEMONS from rc.conf and at least what graphical environment do you have
Comment by Jelle van der Waa (jelly) - Tuesday, 14 June 2011, 19:30 GMT
Are you using testing or not?
Comment by Andrej Podzimek (andrej) - Tuesday, 14 June 2011, 20:40 GMT
The output from pacman -Qm is attached.
DAEMONS=(microcode irqbalance cpufreq andrej_hdparm syslog-ng dbus bluetooth kdm ip6tables iptables @rpcbind @fam @nfs-common network @net-profiles @net-auto-wireless @zfs-fuse @netfs @crond @alsa @osspd @cups @ntpd)
I use KDE.
No, I don't use 'testing'.

BTW, Chromium is also affected. An attempt to open a file leads to a crash.
As for Evolution, the console output is identical, but it crashes before displaying the main window rather than due to a file dialog.
   Qm (2.3 KiB)
Comment by Ionut Biru (wonder) - Tuesday, 14 June 2011, 20:50 GMT
there is something in your system that breaks glib2/gio and two packages tries to load the same plugins. I blame glib2-ubuntu but you have a lot more crap installed and i cannot decide whose fault is
Comment by Andrej Podzimek (andrej) - Wednesday, 15 June 2011, 11:46 GMT
Yes, removing some of the stale AUR packages solved the problem. Thank you for the suggestion. (It would be nice to have an automatic update mechanism for AUR packages integrated into srcpac... AUR packages can easily become outdated, which is what happened in this case.)

Loading...