Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24699 - [splix, cups] "SpliX Cannot get input slot information."

Attached to Project: Community Packages
Opened by MichaƂ Gawron (olimp) - Sunday, 12 June 2011, 17:46 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 17 May 2012, 14:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andreas Radke (AndyRTR)
Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Printing stopped working after system upgrade.
I'm using Samsung ML-1640 and CUPS. When I try to print something, there's a "SpliX Cannot get input slot information." text beside the printing job on CUPS page.

Additional info:
* package version(s)
cups-1.4.6-3
splix-2.0.0-9
* config and/or log files etc.

Contents of /var/log/cups:

E [12/Jun/2011:19:43:08 +0200] [Job 482] SpliX Cannot get input slot information.

Steps to reproduce:

Upgrade OS.
Try to print any PDF from Okular using Samsung ML-1640.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 17 May 2012, 14:57 GMT
Reason for closing:  Fixed
Comment by Jelle van der Waa (jelly) - Sunday, 12 June 2011, 20:07 GMT
nevermind
Comment by Alexey (Llama) - Sunday, 26 June 2011, 16:08 GMT
Confirmed. Any hope or workaround?

Printer Xerox Phaser 3117, SpliX, set according to ArchWiki CUPS article, without hal-cups-utils. Worked until an upgrade. It's able to print one test page, though; then dies. Even the only successful job gets labeled "SpliX Cannot get input slot information".
Comment by Sergej Pupykin (sergej) - Monday, 27 June 2011, 10:05 GMT
It is strange, here are changes from latest update:
-pkgrel=8
+pkgrel=9
-makedepends=('libcups' 'jbigkit')
+makedepends=('libcups' 'jbigkit' 'krb5')

Unfortunately I have no proper hardware.
Comment by ema (emamarro) - Saturday, 02 July 2011, 09:08 GMT
Have same problem with my ML-1640
I have solved like this:

cd /usr/lib/cups/filter
ln -s gstoraster pstoraster

see thread here:
http://www.fedoraforum.org/forum/showthread.php?p=1485349
Comment by Sergej Pupykin (sergej) - Monday, 04 July 2011, 10:54 GMT
symlink was added to package,
please check splix-2.0.0-10
Comment by Alexey (Llama) - Thursday, 12 January 2012, 21:31 GMT
The "SpliX Cannot get input slot information" is back again.Symlinks appear to be in order.
Comment by Giuseppe Borzi (gborzi) - Friday, 20 January 2012, 14:43 GMT
Same problem for me today, until two days ago it was working. I tried to solve the problem by deleting my only printer (Samsung ML-1520) and re-adding it, but the addition of a new printer fails with an error message saying cups doesn't find a driver. I sort of solved this problem by uninstalling splix and configuring the printer with foomatic. Without splix cups works, so perhaps it is a splix bug.
Comment by Natanji (Natanji) - Monday, 27 February 2012, 11:42 GMT
Also happens for me on Samsung CLP-510.

Severity should be set higher because this effectively breaks printing.
Comment by Alejandro Mansilla (c0r0nel) - Monday, 12 March 2012, 22:22 GMT
Hi, im having this problem again. After some of the recent upgrades cups start saying the message "SpliX Cannot get input slot information" again and job is not printed.
I have a Samsung ML1640 printer and Archlinux stable.
I've tryed also with the package splix-svn from aur but the printer is not detected when i try to install from cups web interface.
Comment by jozef riha (jose1711) - Monday, 16 April 2012, 19:48 GMT
i also spotted the "slot" error with usblp and samsung scx4300 after an upgrade. i removed cups-usblp and installed regular cups and aur/samsung-scx4200 basically replacing splix driver with unified samsung driver. so far it works.
Comment by Raphael Groner (k0Do) - Wednesday, 18 April 2012, 20:20 GMT
This is a "me too".

I use an Samsung ML-1640, connected over Ethernet socket. Printing worked till the day before yesterday, I remember made a big update to a lot of packages.
Comment by Minniakhmetov (Lamppost) - Wednesday, 18 April 2012, 20:39 GMT
Same problem on Samsung SCX-4200 with cups-usblp
Comment by Raphael Groner (k0Do) - Wednesday, 18 April 2012, 20:48 GMT
I switched my printer off for some seconds. My FritzBox had time to reinitialize the printer that is connected via USB to that Ethernet router. After switched the printer online again, I can print successfully again. Maybe cause of running out of paper error, cups can not detect that status from the printer.
Comment by Minniakhmetov (Lamppost) - Sunday, 29 April 2012, 13:18 GMT
I built cups with --disable-libusb and this fix the problem on Samsung SCX-4200

Loading...