Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24692 - nm-applet: WARNING **: Failed to add new connection: (32) Insufficient privileges.

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Saturday, 11 June 2011, 20:45 GMT
Last edited by Ionut Biru (wonder) - Sunday, 12 June 2011, 17:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Current version of NetworkManager (Gnome interface) has been unable to add wireless connections except as root for some time now. Error printed on the console is:

** (nm-applet:780): WARNING **: Failed to add new connection: (32) Insufficient privileges.

I am a member of the "network" group; I don't know what other permissions it wants. I searched Google and cannot find references to the problem other than in one Arch forum thread, which suggests to me that it may be an Arch-specific issue. But I would not know.

I am using XFCE if that makes a difference.

Forum thread: https://bbs.archlinux.org/viewtopic.php?pid=931196

Additional info:

Last package versions that work:
networkmanager 0.8.3-0.20110113
network-manager-applet 0.8.2-4

Current versions, which do not work:
networkmanager 0.8.9997-1
network-manager-applet 0.8.9997-1

Steps to reproduce:

Click on the network manager icon in the system tray.
Choose "connect to hidden wireless network".
Enter the network name, security type (in this case WPA & WPA2 personal), and password.
Click on connect. At this point the dialog closes, the error mentioned earlier is printed in the console, and NetworkManager does not even attempt to connect.
This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 12 June 2011, 17:32 GMT
Reason for closing:  Not a bug
Additional comments about closing:  polkit-gnome was disabled from autoload
Comment by Jan de Groot (JGC) - Sunday, 12 June 2011, 09:45 GMT
You need a polkit agent to get permissions. Networkmanager no longer support user-specific connections, only system-wide connections. If you don't have a polkit agent running you won't get permission to change the network configuration.
Comment by John Lindgren (jlindgren) - Sunday, 12 June 2011, 17:04 GMT
Okay, thanks for the (minimal) info -- I still don't know what a "polkit agent" is, beyond that it's a process that magically gives me additional permissions when I run it. I've tried to document the little that I do understand about this on the wiki, so that other users having the same problem will be able to fix it: https://wiki.archlinux.org/index.php/NetworkManager#Set_up_PolicyKit_permissions.
Comment by Ionut Biru (wonder) - Sunday, 12 June 2011, 17:13 GMT
install polkit-gnome
Comment by John Lindgren (jlindgren) - Sunday, 12 June 2011, 17:22 GMT
I do have it installed; I had disabled it in "autostarted applications" because there was no description of what it actually does. In particular, there was nothing to connect it with NetworkManager.

If you tell me I should have left it enabled because I did not know what it did, well, that is the attitude of an Windows or Ubuntu user. And I think that goes against the Arch principle of keeping "every component of the system ... 100% transparent".
Comment by John Lindgren (jlindgren) - Sunday, 12 June 2011, 17:23 GMT
(This report can be closed, btw. I think the Wiki now sufficiently documents what needs to be done to get NetworkManager working.)
Comment by Ionut Biru (wonder) - Sunday, 12 June 2011, 17:27 GMT
please add this info to the wiki that polkit-gnome needs to be installed.
Comment by John Lindgren (jlindgren) - Sunday, 12 June 2011, 17:28 GMT
I already did, take a look. :)

Loading...