Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#24671 - [enchant] add hspell as optional dependence

Attached to Project: Arch Linux
Opened by jwbirdsong (jwbirdsong) - Friday, 10 June 2011, 21:02 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 11 June 2011, 20:51 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Running any (it seems) webkit broswer for term gives
** (luakit:26550): WARNING **: Error loading plugin: cannot open shared object file: No such file or directory
same for uzbl-browser, midori, jumanji

Additional info:
* package version(s)
enchant 1.6.0-2

Should we (you) either
1) Add hspell as dep
2) Use --disable-hspell flag and expect users who use Herbew to rebuild via ABS
3) Forget I filed this bug.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 11 June 2011, 20:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  enchant 1.6.0-3
Comment by jwbirdsong (jwbirdsong) - Saturday, 11 June 2011, 03:00 GMT
sux you can't edit orig. post/report.

Not sure I like ANY of the options I offered; hope there are more.
2 ) Use --disable-hspell flag
a) expect users who use Herbew to rebuild via ABS
b) Offer enchant-hebrew (possibly in AUR)

PLEASE someone add to this list.
Comment by Thomas Dziedzic (tomd123) - Saturday, 11 June 2011, 19:44 GMT
I don't know if this was supposed to be assigned to me.
luakit doesn't link to hspell directly, but instead, enchant does.

/usr/lib/enchant/ is owned by enchant, so I think hspell should be added as an optdepend for enchant and not each individual browser that uses enchant.
Comment by jwbirdsong (jwbirdsong) - Saturday, 11 June 2011, 19:51 GMT
td123 Prolly my fault... guess title could have been clearer.
Although I did meantion enchant related errors & enchant 1.6.0-2 in package version.
'Add hspell as dep' and the ' --disable-hspel' l were pointed at enchant although I guess I didn't make that clear.
Sorry for vagueness

Almost posted something when they changed catagory to community and assigned you.
Just didn't want to get branded as troublemaker.. hehe