Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24665 - pitivi: ImportError: No module named xdg.BaseDirectory

Attached to Project: Community Packages
Opened by John Lindgren (jlindgren) - Friday, 10 June 2011, 15:44 GMT
Last edited by Jelle van der Waa (jelly) - Sunday, 12 June 2011, 21:09 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Pitivi will not start and gives this output:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Traceback (most recent call last):
File "/usr/bin/pitivi", line 143, in <module>
_run_pitivi()
File "/usr/bin/pitivi", line 131, in _run_pitivi
import pitivi.application as ptv
File "/usr/lib/pitivi/python/pitivi/application.py", line 45, in <module>
from pitivi.settings import GlobalSettings
File "/usr/lib/pitivi/python/pitivi/settings.py", line 31, in <module>
import xdg.BaseDirectory as xdg_dirs # Freedesktop directories spec
ImportError: No module named xdg.BaseDirectory

Just guessing, perhaps this is caused by a missing dependency?

Additional info:

pitivi 0.14.0-1
gstreamer0.10 0.10.34-1

Steps to reproduce:

Run "pitivi".
This task depends upon

Closed by  Jelle van der Waa (jelly)
Sunday, 12 June 2011, 21:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  added pyxdg as dep
Comment by Ionut Biru (wonder) - Friday, 10 June 2011, 16:13 GMT
yes, it needs pyxdg

Loading...