Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24657 - [vlc] Won't start

Attached to Project: Arch Linux
Opened by Mr. K. (KitchM) - Thursday, 09 June 2011, 19:39 GMT
Last edited by Giovanni Scafora (giovanni) - Thursday, 16 June 2011, 14:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:VLC won't start


Additional info:
* package version(s)1.1.10
* config and/or log files etc. vlc -vvv reports:
VLC media player 1.1.10 The Luggage (revision exported)
[0x80dc8fc] main libvlc debug: VLC media player - 1.1.10 The Luggage
[0x80dc8fc] main libvlc debug: Copyright © 1996-2011 the VideoLAN team
[0x80dc8fc] main libvlc debug: revision exported
[0x80dc8fc] main libvlc debug: configured with ./configure '--prefix=/usr' '--disable-rpath' '--enable-faad' '--enable-v4l' '--enable-snapshot' '--enable-dbus-control' '--enable-nls' '--enable-lirc' '--enable-pvr' '--enable-ncurses' '--with-live555-tree=/usr/lib/live' '--enable-upnp' '--enable-realrtsp' 'CFLAGS=-march=i686 -mtune=generic -O2 -pipe' 'LDFLAGS=-Wl,--hash-style=gnu -Wl,--as-needed' 'CXXFLAGS=-march=i686 -mtune=generic -O2 -pipe'
[0x80dc8fc] main libvlc debug: translation test: code is "C"
[0x80dc8fc] main libvlc debug: checking plugin modules
[0x80dc8fc] main libvlc debug: loading plugins cache file /usr/lib/vlc/plugins/plugins-04041e-38.dat
[0x80dc8fc] main libvlc debug: recursively browsing `/usr/lib/vlc/plugins'
[0x80dc8fc] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/meta_engine/libtaglib_plugin.so' (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/vlc/plugins/meta_engine/libtaglib_plugin.so))
[0x80dc8fc] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/gui/libskins2_plugin.so' (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/vlc/plugins/gui/libskins2_plugin.so))
[0x80dc8fc] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/mux/libmux_ts_plugin.so' (libdvbpsi.so.7: cannot open shared object file: No such file or directory)
[0x80dc8fc] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/demux/libts_plugin.so' (libdvbpsi.so.7: cannot open shared object file: No such file or directory)
[0x80dc8fc] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/access/libdvb_plugin.so' (libdvbpsi.so.7: cannot open shared object file: No such file or directory)
[0x80dc8fc] main libvlc debug: saving plugins cache /usr/lib/vlc/plugins/plugins-04041e-38.dat
[0x80dc8fc] main libvlc debug: module bank initialized (390 modules)
[0x80dc8fc] main libvlc debug: opening config file (/home/mpk/.config/vlc/vlcrc)
[0x80dc8fc] main libvlc debug: CPU has capabilities MMX 3DNow! MMXEXT FPU
[0x80dc8fc] main libvlc debug: looking for memcpy module: 4 candidates
[0x80dc8fc] main libvlc debug: using memcpy module "memcpymmxext"
[0x82acc1c] main input debug: Creating an input for 'Media Library'
[0x82acc1c] main input debug: Input is a meta file: disabling unneeded options
[0x82acc1c] main input debug: using timeshift granularity of 50 MiB
[0x82acc1c] main input debug: using timeshift path '/tmp'
[0x82acc1c] main input debug: `file/xspf-open:///home/mpk/.local/share/vlc/ml.xspf' gives access `file' demux `xspf-open' path `/home/mpk/.local/share/vlc/ml.xspf'
[0x82acc1c] main input debug: creating demux: access='file' demux='xspf-open' path='/home/mpk/.local/share/vlc/ml.xspf'
[0x82a9164] main demux debug: looking for access_demux module: 2 candidates
[0x82a9164] main demux debug: no access_demux module matching "file" could be loaded
[0x82a9164] main demux debug: TIMER module_need() : 0.715 ms - Total 0.715 ms / 1 intvls (Avg 0.715 ms)
[0x82acc1c] main input debug: creating access 'file' path='/home/mpk/.local/share/vlc/ml.xspf'
[0x82a9154] main access debug: looking for access module: 2 candidates
[0x82a9154] filesystem access debug: opening file `/home/mpk/.local/share/vlc/ml.xspf'
[0x82a9154] main access debug: using access module "filesystem"
[0x82a9154] main access debug: TIMER module_need() : 0.303 ms - Total 0.303 ms / 1 intvls (Avg 0.303 ms)
[0x82aa7dc] main stream debug: Using AStream*Stream
[0x82aa7dc] main stream debug: pre buffering
[0x82aa7dc] main stream debug: received first data after 0 ms
[0x82aa7dc] main stream debug: pre-buffering done 296 bytes in 0s - 4738 KiB/s
[0x82a934c] main stream debug: looking for stream_filter module: 5 candidates
[0x82a934c] main stream debug: no stream_filter module matching "any" could be loaded
[0x82a934c] main stream debug: TIMER module_need() : 0.212 ms - Total 0.212 ms / 1 intvls (Avg 0.212 ms)
[0x82a934c] main stream debug: looking for stream_filter module: 1 candidate
[0x82a934c] main stream debug: using stream_filter module "stream_filter_record"
[0x82a934c] main stream debug: TIMER module_need() : 0.175 ms - Total 0.175 ms / 1 intvls (Avg 0.175 ms)
[0x82acc1c] main input debug: creating demux: access='file' demux='xspf-open' path='/home/mpk/.local/share/vlc/ml.xspf'
[0x82a94c4] main demux debug: looking for demux module: 1 candidate
[0x82a94c4] playlist demux debug: using XSPF playlist reader
[0x82a94c4] main demux debug: using demux module "playlist"
[0x82a94c4] main demux debug: TIMER module_need() : 0.236 ms - Total 0.236 ms / 1 intvls (Avg 0.236 ms)
[0x82a96fc] main demux meta debug: looking for meta reader module: 1 candidate
[0x82a96fc] lua demux meta debug: Trying Lua scripts in /home/mpk/.local/share/vlc/lua/meta/reader
[0x82a96fc] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/reader
[0x82a96fc] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/reader/filename.luac
[0x82a96fc] lua demux meta debug: Trying Lua scripts in /usr/share/vlc/lua/meta/reader
[0x82a96fc] main demux meta debug: no meta reader module matching "any" could be loaded
[0x82a96fc] main demux meta debug: TIMER module_need() : 2.475 ms - Total 2.475 ms / 1 intvls (Avg 2.475 ms)
[0x82acc1c] main input debug: `file/xspf-open:///home/mpk/.local/share/vlc/ml.xspf' successfully opened
[0x8172904] main xml debug: looking for xml module: 2 candidates
[0x8172904] main xml debug: using xml module "xml"
[0x8172904] main xml debug: TIMER module_need() : 1.087 ms - Total 1.087 ms / 1 intvls (Avg 1.087 ms)
[0x82a94c4] playlist demux debug: parsed 0 tracks successfully
[0x8172904] main xml debug: removing module "xml"
[0x82acc1c] main input debug: EOF reached
[0x82a94c4] main demux debug: removing module "playlist"
[0x82a934c] main stream debug: removing module "stream_filter_record"
[0x82a9154] main access debug: removing module "filesystem"
[0x82acc1c] main input debug: TIMER input launching for 'Media Library' : 19.903 ms - Total 19.903 ms / 1 intvls (Avg 19.903 ms)
[0x82a94c4] main interface debug: looking for interface module: 1 candidate
[0x82a94c4] main interface debug: using interface module "hotkeys"
[0x82a94c4] main interface debug: TIMER module_need() : 0.464 ms - Total 0.464 ms / 1 intvls (Avg 0.464 ms)
[0x82acc1c] main interface debug: looking for interface module: 1 candidate
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x82a8434] main playlist debug: Activated
[0x82acc1c] main interface debug: using interface module "inhibit"
[0x82acc1c] main interface debug: TIMER module_need() : 21.426 ms - Total 21.426 ms / 1 intvls (Avg 21.426 ms)
[0x82aa85c] main interface debug: looking for interface module: 1 candidate
[0x82aa85c] main interface debug: using interface module "signals"
[0x82aa85c] main interface debug: TIMER module_need() : 0.636 ms - Total 0.636 ms / 1 intvls (Avg 0.636 ms)
[0x82abd6c] main interface debug: looking for interface module: 1 candidate
[0x82a8434] main playlist debug: rebuilding array of current - root Playlist
[0x82a8434] main playlist debug: rebuild done - 0 items, index -1
[0x82abd6c] main interface debug: using interface module "globalhotkeys"
[0x82abd6c] main interface debug: TIMER module_need() : 16.050 ms - Total 16.050 ms / 1 intvls (Avg 16.050 ms)
[0x82a7ccc] main interface debug: looking for interface module: 0 candidates
[0x82a7ccc] main interface debug: no interface module matched "skins2"
[0x82a7ccc] main interface debug: TIMER module_need() : 0.495 ms - Total 0.495 ms / 1 intvls (Avg 0.495 ms)
[0x82a7ccc] main interface error: no suitable interface module
[0x80dc8fc] main libvlc error: interface "default" initialization failed
[0x80dc8fc] main libvlc debug: deactivating the playlist
[0x82a8434] main playlist debug: Deactivate
[0x82a7d34] main playlist export debug: saving Media Library to file /home/mpk/.local/share/vlc/ml.xspf
[0x82a7d34] main playlist export debug: looking for playlist export module: 1 candidate
[0x82a7d34] main playlist export debug: using playlist export module "export"
[0x82a7d34] main playlist export debug: TIMER module_need() : 0.359 ms - Total 0.359 ms / 1 intvls (Avg 0.359 ms)
[0x82a7d34] main playlist export debug: removing module "export"
[0x82a8434] main playlist debug: Deactivated
[0x80dc8fc] main libvlc debug: removing all services discovery tasks
[0x80dc8fc] main libvlc debug: removing all interfaces
[0x82abd6c] main interface debug: removing module "globalhotkeys"
[0x82aa85c] main interface debug: removing module "signals"
[0x82acc1c] main interface debug: removing module "inhibit"
[0x82a94c4] main interface debug: removing module "hotkeys"
[0x82a8434] main playlist debug: destroying
[0x80dc8fc] main libvlc debug: TIMER ML Load : Total 22.168 ms / 1 intvls (Avg 22.168 ms)
[0x80dc8fc] main libvlc debug: TIMER Items array build : Total 0.237 ms / 1 intvls (Avg 0.237 ms)
[0x80dc8fc] main libvlc debug: TIMER ML Dump : Total 0.896 ms / 1 intvls (Avg 0.896 ms)
[0x80dc8fc] main libvlc debug: removing stats
[0x80dc8fc] main libvlc debug: removing module "memcpymmxext"



Steps to reproduce:Just try to start it.
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Thursday, 16 June 2011, 14:44 GMT
Reason for closing:  Works for me
Comment by Ionut Biru (wonder) - Thursday, 09 June 2011, 20:34 GMT
don't build packages against testing and push them in extra

main libvlc warning: cannot load module `/usr/lib/vlc/plugins/meta_engine/libtaglib_plugin.so' (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/vlc/plugins/meta_engine/libtaglib_plugin.so))
Comment by Giovanni Scafora (giovanni) - Thursday, 09 June 2011, 22:36 GMT
Hey Ionut, keep calm, I built it against extra not against testing!!!
Maybe I used staging (staging includes testing repo) building vlc-1.1.10-1 due a small rebuild against new libdvbpsi, but I'm sure 100% that I built vlc-1.1.10-2 against extra on our build server with sudo extra-i686-build and sudo extra-x86_64-build commands.
In fact, I'm using vlc-1.1.10-2 just now and it works fine (BTW vlc-1.1.10-1 worked fine too) on my local machine where I never used testing repo.
Mr. K. (KitchM) are you using vlc-1.1.10-2 or vlc-1.1.10-1?
If you are using the old one, please upgrade your system and let me know, so I can close this bug (?) report.
The next time, please upgrade your system before filling a bug report and also specify the release (pkgrel) of package.
Thanks.
Comment by Ionut Biru (wonder) - Saturday, 11 June 2011, 16:17 GMT
@KitchM do pacman -Qo /usr/lib/libstdc++.so.6 and paste the output

Loading...