Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#24652 - Newest VLC causes pacman segmentation fault

Attached to Project: Pacman
Opened by carlos sosa (csosa) - Thursday, 09 June 2011, 16:48 GMT
Last edited by Dan McGee (toofishes) - Thursday, 09 June 2011, 20:21 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.5.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
"sudo pacman -Sy vlc --debug"

debug: adding database entry 'vlc'
debug: writing vlc-1.1.10-2 DESC information back to db
debug: writing vlc-1.1.10-2 FILES information back to db
debug: adding entry 'vlc' in 'local' cache
debug: executing ". /tmp/alpm_Rf9JYD/.INSTALL; post_upgrade 1.1.10-2 1.1.10-2"
debug: executing "/bin/sh" under chroot "/"
/tmp/alpm_Rf9JYD/.INSTALL: line 1: 1940 Segmentation fault usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins


Steps to Reproduce:
Install VLC 1.1.10-2


This task depends upon

Closed by  Dan McGee (toofishes)
Thursday, 09 June 2011, 20:21 GMT
Reason for closing:  Won't fix
Additional comments about closing:  VLC issue, not pacman issue
Comment by Dan McGee (toofishes) - Thursday, 09 June 2011, 17:07 GMT
Pacman isn't segfaulting; the program called by the install script is. Does this kill the install process completely? You haven't given enough info here; perhaps attach the full debug log.
Comment by Karol Błażewicz (karol) - Thursday, 09 June 2011, 17:55 GMT
You shouldn't be running 'pacman -Sy foo' but 'pacman -S foo'.
Comment by Dan McGee (toofishes) - Thursday, 09 June 2011, 17:56 GMT
Karol, I appreciate you trying to help but that really has no bearing on what we are seeing here- a segfault is a segfault, and even if deps were broken and wrong library versions existed you shouldn't be seeing this.
Comment by Karol Błażewicz (karol) - Thursday, 09 June 2011, 18:12 GMT
I didn't want to imply that 'pacman -Sy foo' is causing those problems, I'll try to phrase things better next time. And yeah, if it's not relevant to the issue you're trying to deal with, I shouldn't have posted it at all.

Sorry.
Comment by carlos sosa (csosa) - Thursday, 09 June 2011, 20:14 GMT
Attached is the full log.

Here is the end:

debug: updating database
debug: adding database entry 'vlc'
debug: writing vlc-1.1.10-2 DESC information back to db
debug: writing vlc-1.1.10-2 FILES information back to db
debug: adding entry 'vlc' in 'local' cache
debug: executing ". /tmp/alpm_E8tvLl/.INSTALL; post_upgrade 1.1.10-2 1.1.10-2"
debug: executing "/bin/sh" under chroot "/"
/tmp/alpm_E8tvLl/.INSTALL: line 1: 10379 Segmentation fault usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins
debug: call to waitpid succeeded
debug: running ldconfig
debug: executing "/sbin/ldconfig" under chroot "/"
debug: call to waitpid succeeded
debug: unregistering database 'local'
debug: freeing package cache for repository 'local'
debug: unregistering database 'testing'
debug: freeing package cache for repository 'testing'
debug: unregistering database 'core'
debug: freeing package cache for repository 'core'
debug: unregistering database 'extra'
debug: freeing package cache for repository 'extra'
debug: unregistering database 'community-testing'
debug: unregistering database 'community'
debug: unregistering database 'multilib'

Since pacman isn't segfaulting, is there a more appropriate place to submit this?
Comment by Dan McGee (toofishes) - Thursday, 09 June 2011, 20:21 GMT
Yes, to either the VLC maintainer or more than likely upstream to VLC devs. Run the `/usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins` command directly as root and see if it always segfaults, which it should.
Comment by Dan McGee (toofishes) - Thursday, 09 June 2011, 20:44 GMT
This is reported as  FS#24657  as well.

Loading...