Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24577 - [git] git-svn broken after last update

Attached to Project: Arch Linux
Opened by Ismael Barros (RazZziel) - Saturday, 04 June 2011, 19:06 GMT
Last edited by Stéphane Gaudreault (stephane) - Saturday, 04 June 2011, 23:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dan McGee (toofishes)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Among others, in last update these packages were installed:

[2011-06-04 15:44] upgraded perl-crypt-ssleay (0.58-2 -> 0.58-3)
[2011-06-04 15:44] upgraded perl-digest-sha1 (2.13-1 -> 2.13-2)
[2011-06-04 15:44] upgraded perl-html-parser (3.68-1 -> 3.68-2)
[2011-06-04 15:44] upgraded perl-net-ssleay (1.36-4 -> 1.36-5)
[2011-06-04 15:44] upgraded perl-term-readkey (2.30.01-3 -> 2.30.01-4)
[2011-06-04 15:44] upgraded perl-unicode-string (2.09-5 -> 2.09-6)
[2011-06-04 15:44] upgraded perl-xml-parser (2.40-2 -> 2.40-3)
[2011-06-04 15:45] upgraded subversion (1.6.15-2 -> 1.6.17-3)

Now, whey I try to run git svn fetch or git svn rebase, I get this error:

Bizarre copy of UNKNOWN in subroutine entry at /usr/lib/perl5/vendor_perl/SVN/Base.pm line 80.

If I downgrade SVN to version 1.6.15-2-i686, when I try again to run git svn fetch I get:

/usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/auto/SVN/_Core/_Core.so: undefined symbol: Perl_Gthr_key_ptr
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Saturday, 04 June 2011, 23:26 GMT
Reason for closing:  Duplicate
Additional comments about closing:  I am closing this as a duplicate of  FS#24540 . For the severity, do not worry, this issue is important for us as it may prevent perl 5.14 to be moved into extra.
Comment by Stéphane Gaudreault (stephane) - Saturday, 04 June 2011, 22:37 GMT
Looks like a duplicate of  FS#24540 .
Comment by Ismael Barros (RazZziel) - Saturday, 04 June 2011, 22:46 GMT
Indeed, looks like a duplicate; although the severity is pretty critical at least for me, my work is stalled because of this bug :\

Loading...