Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#24539 - [gvfs] gvfsd-http leaks file handles

Attached to Project: Arch Linux
Opened by Jed Brown (jedbrown) - Wednesday, 01 June 2011, 23:18 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 03:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Original symptom:
Rhythmbox podcast feeds could not be updated because it was "unable to parse feed contents".

Investigating further:

$ gvfs-info valid-feed-url

fails due to

Error getting info: Error while getting peer-to-peer dbus connection: Failed to create new socket: Failed to open socket: Too many open files

lsof shows that gvfsd-http has 3192 open files. After killing gvfs (and restarting rhythmbox), everything works again.

Additional info:

Steps to Reproduce:

I haven't restarted in 10 days, this problem started almost a week ago and I ignored it until today.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 03:14 GMT
Reason for closing:  Upstream
Comment by Ionut Biru (wonder) - Thursday, 02 June 2011, 07:12 GMT
can you please report this upstream?
Comment by Jed Brown (jedbrown) - Saturday, 04 June 2011, 18:12 GMT