Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#24490 - [pyqt] [python2-pyqt] Trow "Inconsistency detected by"

Attached to Project: Arch Linux
Opened by Kazuo Teramoto (kazuo) - Saturday, 28 May 2011, 22:19 GMT
Last edited by Andrea Scarpino (BaSh) - Sunday, 29 May 2011, 12:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



When I try to import pyqt using any of the following:

$ python2 -c 'import qt'
$ python2 -c 'import PyQt4.Qt'
$ python -c 'import PyQt4.Qt'

I get:
Inconsistency detected by dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!

This happen with pyqt apps, calibre trows the error when "Saving to disk".

The packages version are:
extra/pyqt 4.8.4-1
extra/python2-pyqt 4.8.4-1
community/pyqt3 3.18.1-9

I'm fully update as today (28.05.2011) (testing and multilib enabled).

This task depends upon

Closed by  Andrea Scarpino (BaSh)
Sunday, 29 May 2011, 12:03 GMT
Reason for closing:  Not a bug
Additional comments about closing:  bus is caused by the nvidia binary
Comment by Andrea Scarpino (BaSh) - Sunday, 29 May 2011, 10:26 GMT
Works here.

$ python2 -c 'import PyQt4.Qt'
$ python -c 'import PyQt4.Qt'

$ pacman -Q pyqt python2-pyqt
pyqt 4.8.4-1
python2-pyqt 4.8.4-1
Comment by Kazuo Teramoto (kazuo) - Sunday, 29 May 2011, 11:56 GMT
Of course the user is always wrong =]

The problem is the new nvidia beta package, so "not a bug". I'm gonna look if it's a packaging error by me or an upstream bug, and report to them.

Thanks Andrea, and sorry for the noise.