Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24463 - [kernel26] Important UEFI related kernel patches

Attached to Project: Arch Linux
Opened by Anonymous Submitter - Friday, 27 May 2011, 06:48 GMT
Last edited by Andrea Scarpino (BaSh) - Sunday, 24 July 2011, 22:43 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Many newer UEFI systems like Dell Latitude laptops, Lenovo Thinkpads and the Sandy Bridge desktop motherboards all come with x86_64 UEFI firmware. However they fail to linux (even recent kernels) due to various bugs in the firmware as well as few bugs in the kernel. A series of patches is being added to 2.6.40/3.0/whatever kernel. I request that these patches be added to the kernel26 package in core.

The patches are (to be applied in order) -

x86, efi: Remove virtual-mode SetVirtualAddressMap call - http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=2b5e8ef35bc89eee944c0627edacbb1fea5a1b84
x86, efi: Consolidate EFI nx control - http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=9cd2b07c197e3ff594fc04f5fb3d86efbeab6ad8
x86, efi: Merge contiguous memory regions of the same type and attribute - http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=202f9d0a41809e3424af5f61489b48b622824aed
x86, efi: Pass a minimal map to SetVirtualAddressMap() - http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=7cb00b72876ea2451eb79d468da0e8fb9134aa8a
x86, efi: Ensure that the entirity of a region is mapped - http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=935a638241b0658b9749edd060f972575f9d4a78
x86, efi: Retain boot service code until after switching to virtual mode - http://git.kernel.org/?p=linux/kernel/git/tip/linux-2.6-tip.git;a=commit;h=916f676f8dc016103f983c7ec54c18ecdbb6e349

Additional info:
* package version(s)
* config and/or log files etc.

https://bbs.archlinux.org/viewtopic.php?pid=939413#p939413

Steps to reproduce:
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Sunday, 24 July 2011, 22:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 3.0-1
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 27 May 2011, 17:41 GMT
Send this to maintainer (Greg-KH) of -stable [#1] tree of Linux. Maybe can be included in future 2.6.39.X or 2.6.38.X.

[#1] http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git;a=summary
Comment by Thomas Bächler (brain0) - Friday, 27 May 2011, 17:49 GMT
Actually, the maintainer needs to submit the patches to Greg.

I don't feel comfortable backporting such a large number of commits (they might cause problems in current kernels). Check if those patches have been queued up for -stable already. If not, send an email to hpa, CC:Greg and CC:stable@kernel.org, and ask for inclusion.
Comment by Anonymous Submitter - Friday, 27 May 2011, 18:07 GMT
The last commit (Retain Boot Service code) has the following message -

[ hpa: adding this to urgent with a stable tag since it fixes currently-broken
hardware. However, I do not know what the dependencies are and so I do
not know which -stable versions this may be a candidate for. ]

Does this mean this will be added to -stable kernels automatically? I sent a email to greg@kroah.com directly but not to LKML as I am not subscribed to it and my email might be overshadowed by the large number of other (and rather important) mails.
Comment by Thomas Bächler (brain0) - Saturday, 28 May 2011, 08:48 GMT
This message means they're probably working on it. The patches are not on the stable-queue ([1]) yet, so let's wait for a few days and see what happens. Only the last patch is CC'd to stable though right now.

I understand that this slows down supporting these (now broken) motherboards. I'd like to be sure that these are the proper patches also for .38 and .39.

[1] http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git;a=tree;f=queue-2.6.39
Comment by Anonymous Submitter - Tuesday, 31 May 2011, 04:20 GMT
These patches are part of mainline kernel 3.0.0-rc1 ( https://bbs.archlinux.org/viewtopic.php?pid=941385#p941385 ). The 'Retain Boot Service Code' patch is in queue for 2.6.39.1 but its not clear whether the previous five patches are required for this patch.
Comment by Anonymous Submitter - Tuesday, 21 June 2011, 09:19 GMT
Please track the list of patches here - https://help.ubuntu.com/community/UEFIBooting#Kernel%20unbootable%20without%20noefi . I agree it is beyond the job of the kernel package maintainer to apply these patches to the current kernel. Discussion regarding UEFI support in kernel is at http://groups.google.com/group/linux.kernel/browse_thread/thread/9230ce8bb985917c/cc8a59229a9561aa?lnk=raot&pli=1 .

PS: Is it possible to implement https://patchwork.kernel.org/patch/865582/ in the kernel config manually for future packages (ie. CONFIG_RELOCATABLE=y). Relevant info at http://cateee.net/lkddb/web-lkddb/RELOCATABLE.html . Thanks in advance.

Loading...