FS#24446 - [kernel26] USB device not recognized any more

Attached to Project: Arch Linux
Opened by Martin Sand (sandstorm) - Wednesday, 25 May 2011, 21:46 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 08 June 2011, 19:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Suddenly my MP3 player is not recognized any more when connecting via USB. Several USB cables for connection used and connected to several Archlinux machines (32 and 64 bit installations). Problem can be confirmed on all machines.

Excerpt from /var/log/messages.log
kernel: [ 8399.007679] sd 15:0:0:0: [sdb] Assuming Write Enabled
kernel: [ 8399.112674] usb 1-4: reset high speed USB device using ehci_hcd and address 12
kernel: [ 8399.293124] usb 1-4: USB disconnect, address 12
kernel: [ 8399.294030] sd 15:0:0:0: [sdb] READ CAPACITY failed
kernel: [ 8399.294048] sd 15:0:0:0: [sdb] Result: hostbyte=0x01 driverbyte=0x00
kernel: [ 8399.294070] sd 15:0:0:0: [sdb] Sense not available.
kernel: [ 8399.294087] sd 15:0:0:0: [sdb] Assuming Write Enabled
kernel: [ 8399.294313] sdb: detected capacity change from 8205107200 to 0
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 08 June 2011, 19:44 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Thursday, 26 May 2011, 09:33 GMT
Are you sure that it is not broken? Did you try it with other distributions (live CDs) or Windows?
Comment by Martin Sand (sandstorm) - Thursday, 26 May 2011, 17:19 GMT
Tried it today on Windows XP. Works perfectly. File structure shown in Windows Explorer.
Comment by Jelle van der Waa (jelly) - Tuesday, 31 May 2011, 10:50 GMT
So how did this happen, updated kernel or libusb? Did you try to google or report upstream? It's not an issue we can fix
Comment by Martin Sand (sandstorm) - Tuesday, 31 May 2011, 17:38 GMT
My last update was on 27-April. Connection worked. I went on holidays and came back on 14-May, did an update including gnome-shell and it was broken. Funny is that it works perfectly on Windows XP including correct display of capacity.
Comment by Martin Sand (sandstorm) - Wednesday, 08 June 2011, 19:37 GMT
Works after today's kernel26 update and can be closed