Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24427 - startup-notification-0.12-1 results in claws-mail crash

Attached to Project: Arch Linux
Opened by Andrew Gaydenko (student975) - Tuesday, 24 May 2011, 21:57 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 25 May 2011, 11:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrading startup-notification from 0.10-2 to 0.12-1 claws-mail crashes on start. It's showstopper at my case, so I downgraded back to 0.10-2.
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 25 May 2011, 11:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  claws-mail-3.7.9-3
Comment by Ionut Biru (wonder) - Tuesday, 24 May 2011, 22:05 GMT
did you try to rebuild?
Comment by Ionut Biru (wonder) - Tuesday, 24 May 2011, 22:08 GMT Comment by Andrew Gaydenko (student975) - Tuesday, 24 May 2011, 22:11 GMT
I didn't. Do you mean claws-mail rebuilding?
Comment by Ionut Biru (wonder) - Tuesday, 24 May 2011, 22:11 GMT
yeah
Comment by Andrew Gaydenko (student975) - Tuesday, 24 May 2011, 22:21 GMT
Rebuilding results in the same bahavior. I'll try to prepare bt log.
Comment by Andrew Gaydenko (student975) - Tuesday, 24 May 2011, 22:31 GMT
The log:

Starting program: /usr/bin/claws-mail
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00007fffef844547 in XGetXCBConnection () from /usr/lib/libX11-xcb.so.1
#0 0x00007fffef844547 in XGetXCBConnection () from /usr/lib/libX11-xcb.so.1
#1 0x00007ffff561b2f1 in sn_display_new () from /usr/lib/libstartup-notification-1.so.0
#2 0x00000000004443de in ?? ()
#3 0x000000000044662c in main ()
Kill the program being debugged? (y or n)
Comment by Andrew Gaydenko (student975) - Tuesday, 24 May 2011, 23:36 GMT
Sorry, that trace is without debug info. This one is with:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffef844547 in XGetXCBConnection () from /usr/lib/libX11-xcb.so.1
#0 0x00007fffef844547 in XGetXCBConnection () from /usr/lib/libX11-xcb.so.1
#1 0x00007ffff561b2f1 in sn_display_new () from /usr/lib/libstartup-notification-1.so.0
#2 0x00000000004ee60c in startup_notification_complete (with_window=0) at main.c:335
#3 0x00000000004f1c81 in main (argc=1, argv=0x7fffffffe838) at main.c:1620
Comment by Ionut Biru (wonder) - Wednesday, 25 May 2011, 00:54 GMT Comment by Krishnan (kgas) - Wednesday, 25 May 2011, 02:41 GMT
I confirm this bug. claws-mail --debug results in crash with claws-mail: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0. message.
Comment by Arjan Nieuwenhuis (arjann) - Wednesday, 25 May 2011, 06:48 GMT
I also confirm this bug.
Comment by Ionut Biru (wonder) - Wednesday, 25 May 2011, 08:09 GMT
stop confirming and start looking.

is a bug in claws http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2414

going to include the fix now
Comment by Krishnan (kgas) - Wednesday, 25 May 2011, 11:21 GMT
It is fixed now with claws-mail-3.7.9-3. Thanks wonder.
Comment by Andrew Gaydenko (student975) - Wednesday, 25 May 2011, 11:25 GMT
@wonder

Thanks, the problem is resolved with claws-mail-3.7.9-3.

Loading...