Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#24422 - [kdelibs] kdex.dtd disappears from filesystem

Attached to Project: Arch Linux
Opened by Steve (stevek) - Tuesday, 24 May 2011, 17:07 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 30 May 2011, 22:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Firstly I'm not sure if this is a kdelibs bug, but kdex.dtd is part of kdelibs. When compiling it is discovered that kdex.dtd is not found in the file system and reinstalling the same version kdelibs replaces it. However over time it disappears again. The cause is unknown at this stage.

Additional info:
We discovered this compiling the AUR package here: An upstream bug was reported and closed as a downstream problem here:

Steps to reproduce:
Check to see if kdelibs is installed and /usr/share/apps/ksgmltools2/customization/dtd/kdex.dtd exists. On a fresh install it will be there, but on an older installation (say a month or so) it may not be.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 30 May 2011, 22:56 GMT
Reason for closing:  None
Additional comments about closing:  re-open if happen again
Comment by Andrea Scarpino (BaSh) - Tuesday, 24 May 2011, 17:36 GMT
I don't understand, /usr/share/apps/ksgmltools2/customization/dtd/kdex.dtd is there in kdelibs 4.6.3-2 and -1, where is the bug??
Comment by Steve (stevek) - Tuesday, 24 May 2011, 18:12 GMT
Yes that's correct, but something is causing it to be removed from the filesystem after a short period. Reinstalling kdelibs will replace it but it will disappear again. And no-one is removing it purposefully. Sorry I don't know how or why.