Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24381 - unable to play mp4 files since gstreamer update ?

Attached to Project: Arch Linux
Opened by hqet4 (hqet4) - Saturday, 21 May 2011, 20:08 GMT
Last edited by Jan de Groot (JGC) - Monday, 04 July 2011, 10:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

I recently upgraded my system and i cannot play mp4 files using gstreamer apps anymore.
This affects totem and totem-video-thumbnailer (so gnome video thumbnails are not generated for mp4 files anymore).
The relevant packages that were upgraded:
[2011-05-21 18:22] upgraded gstreamer0.10 (0.10.32-1 -> 0.10.34-1)
[2011-05-21 18:22] upgraded gstreamer0.10-base (0.10.32-4 -> 0.10.34-1)
[2011-05-21 18:22] upgraded gstreamer0.10-base-plugins (0.10.32-4 -> 0.10.34-1)
[2011-05-21 18:22] upgraded gstreamer0.10-good (0.10.28-1 -> 0.10.29-1)
[2011-05-21 18:22] installed gstreamer0.10-bad (0.10.22-1)
[2011-05-21 18:22] upgraded farsight2 (0.0.26-1 -> 0.0.28-2)
[2011-05-21 18:23] upgraded gstreamer0.10-good-plugins (0.10.28-1 -> 0.10.29-1)
[2011-05-21 18:23] upgraded gstreamer0.10-ugly (0.10.17-2 -> 0.10.18-1)
[2011-05-21 18:23] upgraded gstreamer0.10-ugly-plugins (0.10.17-2 -> 0.10.18-1)

When i invoke the video thumbnailer manually, here is what i get:

$ totem-video-thumbnailer somefile.mp4 out.png
** Message: Error: Your GStreamer installation is missing a plug-in.
gstdecodebin2.c(3233): gst_decode_bin_expose (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
no suitable plugins found

totem-video-thumbnailer couldn't open file 'somefile.mp4'
Reason: The playback of this movie requires a Quicktime demuxer plugin which is not installed..

I have gstreamer0.10-good (and good-plugins) installed and they are supposed to provide mp4/quicktime support according to gstreamer's documentation, but in doubt i also tried installing gstreamer0.10-bad-plugins, the only one i had not installed, but the problem persisted.

Totem's output is a little different:
$ totem somefile.mp4
** Message: Error: Your GStreamer installation is missing a plug-in.
gstdecodebin2.c(3233): gst_decode_bin_expose (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
no suitable plugins found

** Message: Missing plugin: gstreamer|0.10|totem|Quicktime demuxer|decoder-video/quicktime, variant=(string)iso (Quicktime demuxer)
** Message: Automatic missing codec installation not supported (helper script missing)


I also have a gtk dialog that tells me the quicktime demuxer is missing...

My files were playing fine up until this upgrade. I tried downgrading and everything works with the old gstreamer packages...
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 04 July 2011, 10:42 GMT
Reason for closing:  Works for me
Additional comments about closing:  Corrupted or invalid gstreamer registry was the cause of this. Maybe it was from the future?
Comment by Jan de Groot (JGC) - Monday, 23 May 2011, 07:30 GMT
Fun. The qtdemux plugin has been renamed to isomp4 in the recent release of gstreamer, but either playbin2 missed those changes or isomp4 doesn't provide the correct compatibility stuff.
Comment by Wulf Solter (illektr1k) - Tuesday, 24 May 2011, 15:44 GMT
Thanks for the heads up JGC!

A quick sym link fixed it.

sudo ln -s /usr/lib/gstreamer-0.10/libgstisomp4.so /usr/lib/gstreamer-0.10/libgstqtdemux.so
Comment by hqet4 (hqet4) - Thursday, 26 May 2011, 12:12 GMT
Will it be fixed upstream ?
Comment by Andreas (Evilandi666) - Thursday, 26 May 2011, 17:45 GMT
Feel free to fill a upstream bugreport. But no other distro seems to have this bug, so maybe we missed something?
Comment by Ionut Biru (wonder) - Thursday, 26 May 2011, 17:55 GMT
@Andreas maybe because no other distro is using 0.10.34 version released 2 weeks ago?
Comment by Andreas (Evilandi666) - Thursday, 26 May 2011, 18:20 GMT
What about Fedora 15? Mandriva? Don't know if they use it, but a short google session found some matches, but not shure if they are using it or not.
Comment by Ionut Biru (wonder) - Thursday, 26 May 2011, 18:44 GMT
can you guys provide a test file? i tried several from http://samples.mplayerhq.hu/MPEG-4/ and works fine.

i'm on i686
Comment by Andreas (Evilandi666) - Thursday, 26 May 2011, 19:43 GMT
Solution:

Delete $HOME/.gstreamer-0.10/registry.x86_64.bin

relogin afterwards

-> quicktime demux error is gone

if you still have a video mpeg-4 codec not found error, install gstreamer0.10-ffmpeg, afterwards both audio/video work fine.

Thx to ioni for the magic ;)
Comment by hqet4 (hqet4) - Saturday, 28 May 2011, 05:53 GMT
Thanks Andreas, it's working now.

Loading...