Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24275 - [kernel26] V4L in Kernel

Attached to Project: Arch Linux
Opened by Clouseau2 (Clouseau2) - Saturday, 14 May 2011, 16:20 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 16 February 2012, 17:56 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Since kernel 2.6.37-ARCH I have issues with my Avermedia Volar X dvb-t usb. I have configured it following this guide http://www.linuxtv.org/wiki/index.php/AVerMedia_AVerTV_Digi_Volar_X_%28A815%29 and everything worked perfect. I even fixed possible issues in guide by remote going into a loop when keypresed. And when I upgraded to 2.6.37. my keypresses on a remote are registred often twice. I am now on latest official kernel in Arch repo and the problem persists. I have even tried through lirc to fix the problem but the keypresses are often doubled also so there must be a bug in kernel/v4l drivers.

Sorry for bad english :)

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:

Press in example channel up on RM-KS remote controle of dvb-t and it is often registred as a double keypress.

This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 16 February 2012, 17:56 GMT
Reason for closing:  Upstream
Comment by Clouseau2 (Clouseau2) - Monday, 16 May 2011, 13:11 GMT
OK, I managed to figure it out where could be the problem - https://bbs.archlinux.org/viewtopic.php?id=109037&p=1

I have only this protocol available in /sys/class/rc/rc0/protocols NEC. I cannot blacklist modules ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,rc_rc6_mce,ir_rc5_decoder,ir_nec_decoder... because all of them loads with dvb_usb_af9015 module which is needed for Avermedia Volar X card. So there must be a problem in that lirc module now integradet in kernel... I really don't wan't to recompile my kernel because I switchet from Gentoo to Arch because don't want no more compiling to do...

Is there maybe another solution for this?
Comment by Clouseau2 (Clouseau2) - Monday, 16 May 2011, 20:17 GMT
Ok, I have compiled kernel26-ck without ir_decoder stuff and needed only to left rc_core because if I disable that in nconfig I cannot choose driver for my card. The result is the same, my remote often registers double click. Then I have compiled the kernel with support for v4l modules but without rc_core and my driver (afatec 9015) and afterwards tried to compile v4l-dvb development in aur which failed. And then I tried v4l-git which also failed...

Any help?
Comment by Clouseau2 (Clouseau2) - Wednesday, 18 May 2011, 17:16 GMT
Ok, kernel26-2.6.36.3-2 has no problem with occasional double key registering. First next one kernel and that is kernel26-2.6.37.2-1 till the latest kernel in the repo has problem so there must be something changed in kernel26-2.6.37-2.1. Can someone maybe tell me what to look for or where to look for or help me with what has changed in 2.6.37 kernel that could be the problem?

Tnx.
Comment by Clouseau2 (Clouseau2) - Wednesday, 18 May 2011, 17:29 GMT
Found the changelog http://kernelnewbies.org/Linux_2_6_37 but nothing indicates what would be the problem...
Comment by Clouseau2 (Clouseau2) - Wednesday, 18 May 2011, 18:17 GMT
Ok, with 2.6.36 I have nothing in /sys/class/rc/ and the remote works out of the box. With next kernel and newer I have now /sys/class/rc/rc0/... which is probably where the bug is, this is created as extra and it obviously interferes with the remote often accepting one click as two... What to do, what to do.
Comment by Jelle van der Waa (jelly) - Saturday, 18 June 2011, 09:26 GMT
any update? ( since we have .39 now)
Comment by Clouseau2 (Clouseau2) - Sunday, 26 June 2011, 15:08 GMT
The problem is still here with kernel26-2.6.39.1-1... I still use this in my pacman.conf so I can have kernel26-2.6.36.3-2 installed:

IgnorePkg = kernel26 kernel26-headers xorg-server xorg-server-common xf86-input-evdev nvidia nvidia-utils

The system is doing fine for now :)
Comment by Clouseau2 (Clouseau2) - Sunday, 03 July 2011, 19:17 GMT
N'yes... I need a never kernel because modem-manager slowly opens and closes serial ports of Vodafone Mobile Connect USB stick. It's a kernel issuse because it waits too long between opening and closing serial ports. So upon insertion of Vodafone USB I have to wait 5minutes to connect to internet - I'm using knetwork-manager plasma addon and everythings is correctly set. Or I can use wvdial and stay on this kernel...
The issue is fixed in later kernels and if I upgrade, my remote will stop functioning normal...
Comment by Jelle van der Waa (jelly) - Sunday, 03 July 2011, 21:37 GMT
This is a seperate issue, again you should adress to the kernel dev.

Loading...