Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24274 - [xorg-xrandr] xrandr scaling jails mouse

Attached to Project: Arch Linux
Opened by Alexander Kyte (sublimepua) - Saturday, 14 May 2011, 15:22 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 17 October 2012, 06:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description:
Using Xrandr to scale on the current version of Xorg in extra leads to the mouse beng limited to movement in a specific corner of the screen.


Steps to reproduce:
1. Do a fresh install, installing xorg.server as per the beginner's guide. I have an intel 950 graphics card, so this might be limited to intel.
2. Use xrandr to scale the screen. This command is almost necessary to have good working conditions on a netbook's screen. The command is

Xrandr --output *screen name* --mode **current resolution* --scale **proportion to scale by, I chose 1.25x1.25* --panning **new resolution**

3. The screen is resized as it should be, but the mouse cannot move out of an invisible box in the upper-left hand corner, the size of the origional screen's resolution. The mouse is essentially trapped. While not debilitating, this is annoying.

I have not been able to reproduce this error on Sabayon, Ubuntu, Slackware, or Fedora. I believe that this is either caused by our implementation of xorg-server, or our deault configuration. Any advice?
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 17 October 2012, 06:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  2012-10-16: A task closure has been requested. Reason for request: Fixed in newer versions of Xorg.
Comment by Alexander Kyte (sublimepua) - Sunday, 22 May 2011, 04:28 GMT
aaaany updates guys?
Comment by whistle (whistle) - Tuesday, 31 May 2011, 22:42 GMT
I have similar problems with:

Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller

and using xrandr as follows:

xrandr --output VGA1 --auto --left-of LVDS1

Very frustrating. Please fix this soon.
Comment by Dmitrij D. Czarkoff (czarkoff) - Wednesday, 08 June 2011, 11:30 GMT
Same problem here with "00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)".

xrandr command "xrandr --output LVDS1 --scale 1.3x1.3".
Comment by Dmitrij D. Czarkoff (czarkoff) - Wednesday, 08 June 2011, 12:01 GMT
Does anyone has any clue about the source of this problem?
Comment by Ophiel (ophiel) - Tuesday, 28 June 2011, 20:17 GMT
Yes, it makes some apps unusable on netbooks, though I had the same problem on Fedora and Mint. Please fix it...
Comment by Dariusz Tefelski (sq5nbg) - Monday, 08 August 2011, 19:58 GMT
I think panning hasn't been working in Archlinux since beginning of the 2011. I have MSI U100 netbook with Intel Corporation Mobile 945GME graphics card. I am also using Ubuntu 10.04 as backup and panning is working there without problems.
Comment by Alexander Kyte (sublimepua) - Saturday, 13 August 2011, 04:03 GMT
It appears that this problem was first noticed around 5.14.11 https://bbs.archlinux.org/viewtopic.php?id=118999 and xorg-server 1.8.0.902-1 was released on the 6th. it most likely came from there.

http://projects.archlinux.org/svntogit/packages.git/commit/xorg-server/trunk?id=571e22a871a99d6fc0664d74228d716b99b2cc5b

but the release of 1.8.1 shows a few changes with cursor handling, which looks to be exactly whats wrong. Someone wanna explain the code to me?
Comment by Dariusz Tefelski (sq5nbg) - Friday, 26 August 2011, 13:54 GMT
I have downgraded xorg-server with good results. Panning is working again on my machine (MSI U100). I have downloaded packages from Arch Rollback Machine: http://arm.konnichi.com/search/
xorg-server 1.9.4.901-1
xf86-video-intel 2.14.0-3
xf86-input-mouse 1.7.0-1
xf86-input-keyboard 1.6.0-1
xf86-input-evdev 2.6.0-2

In /etc/pacman.conf I added line:
IgnorePkg = xorg-server xf86-video-intel xf86-input-mouse xf86-input-keyboard xf86-input-evdev

All works ok, but of course it is a temporary solution. Still bug exist in current packages.

Comment by Dmitrij D. Czarkoff (czarkoff) - Sunday, 30 October 2011, 19:08 GMT
For some netbooks and slates it is a showstopper bug...
Comment by Karol Błażewicz (karol) - Sunday, 30 October 2011, 19:13 GMT Comment by Alyssa Hung (Deciare) - Thursday, 19 January 2012, 00:19 GMT Comment by Greg (dolby) - Monday, 15 October 2012, 08:06 GMT
Still a problem with latest xorg?
Comment by Stefanescu Cristian (big_bum) - Monday, 15 October 2012, 09:10 GMT
Will test soon.

Without --panning mouse gets trapped. With panning activated, everything is OK.

Loading...