Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#24270 - the use of colon ":" in package names

Attached to Project: Pacman
Opened by david (stryder) - Saturday, 14 May 2011, 09:37 GMT
Last edited by Dan McGee (toofishes) - Tuesday, 31 May 2011, 14:37 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Dan McGee (toofishes)
Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version 3.5.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Recently the "colon" has been introduced to package names, for example
rasqal-1:0.9.21-1
redland-1:1.0.12-1
redland-storage-virtuoso-1:1.0.12-1
ntrack-1:13-1
lirc-utils-1:0.9.0-2
vi-1:050325-1

The colon is not a valid character for many filesystems, including samba. In my case, I am not able to make use of a share folder in virtualbox to update my system. Or any samba shares. If this persists I am forced to create a virtual disk just to hold my packages. This will be inefficient. In the case of this thread (https://bbs.archlinux.org/viewtopic.php?id=118333) the person uses a thumb drive to transfer packages to his office computer which does not have an internet connection. The fat32 filesystem in his thumbdrive precludes these file names. Since many of our systems live in a mixed environment with different filesystems, it makes sense to have filenames that are widely acceptable.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Dan McGee (toofishes)
Tuesday, 31 May 2011, 14:37 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Use a better FS or chose mounting options wisely
Comment by Dan McGee (toofishes) - Monday, 16 May 2011, 16:49 GMT
  • Field changed: Status (Unconfirmed → Researching)
  • Field changed: Category (System → General)
  • Field changed: Reported Version ( → 3.5.2)
  • Field changed: Architecture (All → All)
  • Task assigned to Allan McRae (Allan), Dan McGee (toofishes)
The colon is actually in version specifiers, not names.
Comment by david (stryder) - Sunday, 29 May 2011, 11:18 GMT
Just to say that I solved my particular problem by using NFS instead of Samba though I still think that you should still use filenames that are more widely accepted. The virtualbox share folder for example will not work.
Comment by Rémy Oudompheng (remyoudompheng) - Sunday, 29 May 2011, 11:58 GMT
This file name format for packages with epoch is used by Debian for years. Mount your samba shares with the "mapchars" option so that invalid characters are automatically translated to code points in unmapped Unicode regions.

I think Ubuntu, being a Debian derivative, also uses colons. It doesn't seem to have prevented its widespread adoption, so it would be worth having a look at what advice they give to users.
Comment by Dave Reisner (falconindy) - Monday, 30 May 2011, 22:12 GMT
redhat/fedora uses this as well. In fact, someone can correct me if I'm wrong, but I believe we borrowed version parsing code from RPM when we added epoch.
Comment by david (stryder) - Tuesday, 31 May 2011, 02:08 GMT
OK, I did a brief google and while the problem exists it doesn't seem to bother most people. As I have a solution to my problem with it, feel free to close the bug report.
Comment by Dan McGee (toofishes) - Tuesday, 31 May 2011, 14:37 GMT
Yes, our version number format matches RPM; I didn't look much into how they named their package files however. Either way it seems like this can be worked around quite easily and is more a problem with certain filesystems rather than something we are doing wrong.
Comment by Anonymous Submitter - Thursday, 23 June 2011, 14:56 GMT

Loading...