Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24212 - [thunar-volman] add gvfs as a dependency

Attached to Project: Arch Linux
Opened by Eric Toombs (ewtoombs) - Wednesday, 11 May 2011, 02:16 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 23 October 2011, 09:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
thunar-volman doesn't work properly unless gvfs is installed. All devices that I have tried won't automount without it. Therefore gvfs must be added to thunar-volman's dependency list. If there are devices that automount fine without gvfs then it must at least be added to its optional dependencies.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 23 October 2011, 09:54 GMT
Reason for closing:  Not a bug
Additional comments about closing:  gvfs is already an optional dep and well described in main thunar pkg.
Comment by Marek Niklicek (Dogmeat) - Wednesday, 11 May 2011, 11:19 GMT
Thunar already has gvfs as an optional dependency.

pacman -Si thunar | grep Opt
Optional Deps : gvfs: for trash support, mounting with udisk and remote filesystems
Comment by Eric Toombs (ewtoombs) - Wednesday, 11 May 2011, 15:04 GMT
You've missed the point, Marek. This has nothing to do with thunar's dependencies. Of course it can work fine without gvfs. thunar-volman can't.
Comment by Greg (dolby) - Wednesday, 11 May 2011, 22:15 GMT
And you are using thunar-volman without thunar?
Comment by Eric Toombs (ewtoombs) - Wednesday, 11 May 2011, 22:37 GMT
What do you mean, Greg? thunar-volman depends on thunar. Nobody would be stupid enough to use thunar-volman without thunar.
Comment by Eric Toombs (ewtoombs) - Wednesday, 11 May 2011, 23:01 GMT
Oh, that was sarcasm. I get it. Remember that your intonation doesn't get transmitted along with the text. gvfs is an optional dependency of both at least and it's probably an actual dependency of thunar-volman. One would not necessarily look at thunar's opt. dep. list after installing thunar-volman and expecting automounting to work.
Comment by Greg (dolby) - Wednesday, 11 May 2011, 23:48 GMT
The dependency chain is there. thunar-volman -> thunar -> (optional) gvfs. And its correct. The application that works with gvfs is thunar, *not* thunar-volman. Volman only needs gvfs support built into thunar. Thats one of the disadvantages of using and not automatically handling optdepends.

edit: see the README of thunar-volman: http://git.xfce.org/xfce/thunar-volman/tree/README
thunar-volman depends on the following packages:
- Thunar 1.1.1 or above - exo 0.5.0 or above - glib 2.18.0 or above - GTK+ 2.24.0 or above - GUDev 145 or above - libxfce4ui 4.7.0 or above - libxfce4util 4.7.0 or above - xfconf 4.7.0 or above
Do you see gvfs there? No, cause its satisfied by thunar.
Comment by Eric Toombs (ewtoombs) - Thursday, 12 May 2011, 00:40 GMT
Can thunar-volman do anything without gvfs?
Comment by Anders H (b9anders) - Sunday, 15 May 2011, 18:29 GMT
gvfs may be an optional dependency for Thunar and Thunar-volman may compile just fine without, but surely there is little point in leaving it out as a dependency for thunar-volman when it can't actually do anything without gvfs. Functionally, it is an essential requirement, whether it is listed as a build dependency or not.

This is not clear to end-users as it is now. Is it quite possible to install thunar, install volman a little later when that little print of optional dependencies in the installation output is long forgotten and then start wondering why volman doesn't do anything. And the intuitive answer is not really to go look in the optional dependencies for a parent package for a solution. No one who uses volman can use it without gvfs, so it might as well just be listed as a dependency to avoid confusion.
Comment by Eric Toombs (ewtoombs) - Tuesday, 17 May 2011, 11:24 GMT
pacman does honour runtime dependencies, doesn't it? It would be silly only to install the build dependencies.
Comment by mike hamerski (mhamerski) - Sunday, 25 September 2011, 13:20 GMT
Since I've not been able to get automounting in Thunar to work properly over the last 4 months, until I installed gvfs for a totally unrelated reason, I fail to see why adding a line of text info would be considered spurious. Seeing as Arch is a modular system, more info actually seems useful, as this is totally counter-intuitive to my mind.

Loading...