Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24167 - [webkit-sharp] System.DllNotFoundException: webkit-1.0.so.2

Attached to Project: Arch Linux
Opened by Jaroslav Lichtblau (Dragonlord) - Sunday, 08 May 2011, 12:10 GMT
Last edited by Isenmann Daniel (ise) - Tuesday, 13 September 2011, 06:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After the release of Gnome3, starting the mono dependent AUR package - opencachemanager (http://aur.archlinux.org/packages.php?ID=46195) gives just a spash screen and then the app dies with following error:

$ ocm-gtk
NO SESSION DBUS RUNNING

(ocm-gtk:20410): Gtk-WARNING **: menu: missing action (null)
Exception in Gtk# callback delegate
Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.TypeInitializationException: An exception was thrown by the type initializer for WebKit.WebView ---> System.DllNotFoundException: webkit-1.0.so.2
at (wrapper managed-to-native) WebKit.Download:webkit_download_get_type ()
at WebKit.Download.get_GType () [0x00000] in <filename unknown>:0
at GtkSharp.WebkitSharp.ObjectManager.Initialize () [0x00000] in <filename unknown>:0
at WebKit.WebView..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at ocmgtk.HTMLWidget..ctor () [0x00000] in <filename unknown>:0
at ocmgtk.DescriptionWidget..ctor () [0x00000] in <filename unknown>:0
at ocmgtk.GeoCachePane.Build () [0x00000] in <filename unknown>:0
at ocmgtk.GeoCachePane..ctor () [0x00000] in <filename unknown>:0
at MainWindow.Build () [0x00000] in <filename unknown>:0
at MainWindow..ctor () [0x00000] in <filename unknown>:0
at ocmgtk.MainClass.ShowMain () [0x00000] in <filename unknown>:0
at ocmgtk.MainClass.<HandleSplashtimeElapsed>m__0 (System.Object , System.EventArgs ) [0x00000] in <filename unknown>:0
at Gtk.Application+InvokeCB.Invoke () [0x00000] in <filename unknown>:0
at GLib.Timeout+TimeoutProxy.Handler () [0x00000] in <filename unknown>:0
at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
at GLib.Timeout+TimeoutProxy.Handler()
at Gtk.Application.gtk_main()
at Gtk.Application.Run()
at ocmgtk.MainClass.Main(System.String[] args)

Additional info:
* package version(s)
opencachemanager 0.23.14-1
Targets (131): xproto-7.0.21-1 xcb-proto-1.6-2 libxdmcp-1.1.0-1
libxau-1.0.6-1 libxcb-1.7-2 kbproto-1.0.5-1
libx11-1.4.3-2 renderproto-0.11.1-1
libxrender-0.9.6-1 libpng-1.4.5-1 freetype2-2.4.4-2
fontconfig-2.8.0-1 pixman-0.20.2-1 cairo-1.10.2-2
libjpeg-turbo-1.1.0-1 libtiff-3.9.5-1 giflib-4.1.6-4
libexif-0.6.20-1 libgdiplus-2.10-1 mono-2.10.2-1
libsasl-2.1.23-5 libldap-2.4.24-1 sqlite3-3.7.6.1-1
heimdal-1.3.3-4 libtasn1-2.9-1 gnutls-2.12.4-1
atk-2.0.0-1 libxft-2.2.0-1 libdatrie-0.2.4-1
libthai-0.1.15-1 pango-1.28.4-2 xextproto-7.2.0-1
fixesproto-5.0-1 libxfixes-5.0-1 libxcursor-1.1.11-1
libxext-1.2.0-1 xineramaproto-1.2.1-1
libxinerama-1.1.1-1 randrproto-1.3.2-1
libxrandr-1.3.1-1 inputproto-2.0.1-1 libxi-1.4.2-1
compositeproto-0.4.2-1 libxcomposite-0.4.3-1
damageproto-1.2.1-1 libxdamage-1.1.3-1
libxml2-2.7.8-1 shared-mime-info-0.90-1
libdaemon-0.14-1 dbus-1.4.1-1 avahi-0.6.30-2
libcups-1.4.6-1 gdk-pixbuf2-2.23.3-1
gtk-update-icon-cache-2.24.4-1 gtk2-2.24.4-1
libglade-2.6.4-2 gtk-sharp-2-2.12.10-1
libart-lgpl-2.3.21-1 art-sharp-2.24.2-1
libidl2-0.8.14-1 orbit2-2.14.19-1 polkit-0.101-2
dbus-glib-0.92-1 gtk3-3.0.9-1 gconf-2.32.3-1
gconf-sharp-2.24.2-1 libgssglue-0.1-3
libtirpc-0.2.1-2 rpcbind-0.2.0-3 fam-2.7.0-14
keyutils-1.4-1 cifs-utils-4.9-2 tdb-1.2.9-1
talloc-2.0.5-1 smbclient-3.5.8-2
gnome-mime-data-2.18.0-5 gnome-vfs-2.24.4-2
gnome-vfs-sharp-2.24.2-1 libgnomecanvas-2.30.3-1
libgnome-data-2.32.0-3 libbonobo-2.32.1-1
libgnome-keyring-3.0.1-1 libproxy-0.4.6-6
run-parts-3.4.4-1 ca-certificates-20110421-3
gsettings-desktop-schemas-3.0.1-2
glib-networking-2.28.6.1-2 libsoup-2.34.1-1
libsoup-gnome-2.34.1-1 libunique3-3.0.0-1
sg3_utils-1.30-1 parted-2.3-1 libatasmart-0.17-1
lsof-4.84-3 eject-2.1.5-5 udisks-1.0.3-2
libnotify-0.7.2-1 hicolor-icon-theme-0.12-1
gnome-disk-utility-3.0.0-1 libcddb-1.3.2-2
libcdio-0.82-1 fuse-2.8.5-1 gvfs-1.8.1-1
libogg-1.2.2-1 libvorbis-1.3.2-1 alsa-lib-1.0.24.1-1
libcanberra-0.28-1 libgnome-2.32.0-3
libbonoboui-2.24.5-1 libice-1.0.7-1 libsm-1.2.0-1
libgnomeui-2.24.4-1 libgnome-sharp-2.24.2-1
gconf-sharp-peditors-2.24.2-1 gnome-sharp-2.24.2-1
gpsbabel-1.4.2-1 ndesk-dbus-0.6.0-2
ndesk-dbus-glib-0.4.1-2 libxt-1.1.1-1
libxslt-1.1.26-2 icu-4.6.1-1 gstreamer0.10-0.10.32-1
orc-0.4.14-1 videoproto-2.3.1-1 libxv-1.0.6-1
gstreamer0.10-base-0.10.32-4 aspell-0.60.6-5
hunspell-1.2.15-1 enchant-1.6.0-1 libwebkit-1.4.0-1
webkit-sharp-0.3-1

* config and/or log files etc.
~]$ cat /usr/lib/mono/gac/webkit-sharp/1.1.15.0__eaa1d335d2e19745/webkit-sharp.dll.config
<configuration>
<dllmap dll="webkit-1.0" target="webkit-1.0.so.2"/>
</configuration>

Steps to reproduce:
build opencachemanager in clean chroot
pacman -U opencachemanager-0.23.14-1-any.pkg.tar.xz
$ ocm-gtk
This task depends upon

Closed by  Isenmann Daniel (ise)
Tuesday, 13 September 2011, 06:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in webkit-sharp-0.3-3. Links now to /usr/lib/libwebkitgtk-1.0.so.0
Comment by Rémy Oudompheng (remyoudompheng) - Sunday, 08 May 2011, 12:35 GMT
Hello, it probably needs to be rebuilt to point to the correct location /usr/lib/libwebkitgtk-1.0.so.
Can you check that this fixes the problem ?
Comment by Ionut Biru (wonder) - Sunday, 08 May 2011, 12:48 GMT
mono is special. a rebuild doesn't fix the harcoded soname from webkit-sharp.dll.config.
Comment by Jaroslav Lichtblau (Dragonlord) - Thursday, 12 May 2011, 17:31 GMT
Found the time to look into this better - simple updating of webkit-sharp.dll.config.in was not good enough. Ugly fix with creating symlink worked, but that's not what we want.
sed command update and package rebuild fixed it.

- PKGBUILD patch attached.
Comment by Jaroslav Lichtblau (Dragonlord) - Wednesday, 29 June 2011, 21:40 GMT
  • Field changed: Percent Complete (100% → 0%)
Same error, same solution - just the library version moved to 0.7.1 - sed line needs to be updated in the PKGBUILD.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 29 June 2011, 21:46 GMT
Have you tried making it link to /usr/lib/libwebkitgtk-1.0.so.0 instead of usr/lib/libwebkitgtk-1.0.so.0.7.x, so that it won't break unless there is a soname bump?

Loading...