Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24132 - [kernel26] Kernel 2.6.38 ACPI regressions

Attached to Project: Arch Linux
Opened by Bryan (bryan) - Friday, 06 May 2011, 19:37 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 16 February 2012, 17:55 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Since a kernel upgrade two days ago when 2.6.38.2-1-x86_64 was available through pacman I observe one regression:

- reboot or poweroff command does not complete and stops in a "Rebooting" or "Powering off" line on console, not going further (ACPI related ?).

Nothing weird or unusual in logs (kernel, message, Xorg). Reverting to 2.6.37.5-1-x86_64 worked and restored proper behaviour.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 16 February 2012, 17:55 GMT
Reason for closing:  Upstream
Comment by Bryan (bryan) - Friday, 06 May 2011, 19:41 GMT Comment by Jelle van der Waa (jelly) - Saturday, 07 May 2011, 10:04 GMT
1000% upstream issue, please report it there
Comment by Bryan (bryan) - Sunday, 22 May 2011, 09:06 GMT
And clearly an ACPI related issue:

- poweroff : does what expected but stops right after showing "POWER OFF" string ;
- reboot : i.e. with string "REBOOTING" ;

acpitool -s puts the laptop is S3 sleep state.
Thermal info has moved:

# acpitool -tv
Could not open /proc/acpi/thermal_zone
Thermal info: <not available>

some information is available from /proc/acpi/ibm/thermal showing shifted temperature values (laptop in same running conditions):

kernel 2.6.37.5:
temperatures: 32 25 25 26 27 -128 25 -128 26 27 -128 -128 -128 -128 -128 -128

kernel 2.6.38.6-2:
temperatures: 48 51 51 44 27 -128 33 -128 47 45 -128 -128 -128 -128 -128 -128
Comment by Diego Viola (diegoviola) - Wednesday, 25 May 2011, 22:26 GMT
I've submitted a bug report upstream here about the shutdown/reboot issue:

https://bugzilla.kernel.org/show_bug.cgi?id=33872

Loading...