Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24099 - Nautilus 3.0.1.1 segmentation fault if gnome-icon-theme is missing

Attached to Project: Arch Linux
Opened by Thayer Williams (thayer) - Wednesday, 04 May 2011, 17:24 GMT
Last edited by Ionut Biru (wonder) - Friday, 06 May 2011, 07:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Nautilus 3 apparently depends on gnome-icon-theme and will seg fault if the package is not installed.

Package info:
* nautilus 3.0.1.1-1
* gnome-icon-theme 3.0.0-1

Steps to reproduce:

# pacman -S nautilus
$ nautilus
<seg fault>
# pacman -S gnome-icon-theme
$ nautilus
<happy worker bee>
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 06 May 2011, 07:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  nautilus 3.0.1.1-3
Comment by Ionut Biru (wonder) - Wednesday, 04 May 2011, 17:47 GMT
we had this reported upstream https://bugzilla.gnome.org/show_bug.cgi?id=646006

do you use gtk3 from extra?
Comment by Thayer Williams (thayer) - Wednesday, 04 May 2011, 18:10 GMT
This occurs when running nautilus in a non-GNOME environment; in this case, WMFS. All official packages and doesn't matter whether ~/.config/gtk-3.0/settings.ini is present or not.
Comment by Ionut Biru (wonder) - Wednesday, 04 May 2011, 18:17 GMT
can you recompile nautilus with debug and get a trace?
Comment by Thayer Williams (thayer) - Wednesday, 04 May 2011, 19:09 GMT
I'd be happy to if I could I find some instructions. Also, the upstream bug you linked assumes that gnome-icon-theme and gnome-icon-theme-symbolic are already installed. Perhaps it's not quite the same issue?
Comment by Ionut Biru (wonder) - Wednesday, 04 May 2011, 19:11 GMT Comment by Thayer Williams (thayer) - Wednesday, 04 May 2011, 19:47 GMT
Thanks for that! Attached is the trace.log, though it's meager compared to others in the upstream bug.
Comment by Ionut Biru (wonder) - Wednesday, 04 May 2011, 19:50 GMT
i'll add the theme to dependency then
Comment by Thayer Williams (thayer) - Wednesday, 04 May 2011, 19:53 GMT
Sounds good. I also tried installing only gnome-icon-theme-symbolic since it's normally pulled in by gnome-icon-theme, but nautilus still seg faults so it must be the gnome-icon-theme package itself.
Comment by Thayer Williams (thayer) - Friday, 06 May 2011, 06:01 GMT
  • Field changed: Percent Complete (100% → 0%)
gnome-icon-theme is still missing from deps (perhaps gnome-themes-standard was added by accident?)
Comment by Ionut Biru (wonder) - Friday, 06 May 2011, 06:41 GMT
yes. i failed

Loading...