Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24096 - [GNOME3] gdm or gnome-session crashes after resuming from suspend

Attached to Project: Arch Linux
Opened by Paul N. Maxwell (Maxwel) - Wednesday, 04 May 2011, 15:05 GMT
Last edited by Gaetan Bisson (vesath) - Wednesday, 03 October 2012, 14:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After resuming laptop from suspend to RAM gdm restarts

/var/log/messages
May 4 17:35:43 maxwel-ltws gnome-session[4844]: Gdk-WARNING: The program 'gnome-session' received an X Window System error.
This probably reflects a bug in the program.
The error was 'XI_BadDevice (invalid Device parameter)'.
(Details: serial 218 error_code 149 request_code 141 minor_code 48)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

gnome-session 3.0.1-1
gdm 3.0.0-3
kernel26 2.6.38.4-1

Steps to reproduce:
Suspend to RAM and then resume. If you are not lucky, gdm will restart and your unsaved data will be lost.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Wednesday, 03 October 2012, 14:40 GMT
Reason for closing:  No response
Additional comments about closing:  Looks fixed by now.
Comment by Ionut Biru (wonder) - Wednesday, 04 May 2011, 15:44 GMT
who suspends without saving the data?:D
Comment by Paul N. Maxwell (Maxwel) - Wednesday, 04 May 2011, 16:34 GMT
Of course my data have been saved, but after gdm crash I need to launch all programs again and again. It's not much convenient...
Comment by Ionut Biru (wonder) - Wednesday, 04 May 2011, 16:37 GMT
what video card do you have? from what i see Xorg crashed and gnome-session along with it
Comment by Paul N. Maxwell (Maxwel) - Wednesday, 04 May 2011, 17:06 GMT
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
Subsystem: Dell Device 022f
Kernel driver in use: i915
Kernel modules: i915
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
Subsystem: Dell Device 022f

There is no errors in /var/log/Xorg.0.log.
Crashes stars after upgrading GNOME to version 3. Xorg hasn't been upgraded with gnome.
Version: extra/xorg-server 1.10.1-1
Comment by Jan Alexander Steffens (heftig) - Thursday, 05 May 2011, 10:22 GMT
I believe XI_BadDevice is an XInput error. Apparently an input device didn't survive suspend.

Do you remove e.g. a mouse after suspending, then waking up without?
Comment by Jan Alexander Steffens (heftig) - Thursday, 05 May 2011, 10:29 GMT Comment by Paul N. Maxwell (Maxwel) - Thursday, 05 May 2011, 10:38 GMT
During suspend to RAM mouse was plugged, but during resuming mouse was and plugged and unplugged. In both cases gdm crashes.
Comment by Albino Biasutti Neto (bino28) - Thursday, 23 June 2011, 11:54 GMT
I am with the problem.

Not Solved.
Comment by Aoshi Shinomori (aoshi) - Saturday, 02 July 2011, 20:12 GMT
Well, my problem is little different but i think this is the right place to write.
I have 2 Users accounts, when i click on "Switch User" i go to the other user work a litle and then click "Lock Screen" 1 hour later an example without working and when i return to Arch, the system crash.
Comment by Ionut Biru (wonder) - Monday, 03 October 2011, 19:29 GMT
still valid with gnome 3.2?
Comment by Paul N. Maxwell (Maxwel) - Tuesday, 04 October 2011, 05:29 GMT
Everything is fine... yet... need more time for testing...
Comment by Paul N. Maxwell (Maxwel) - Wednesday, 05 October 2011, 16:32 GMT
Problem still exists. GDM restarts after resuming from suspend to RAM.
Comment by Albino Biasutti Neto (bino28) - Saturday, 08 October 2011, 01:47 GMT
Continue the problem.

Log: http://pastebin.com/784fhwU4

When open firefox block screen, doing Lock Screen.
Comment by Ivan Lezhnjov IV (ILIV) - Monday, 09 April 2012, 09:17 GMT
My setup is affected by this as well. I run a bit outdated software, but I figure it's relevant nonetheless:

gtk3 3.0.11-1
gnome-desktop 3.0.2-1

Since this is related to X Input barking at us, I think it's perhaps because of my Apple USB aluminium, wired keyboard. Which is kinda sad. Any workarounds?
Comment by Greg (dolby) - Friday, 24 August 2012, 05:17 GMT
Still a problem?
Comment by xCrucialDudex (xCrucialDudex) - Friday, 24 August 2012, 05:26 GMT
No, not for me.

Loading...