Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24082 - [initscripts] rc concflicts with some package

Attached to Project: Arch Linux
Opened by MaurĂ­cio CA (mauricioca) - Wednesday, 04 May 2011, 01:41 GMT
Last edited by Tom Gundersen (tomegun) - Thursday, 12 May 2011, 00:20 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: 'rc' script conflicts with 'rc' shell, provided by packages 9base and plan9port. I marked severity as high because this breaks anything depending on rc scripts, sometimes silently.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Thursday, 12 May 2011, 00:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 2011.05.1
Comment by Andrea Scarpino (BaSh) - Wednesday, 04 May 2011, 05:58 GMT
  • Field changed: Summary ([initscripts] → [initscripts] rc concflicts with some package)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Tom Gundersen (tomegun)
$ pkgfile rc
extra/cmus
community/9base
community/plan9port
core/initscripts
Comment by Greg (dolby) - Wednesday, 04 May 2011, 07:55 GMT
The cmus one is the configuration file in /usr/share/cmus so it doesnt harm, its not executable. IMO if possible the 9base and plan9port packages files should have be renamed rc-{9base,plan9port}. Those unlike the rc in initscripts arent installed by everyone. Their files are in /opt and not /sbin so there is no file conflict.
Comment by Dave Reisner (falconindy) - Wednesday, 04 May 2011, 12:20 GMT
Renaming a shell is not a small deal, regardless of perceived popularity. This is a PATH conflict not a filename conflict. /sbin/rc is new to the game and probably should be the one to yield.

Loading...