Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24044 - [vte] Upgrade to 0.28 broke Terminal

Attached to Project: Arch Linux
Opened by Dan McGee (toofishes) - Monday, 02 May 2011, 13:34 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 04 May 2011, 08:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Really not sure where to start looking here, other than downgrading back to 0.26-2 (and removing vte-common) made the error disappear. This error message shows once on xfce4-terminal startup, and then various things don't work- such as the 'enter' key.

Here is the error message:
*** VTE ***: Failed to load terminal capabilities from '/etc/termcap'

Interestingly enough, this does not show up on my x86_64 desktop system also using XFCE, only on my i686 laptop. Let me know if you want more details or what I should be looking at. The referenced '/etc/termcap' file exists on no system of mine either.
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 04 May 2011, 08:16 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Monday, 02 May 2011, 13:39 GMT
maybe is related to  FS#21007  and the fact that you overwrote the term settings?
Comment by Dan McGee (toofishes) - Monday, 02 May 2011, 13:59 GMT
That could be. I'll have to check out what I have different as far as config goes.
Comment by Scott Pidzarko (Scotty) - Tuesday, 03 May 2011, 04:13 GMT
Funny, in  FS#21007  Dan you said the problem was "The XFCE 'terminal' package also exhibits this breakage. It defaults TERM now to 'linux' regardless of what you have set in the preferences. Quite annoying for them to break this fundamental stuff..." It appears to have done exactly that, running "echo $TERM" returns "linux" for me.

Running vte 0.28.0-1 as a result of it upgrading today, when the bug appeared.

Following what Dan says further down fixed it for me in the xfce terminal:

"Still broken with XFCE Terminal.

Right Click > Preferences > Advanced Tab > $TERM setting: --> 'xterm-256color'

Then restart, and type in shell:
$ echo $TERM
xterm"

The error disappears when starting a terminal again, and the terminal functions normally again. Hope this helps fix the issue properly for you Ionut.
Comment by Ionut Biru (wonder) - Tuesday, 03 May 2011, 07:35 GMT
http://bugzilla.gnome.org

they might fix it
Comment by Xavier D. (magicrhesus) - Tuesday, 03 May 2011, 09:40 GMT
I think it's because a file has moved from place ( https://bugs.launchpad.net/ubuntu/+source/vte/+bug/140011 ).
At least creating a symlink solved this issue for me.
Comment by Guilherme de Sousa (guisacouto) - Tuesday, 03 May 2011, 12:31 GMT
Same problem here.. I use lilyterm, and since last vte update, the Enter/Return key stopped working
Comment by Dan McGee (toofishes) - Tuesday, 03 May 2011, 17:18 GMT
The awful solution was inferred in the bug report Xavier linked, so thanks. After you upgrade you need to ensure all terminal processes are completely gone as it uses some sort of daemon; thus a "killall terminal" did the trick for me. Next startup, no error appeared and things were back to normal.

Ionut, feel free to close this out now that I've at least put a workaround here for anyone looking for it.

Loading...