Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24010 - [calibre] pypdf should not be unbundled

Attached to Project: Community Packages
Opened by John Schember (user_none) - Sunday, 01 May 2011, 02:03 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 26 May 2011, 17:48 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

PyPDF included in the calibre source is a fork of the upstream PyPDF project. It includes changes that are not included in the arch package. Some PDF functionality is broken by unbundling this library.

Additional info:
* package version(s)
* 0.7.59-1

Steps to reproduce:

Running pdfmanipulate merge, will cause an exception due to the difference in the packaged and bundled pypdf libraries.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 26 May 2011, 17:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  calibre 0.8.2-2
Comment by Ionut Biru (wonder) - Wednesday, 25 May 2011, 17:48 GMT
@Giovanni, listen to John. He is the dev of calibre and he knows better.

https://bbs.archlinux.org/viewtopic.php?pid=939119#p939119
Comment by Andrea Scarpino (BaSh) - Wednesday, 25 May 2011, 17:52 GMT
Is a bug, but John if you use a different version of PyPDF you should fork it.
Comment by Giovanni Scafora (giovanni) - Thursday, 26 May 2011, 11:33 GMT
I fixed that issue in calibre-0.8.2-2 for both architectures.
Please let me know if now it's ok, so I can close this bug report.
Comment by John Schember (user_none) - Thursday, 26 May 2011, 17:39 GMT
Looks good. Thanks!

Loading...