Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#24006 - [networkmanager] my custom connections lost after update, can only read root connections

Attached to Project: Arch Linux
Opened by Asem (asem) - Saturday, 30 April 2011, 22:45 GMT
Last edited by Ionut Biru (wonder) - Sunday, 30 October 2011, 09:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 19
Private No

Details

Description:

after the update to 0.8.998-2
i found that i lost the connection to the network and cant find my custom wireless connections
i thought its kdeplasma-applet-networkmanagment fault but i installed gnome network-manager-applet and there was the same problem
i can only create new connections after supplying the root password even though system connection is not checked

note that the wireless signal power is not read for the found networks only the one i established using the root password is read.

Steps to reproduce:
This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 30 October 2011, 09:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  problem solved
Comment by Ragheed Al-Rifaii (ragheed) - Sunday, 01 May 2011, 01:15 GMT
3G modem gets detected in the logs but doesn't show in the applet also after this update
Comment by Vladimir Djurovic (vdjurovic) - Sunday, 01 May 2011, 09:21 GMT
I ran into the same issue. Attached is the screenshot of NM applet with error message.
Also, here's the message from daemon.log:

May 1 09:16:20 localhost NetworkManager[4102]: <info> (wlan0): device state change: 8 -> 3 (reason 38)
May 1 09:16:20 localhost NetworkManager[4102]: <info> (wlan0): deactivating device (reason: 38).
May 1 09:16:20 localhost dhcpcd[4918]: received SIGTERM, stopping
May 1 09:16:20 localhost dhcpcd[4918]: wlan0: removing interface
May 1 09:16:20 localhost NetworkManager[4102]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 4918
May 1 09:16:20 localhost NetworkManager[4102]: <warn> error requesting auth for org.freedesktop.NetworkManager.use-user-connections: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.use-user-connections is not registered
May 1 09:16:20 localhost NetworkManager[4102]: <warn> User connections unavailable: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.use-user-connections is not registered

Reverting back to version 0.8.3-0.20110113 helps.
Comment by Ionut Biru (wonder) - Sunday, 01 May 2011, 09:27 GMT
do pacman -Qo on those sonames Vladimir.
Comment by Filippo (filippo.leon) - Sunday, 01 May 2011, 09:32 GMT
Same problem here: Networkmanager lost all configurations (Wireless, VPN, ...) and I cannot connect to Wireless anymore directly via Applet (must go to syssettingss with root passwd) (no log of activity when trying to connect).
Comment by Ionut Biru (wonder) - Sunday, 01 May 2011, 11:40 GMT
check out networkmanager-0.8.998-3 network-manager-applet-0.8.998-2
Comment by Vladimir Djurovic (vdjurovic) - Sunday, 01 May 2011, 12:11 GMT
@lonut Biru

vlada@localhost ~]$ pacman -Qo /usr/lib/kde4/kcm_networkmanagement.so
/usr/lib/kde4/kcm_networkmanagement.so is owned by kdeplasma-applets-networkmanagement git20110418-2
[vlada@localhost ~]$ pacman -Qo /usr/lib/libknmservice.so
/usr/lib/libknmservice.so is owned by kdeplasma-applets-networkmanagement git20110418-2

Turns out that previous version did not work after restart. So, I reinstalled 0.8.998-2, restarted NetworkManager, and now wireless connections work. I'm not sure what happened, but everything seems fine for now.
Comment by olivier (0livier) - Sunday, 01 May 2011, 14:13 GMT
Hello,

it does work with network-manager-applet, but not with kdeplasma-applets-networkmanagement.
Comment by Asem (asem) - Sunday, 01 May 2011, 17:15 GMT
with network-manager-applet it asks for root password when creating new connections because of policy doesn't allow all users
Comment by Ionut Biru (wonder) - Sunday, 01 May 2011, 17:41 GMT Comment by Asem (asem) - Sunday, 01 May 2011, 18:25 GMT
@lonut thats what the problem really is, any new connection is treated as system connection not peruser one and if i put the password or modified the policy file to continue without a password i will find the connections in /etc/Networkmanager/system-connections
Comment by Ionut Biru (wonder) - Sunday, 01 May 2011, 18:28 GMT
if you look in the history for org.freedesktop.NetworkManager.policy.in you'll see that was dropped.

http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=67ba32cd299adf5ad58e5badfb00d9a3334cb714
Comment by Asem (asem) - Sunday, 01 May 2011, 19:02 GMT
ah thats right, i found that too
http://live.gnome.org/NetworkManager/RemovingUserSettings

shouldn't the package modified given that change?
Comment by Andrea Scarpino (BaSh) - Sunday, 01 May 2011, 21:27 GMT
@oliver
are you using the git20110418-2? Did you restarted plasma after the update?
Comment by André Felício (antigerme) - Monday, 02 May 2011, 03:23 GMT
I have the same problem with networkmanager-0.8.998-3
Comment by Ionut Biru (wonder) - Monday, 02 May 2011, 07:45 GMT
i lost the track or what problems do you guys have :D. Can you stop saying "i have this problem" and just describe it again?

from what i see Asem bug is not really a bug but they dropped the support.
Comment by Asem (asem) - Monday, 02 May 2011, 08:20 GMT
@Ionut
To sum up
new networkmanager seems to drop support of users connections, so any existing ones will not be accessible
the polikit will ask users for root passwords in order to stablish new one.
now i tried the 2 applets gnomes, and kde one
kde plasma applet can stablish new wired and wireless connections after giving the password or modifing the polkit but cant detect 3g modems or add a vpn connection.
gnome applete can do all stuff that kde applet does but can detect 3g modem and can add openvpn but fail to establish it( i will see why later)

so i think we can close the bug report for this package, what can be done is a postinstall message to notify users about the change or something and file another ones for each client because they seem to not adopt the change very well
Comment by Ragheed Al-Rifaii (ragheed) - Monday, 02 May 2011, 08:26 GMT
here's the description again:
1) all the user connections are not shown in the connection list though they are still exiting in ~/.kde4/share/apps/networkmanagement/connections
2) can't connect to any user created connection unless it's a system connection and i sill have to provide the root password
3) new devices are not shown like 3G modems though the logs look pretty sane to me
4) gnome nm-applet works fine !

this is pretty much a polkit issue since it came up with other permissions issues like mounting usb stick in dolphin but that's another issue.

what was strange is polkit-kde was unflaged today though Gentoo, debian, Redhat, Fedora and Suse are providing polkit-kde 0.101 !
Comment by olivier (0livier) - Monday, 02 May 2011, 08:27 GMT
@BaSh, wonder

With latest networkmanager and kdeplasma-applet packages, I am unable to create a new wireless connection. It is impossible to create the connection from the applet, but possible from the "manage connection" interface, where the pôlkit dialog fires up.

Nonetheless, even once created through that interface, it is not possible to connect to the wireless network.

What DID work was to create the connection throught the gnome applet. Then, the connection can be established through the plasma applet.


These tests were performed after deleting the .kde4/share/apps/networkmanagement and restarting plasma.

Olivier
Comment by Andrea Scarpino (BaSh) - Monday, 02 May 2011, 08:37 GMT Comment by Ragheed Al-Rifaii (ragheed) - Monday, 02 May 2011, 08:50 GMT
@BaSh
my bad it's polkit not polkit-kde. seems i need to replace my glasses again
Comment by Lars Hupel (larsrh) - Monday, 02 May 2011, 12:14 GMT
I can confirm this behaviour. However, it seems to be intended (not that I would appreciate that change). For now, I downgraded networkmanager and also the KDE plasmoid.
Comment by Divan Santana (divansantana) - Monday, 02 May 2011, 13:00 GMT
My problems since the update are:
- My hidden wireless network no longer autoconnects, used to work perfectly consistently before
- My wireless networks are now missing in the plasma network management applet
- I can't add a new one
- I added a new one via kdesu systemsettings but then can't edit it(permission denied), and can't see it in the plasma network management applet view therefore can't click to connect
- And it doesn't auto connect at all to the hidden wireless network
- Therefore no wireless access to hidden network
- If I try delete or edit the hidden wireless via systemsettings(or kdesu) network settings, network connections etc, it crashes eveytime.
- If I try delete the hidden wireless via applet, manage connections, get error "Removing connection failed. Error code is 0/2 ()."
- system connection option is now greyed out, never used to be
- Mobile Broadband tab is now greyed out, never used to be
Comment by Divan Santana (divansantana) - Monday, 02 May 2011, 13:07 GMT
I made my wireless not hidden, and removed all under .kde4/share/apps/networkmanagement and restarted plasma.
Then clicked on my wireless network via kde plasma network management applet and it works.
Made it hidden again, but then I found it impossible to connect again since it doesn't show up in the applet anymore.

For now leaving it unhidden.
- Mobile Broadband tab is still greyed out
- system connection option is still greyed out
Comment by Divan Santana (divansantana) - Monday, 02 May 2011, 14:46 GMT
Downgraded by doing:
sudo pacman -U /var/cache/pacman/pkg/networkmanager-0.8.3-0.20110113-x86_64.pkg.tar.xz /var/cache/pacman/pkg/networkmanager-vpnc-0.8.2-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/kdeplasma-applets-networkmanagement-git20110418-1-x86_64.pkg.tar.xz

and added below to pacman.conf
IgnorePkg = networkmanager,networkmanager-vpnc,kdeplasma-applets-networkmanagement

- All my user score type wireless networks settings are back
- Mobile Broadband tab is no longer greyed out
- Can connect to hidden wireless network again

I'm sure many all/other KDE users wireless networks /networkmanager/mobile broadband connections are going to break with this update.

Shouldn't the network manager be downgraded in the arch repos again until this is fixed? Many users won't know how to work around this and will be left with no network, if they rely on wireless.
Comment by Vladimir Djurovic (vdjurovic) - Monday, 02 May 2011, 15:55 GMT
For me, the things look like this si far:
- I can connect to wireless network I had previously, but trying to add new wireless connections gives the following error: "Adding connection failed. Error code is 0/2 ()"
- "Mobile broadband" tab is greyed out. When I plug in USB modem, it's still greyed out. From daemons.log:
May 2 17:31:06 localhost modem-manager: ModemManager (version 0.4) starting...
May 2 17:31:06 localhost modem-manager: Could not acquire the org.freedesktop.ModemManager service.
Message: 'Connection ":1.42" is not allowed to own the service "org.freedesktop.ModemManager" due to security policies in the configuration file'
May 2 17:33:41 localhost modem-manager: (Huawei): (ttyUSB1) deferring support check
May 2 17:33:41 localhost modem-manager: (ttyUSB0) opening serial device...
May 2 17:33:41 localhost modem-manager: (ttyUSB0): probe requested by plugin 'Huawei'
May 2 17:33:42 localhost modem-manager: (ttyUSB0) closing serial device...
May 2 17:33:42 localhost modem-manager: (ttyUSB0) opening serial device...
May 2 17:33:42 localhost modem-manager: (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB0
May 2 17:33:42 localhost modem-manager: Added modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
May 2 17:33:42 localhost modem-manager: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
May 2 17:33:42 localhost modem-manager: (tty/ttyUSB1): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
May 2 17:33:42 localhost modem-manager: (ttyUSB0) closing serial device...
May 2 17:33:42 localhost modem-manager: (tty/ttyUSB1): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
May 2 17:33:44 localhost modem-manager: (ttyUSB1): re-checking support...
May 2 17:33:44 localhost modem-manager: (ttyUSB1) opening serial device...
May 2 17:33:44 localhost modem-manager: (ttyUSB1) closing serial device...
May 2 17:33:44 localhost modem-manager: (Huawei): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 claimed port ttyUSB1
May 2 17:33:44 localhost modem-manager: Exported modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2 as /org/freedesktop/ModemManager/Modems/0
May 2 17:33:44 localhost modem-manager: (/org/freedesktop/ModemManager/Modems/0): data port is ttyUSB0
May 2 17:33:44 localhost NetworkManager[4087]: <warn> (ttyUSB0): failed to look up interface index
May 2 17:33:44 localhost NetworkManager[4087]: <info> (ttyUSB0): new GSM/UMTS device (driver: 'option1' ifindex: -1)
May 2 17:33:44 localhost NetworkManager[4087]: <info> (ttyUSB0): exported as /org/freedesktop/NetworkManager/Devices/2
May 2 17:33:44 localhost NetworkManager[4087]: <info> (ttyUSB0): now managed
May 2 17:33:44 localhost NetworkManager[4087]: <info> (ttyUSB0): device state change: 10 -> 20 (reason 2)
May 2 17:33:44 localhost NetworkManager[4087]: <info> (ttyUSB0): deactivating device (reason: 2).
May 2 17:33:44 localhost NetworkManager[4087]: <info> (ttyUSB0): device state change: 20 -> 30 (reason 0)

I suppose it's some kind of permissions issue.
Comment by Andrea Scarpino (BaSh) - Monday, 02 May 2011, 19:29 GMT
Seems that the KDE plasmoid is broke for most configuration, though works for basic wifi configuration like None/WEP/WPA/WAP2 Enterprise). 3G modem support and VPN are broke and also support for hidden wifi seems to be.
This is because KDE will not support Network Manager 0.9 before 4.7.

If you are using KDE, your solutions are:
0) Downgrade networkmanager to 0.8.3-0.20110113, or previous, and kdeplasma-applets-networkmanagement to git20110418-1, or previous.
1) Use the network-manager-applet of GNOME
2) Switch to wpa_supplicant/netcfg/wicd/*

Note, I had to patch kdebase-workspace 4.6.3 to build with NM09, this *could* (I cannot test it yet) broke the support for NM < 0.9; in that case the solution 0 will not work with KDE 4.6.3.
Comment by Pablo (elfio) - Tuesday, 03 May 2011, 09:57 GMT
I have the same problem. I can't add or connect to any wifi. When I try a have the bug.png pop-up. This is the dmesg output:

[ 37.621795] iwl3945 0000:0c:00.0: Start IWL Event Log Dump: display last 20 count
[ 37.621835] iwl3945 0000:0c:00.0: 0001617991 0x00000000 1002
[ 37.621857] iwl3945 0000:0c:00.0: 0000000012 0x000001b8 1005
[ 37.621879] iwl3945 0000:0c:00.0: 0000000040 0x000000d1 0103
[ 37.621901] iwl3945 0000:0c:00.0: 0000000135 0x041f0018 0401
[ 37.621923] iwl3945 0000:0c:00.0: 0000000236 0x04200097 0401
[ 37.621944] iwl3945 0000:0c:00.0: 0000000239 0x00000001 0451
[ 37.621966] iwl3945 0000:0c:00.0: 0000000259 0x00000000 0451
[ 37.621988] iwl3945 0000:0c:00.0: 0000000356 0x04210047 0401
[ 37.622009] iwl3945 0000:0c:00.0: 0000000475 0x04220047 0401
[ 37.622031] iwl3945 0000:0c:00.0: 0000000603 0x44230080 0401
[ 37.622052] iwl3945 0000:0c:00.0: 0000000617 0x00000017 0452
[ 37.622074] iwl3945 0000:0c:00.0: 0000000622 0x00173b6e 0450
[ 37.622096] iwl3945 0000:0c:00.0: 0000000627 0x00173b6e 0450
[ 37.622119] iwl3945 0000:0c:00.0: 0000000633 0x00173b6e 0450
[ 37.622143] iwl3945 0000:0c:00.0: 0000000638 0x00173b6e 0450
[ 37.622165] iwl3945 0000:0c:00.0: 0000000643 0x00173b6e 0450
[ 37.622188] iwl3945 0000:0c:00.0: 0000000648 0x001a3b6e 0450
[ 37.622210] iwl3945 0000:0c:00.0: 0000000653 0x001a3b6e 0450
[ 37.622232] iwl3945 0000:0c:00.0: 0000000658 0x001a3b6e 0450
[ 37.622254] iwl3945 0000:0c:00.0: 0000000664 0x00000100 0125
[ 37.622268] iwl3945 0000:0c:00.0: Error Reply type 0x000002FC cmd REPLY_SCAN_CMD (0x80) seq 0x4423 ser 0x00340000
[ 37.622276] iwl3945 0000:0c:00.0: Command REPLY_SCAN_CMD failed: FW Error
[ 37.626545] iwl3945 0000:0c:00.0: Can't stop Rx DMA.
[ 40.476541] EXT4-fs (sda2): re-mounted. Opts: commit=0
[ 40.916270] EXT4-fs (sda3): re-mounted. Opts: user_xattr,commit=0
[ 42.527781] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[ 67.617645] iwl3945 0000:0c:00.0: Microcode SW error detected. Restarting 0x82000008.
[ 67.617650] iwl3945 0000:0c:00.0: Loaded firmware version: 15.32.2.9
[ 67.617682] iwl3945 0000:0c:00.0: Start IWL Error Log Dump:
[ 67.617684] iwl3945 0000:0c:00.0: Status: 0x0002A2E4, count: 1
[ 67.617686] iwl3945 0000:0c:00.0: Desc Time asrtPC blink2 ilink1 nmiPC Line
[ 67.617910] iwl3945 0000:0c:00.0: SYSASSERT (0x5) 0000000515 0x008B6 0x13756 0x00320 0x00000 764

If I try by iwconfig, this is what I get:

Output of iwevent:

11:46:30.951952 wlan0 Set ESSID:"XX-XX"
11:46:30.952250 wlan0 Set Encryption key:4A
11:46:33.533587 wlan0 Scan request completed


Output of dmesg trying to connect by iwconfig:

[ 337.622378] iwl3945 0000:0c:00.0: Start IWL Event Log Dump: display last 20 count
[ 337.622423] iwl3945 0000:0c:00.0: 0001617914 0x00000000 1002
[ 337.622449] iwl3945 0000:0c:00.0: 0000000012 0x000001b8 1005
[ 337.622475] iwl3945 0000:0c:00.0: 0000000040 0x000000d1 0103
[ 337.622500] iwl3945 0000:0c:00.0: 0000000149 0x041e0018 0401
[ 337.622526] iwl3945 0000:0c:00.0: 0000000262 0x041f0097 0401
[ 337.622551] iwl3945 0000:0c:00.0: 0000000265 0x00000001 0451
[ 337.622577] iwl3945 0000:0c:00.0: 0000000284 0x00000000 0451
[ 337.622602] iwl3945 0000:0c:00.0: 0000000400 0x04200047 0401
[ 337.622628] iwl3945 0000:0c:00.0: 0000000499 0x04210047 0401
[ 337.622653] iwl3945 0000:0c:00.0: 0000000647 0x44220080 0401
[ 337.622678] iwl3945 0000:0c:00.0: 0000000662 0x00000017 0452
[ 337.622704] iwl3945 0000:0c:00.0: 0000000667 0x00163b6e 0450
[ 337.622730] iwl3945 0000:0c:00.0: 0000000672 0x00163b6e 0450
[ 337.622755] iwl3945 0000:0c:00.0: 0000000677 0x00163b6e 0450
[ 337.622780] iwl3945 0000:0c:00.0: 0000000682 0x00163b6e 0450
[ 337.622805] iwl3945 0000:0c:00.0: 0000000687 0x00163b6e 0450
[ 337.622831] iwl3945 0000:0c:00.0: 0000000692 0x00193b6e 0450
[ 337.622856] iwl3945 0000:0c:00.0: 0000000697 0x00193b6e 0450
[ 337.622881] iwl3945 0000:0c:00.0: 0000000703 0x00193b6e 0450
[ 337.622907] iwl3945 0000:0c:00.0: 0000000708 0x00000100 0125
[ 337.622931] iwl3945 0000:0c:00.0: Error Reply type 0x000002FC cmd REPLY_SCAN_CMD (0x80) seq 0x4422 ser 0x00340000
[ 337.622976] iwl3945 0000:0c:00.0: Command REPLY_SCAN_CMD failed: FW Error
[ 337.627539] iwl3945 0000:0c:00.0: Can't stop Rx DMA.
[ 401.623178] wlan0: direct probe to XX:XX:XX:XX:XX:ad (try 1/3)
[ 401.625212] wlan0: direct probe responded
[ 401.640145] wlan0: authenticate with XX:XX:XX:XX:XX:ad (try 1)
[ 401.642090] wlan0: authenticated
[ 401.647017] wlan0: associate with XX:XX:XX:XX:XX:ad (try 1)
[ 401.651270] wlan0: RX AssocResp from XX:XX:XX:XX:XX:ad (capab=0x411 status=0 aid=1)
[ 401.651278] wlan0: associated
[ 401.656679] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 401.657226] wlan0: disassociating from XX:XX:XX:XX:XX:ad by local choice (reason=3)
[ 401.658965] wlan0: deauthenticating from XX:XX:XX:XX:XX:ad by local choice (reason=3)
[ 401.696929] cfg80211: Calling CRDA to update world regulatory domain



The wifi card is ok. If I disable the networkmanager daemon from /etc/rc.conf and enable the network daemon everythings works again using iwconfig, but I have to reboot and not stop networkmanager and start network.

Sorry about my english :S. Any request just tell me.

Edit:

I'm using networkmanager 0.8.998-3 and kdeplasma-applets-networkmanagement git20110502-1. A 64bits Archlinux installation. No problem before with the wireless card.
   bug.png (17.6 KiB)
Comment by Guilherme de Sousa (guisacouto) - Wednesday, 04 May 2011, 13:16 GMT
My situation:

In nm-applet wireless networks that I use started appearing in zones that they don't exist. For example in my university it started showing my Home wireless router as available and with signal.. then I killed NetworkManager and started it again, and it showed a network I use at a coffee shop... And the worst part is that it shows my univ network (eduroam), but when I try to connect it asks for password immediately.. I insert it and it asks again, over and over.

Downgraded to NetworkManager&nm-applet and it started working again, so the problem is from the NetworkManager and not any of the dependencies I guess.

Best regards

setup:
ArchLinux i686
EeePc 1000h
Awesome WM
NetworkManager
network-manager-applet
Comment by Ionut Biru (wonder) - Wednesday, 04 May 2011, 13:17 GMT
guys stop downgrading and start reporting bugs upstream. they won't be fixed magically if nobody report them.

bugs concerning networkmanager and nm-applet should go on http://bugzilla.gnome.org
Comment by David Fajardo (davirrirri) - Thursday, 05 May 2011, 00:18 GMT
Bug reported in GNOME https://bugzilla.gnome.org/show_bug.cgi?id=649422
You can leave your comments if you have the same NM problem.
Comment by Andrea Scarpino (BaSh) - Tuesday, 24 May 2011, 17:51 GMT
good news about the KDE plasmoid!
With both kdebase-workspace 4.6.3-2 and kdeplasma-applets-networkmanagement 1:git20110524-1 wireless networks and 3G modems work again with NM09.
Comment by Divan Santana (divansantana) - Wednesday, 25 May 2011, 03:26 GMT
Andrea, thanks for this however it's not working for me at all.
Exact same problem with kdeplasma-applets-networkmanagement 1:git20110524-1 , kdebase-workspace 4.6.3-2 and kdelibs 4.6.3-2 after a reboot.

I've also got all the latest packages.

Unfortunately I had to apply this workaround and downgrade ALL of the following to get it to work again. Obviously not ideal.
sudo pacman -U /var/cache/pacman/pkg/networkmanager-0.8.3-0.20110113-x86_64.pkg.tar.xz /var/cache/pacman/pkg/networkmanager-vpnc-0.8.2-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/kdeplasma-applets-networkmanagement-git20110418-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/kdebase-workspace-4.6.3-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/kdelibs-4.6.3-1-x86_64.pkg.tar.xz

$ grep ^IgnorePkg /etc/pacman.conf
IgnorePkg = networkmanager networkmanager-vpnc kdeplasma-applets-networkmanagement kdebase-workspace kdelibs

Any idea or something else I need to do to get it to work?
Comment by Divan Santana (divansantana) - Wednesday, 25 May 2011, 06:49 GMT
Correction I was using the latest kdelibs not as my above post:
[2011-05-25 04:40] upgraded kdebase-workspace (4.6.3-1 -> 4.6.3-2)
[2011-05-25 04:40] upgraded kdelibs (4.6.3-2 -> 4.6.3-3)
[2011-05-25 04:40] upgraded startup-notification (0.10-2 -> 0.12-1)
[2011-05-25 04:42] upgraded networkmanager (0.8.3-0.20110113 -> 0.8.999-1)
[2011-05-25 04:42] upgraded kdeplasma-applets-networkmanagement (git20110418-1 -> 1:git20110524-1)
[2011-05-25 04:42] upgraded networkmanager-vpnc (0.8.2-1 -> 0.8.999-1)

The KDE plasmoid still didn't work.

Also the correct downgrade/workaround instructions are
$ grep ^IgnorePkg /etc/pacman.conf
IgnorePkg = networkmanager networkmanager-vpnc kdeplasma-applets-networkmanagement kdebase-workspace kdelibs

sudo pacman -U /var/cache/pacman/pkg/networkmanager-0.8.3-0.20110113-x86_64.pkg.tar.xz /var/cache/pacman/pkg/networkmanager-vpnc-0.8.2-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/kdeplasma-applets-networkmanagement-git20110418-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/kdebase-workspace-4.6.3-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/kdelibs-4.6.3-2-x86_64.pkg.tar.xz
Comment by Andrea Scarpino (BaSh) - Wednesday, 25 May 2011, 08:05 GMT
Sorry Divan, don't know why doesn't work for you. Maybe you could try to delete /var/lib/NetworkManager and reinstall 0.9 again
Comment by Ragheed Al-Rifaii (ragheed) - Wednesday, 25 May 2011, 10:22 GMT
connections are working ok now ... UMTS modems are working also ... but i'm still not getting my old connections list ... any idea about this issue ?
Comment by Divan Santana (divansantana) - Monday, 30 May 2011, 11:38 GMT
Andrea, I tried your suggestion, applied the latest updates.
Then did this:
sudo /etc/rc.d/networkmanager stop
sudo pacman -R kdeplasma-applets-networkmanagement networkmanager networkmanager-dispatcher-ntpd networkmanager-vpnc
sudo rm -rf /var/run/NetworkManager /var/lib/NetworkManager /etc/NetworkManager
mv /home/divan/.kde4/share/config/networkmanagementrc ~/Desktop
mv ~/.kde4/share/apps/networkmanagement/connections/* ~/Desktop

Then installed latest versions of the below after removing the IgnorePkg line in pacman.conf
sudo pacman -S kdeplasma-applets-networkmanagement networkmanager networkmanager-dispatcher-ntpd networkmanager-vpnc

Rebooted

Exact same bug as before, hidden wireless doesn't work at all no matter what. Mobile broadband tab is greyed out.
I can connect to wireless network if it's not hidden.

Can you confirm that the above stuff that's not working for me is working for you? Don't understand why it would work for you and not me...

Another guy in the office here is going to attempt this on his Arch system now and we'll see if it works for him.
Comment by Divan Santana (divansantana) - Tuesday, 31 May 2011, 16:49 GMT
Andrea, I've checked with two other friends running Arch Linux and KDE.
Both of them when applying latest updates have the exact same bug as me.

Therefore, don't you think maybe kdebase-workspace, kdelibs and kdeplasma-applets-networkmanagement should be updated back to the previous versions?
This way people will be able to connect to hidden networks and still use their mobile broadband.
Hopefully otherwise when 4.6.4 comes we won't be able to update to 4.6.4 unless we break the above.
Comment by Ionut Biru (wonder) - Tuesday, 31 May 2011, 16:53 GMT
just install network-manager-applet and modemanager and profit until is fixed
Comment by Andrea Scarpino (BaSh) - Tuesday, 31 May 2011, 19:59 GMT
@Divan
I don't know why the updated packages don't work for you and your friends, but for me and others archers; anyway I'll explain here the difference between the old version and the new:
In both kdebase-workspace 4.6.2-1 and 4.6.3-1, I patched the NM-solid backend for NM08 to build with NM09.
In kdebase-workspace 4.6.3-2 the NM-solid backend is disabled.
The latter version in [extra] of kdeplasma-applets-networkmanagement provides the NM-solid backend for NM09. Then, the updated packages in [extra] provide the right configuration in KDE for NM0.9. If you are getting some trouble you should report the bug to bugs.kde.org.
Also I'm updating now kdeplasma-applets-networkmanager to last git.
Comment by Divan Santana (divansantana) - Wednesday, 01 June 2011, 08:21 GMT
@Ionut Yeah I could do that but Andrea is saying it's working his side so that's concerning me about what's wrong on our laptops. Also, I believe this is going to effect a lot of KDE users on Arch negatively. Anyway Arch Users should be competent enough to work around this problem.

@Andrea
Thanks very much for the feedback and latest updates.
Unfortunately testing again this morning and not working yet. Exact same problems, all my saved connections disappear, hidden wireless cant work, broadband tab greyed out.

Wierd thing is you've got it working, I have no idea how, maybe it's my set up. I'll workaround this bug, and wait for a future update which I'm sure will fix it sometime.

Thanks,
Comment by Asem (asem) - Wednesday, 01 June 2011, 10:31 GMT
Ok guys,
i have a side note
on wikipedia they report that the last stable version of networkmanager is 0.8.4.0

I don't know how packaging works, but i think we always have stable releases on extra
Comment by Ionut Biru (wonder) - Wednesday, 01 June 2011, 10:44 GMT
it is but that version is not compatible with gnome 3.
Comment by Andrea Scarpino (BaSh) - Wednesday, 01 June 2011, 10:49 GMT
AFAIK Gnome 3 needs NM >= 0.9

I guess we can close this bug or please remember me the goal.
Comment by Asem (asem) - Wednesday, 01 June 2011, 10:51 GMT
the problem is networkmanger droped userbased connections , and the applets (kde and gnome) didn't adapt the change well
Comment by Divan Santana (divansantana) - Monday, 27 June 2011, 12:27 GMT
Yey the latest updates definitely fixes this 100%. :)
I've confirmed with a few people that this is working again.
kdeplasma-applets-networkmanagement 1:git20110620-1
Comment by Jesus Gonzalez (txus) - Tuesday, 28 June 2011, 11:12 GMT
Still doesn´t work here, with XFCE & networkmanager 0.8.9997-1 & network-manager-applet 0.8.9997-1. Only system connections, and asks for root password for new connections (and they are systemwide when created) (e.g. new wifi network).
Also doesn´t seem to store the passwords with gnome-keyring, because it doesn´t ask for the keyring password. Plus, when deactivating wireless through the applet´s menu, I can´t seem to be able to get it back on.

Generally speaking, it seems like my user is not able to "touch" networkmanager at all. Versions 0.8.3 were working perfectly.
Comment by Ionut Biru (wonder) - Tuesday, 28 June 2011, 11:20 GMT
@txus maybe you didn't get but it was already said multiple times here. UserSettings is dropped from 0.9[1] and only system connections are supported and the fact is asking root password is because upstream doesn't include a proper polkit policies.[2]

[1] http://live.gnome.org/action/login/NetworkManager/RemovingUserSettings
[2] https://bugzilla.gnome.org/show_bug.cgi?id=652128

the fact that is doesn't store passwords in keyring might be a bug but is it logically not to do it because of system connections. every user should be able to use it. If you are not satisfied about this report it upstream as regression for wireless networks.

I'm going to close this bug because there are clearly upstream changes and not bugs
Comment by Jesus Gonzalez (txus) - Tuesday, 28 June 2011, 11:28 GMT
@wonder I was well aware that user settings were dropped in 0.9, but you gave the advice of using nm-applet, which doesn´t work for me and it actually IS working for some people apparently, hence the reporting. And thanks about the polkit policy advice, didn´t look into that.
Comment by André Felício (antigerme) - Tuesday, 28 June 2011, 18:58 GMT
It's work for me.
Comment by Suraj N. Kurapati (sunaku) - Monday, 11 July 2011, 21:57 GMT
I disagree with André Felício. The network*manager* packages (at version 0.8.999*-1) do not work for me under a lightweight tiling window manager (wmii) that is launched by the startx command from a Linux Virtual Terminal. (I do not use KDE or GNOME.)
Comment by Ionut Biru (wonder) - Wednesday, 19 October 2011, 14:15 GMT
is there anything to do here?
Comment by Andrea Scarpino (BaSh) - Wednesday, 19 October 2011, 14:41 GMT
No.
Comment by Suraj N. Kurapati (sunaku) - Friday, 21 October 2011, 23:16 GMT
I followed the instructions at https://wiki.archlinux.org/index.php/NetworkManager#Set_up_PolicyKit_permissions to create a /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla file and then added the following to my xinitrc file before my window manager is run:

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
nm-applet --sm-disable &

Now NetworkManager works correctly. I'm able to add new connections and see all the existing ones.

There is one minor bug though: the GTK2 style in my user account (zukitwo theme) is not applied to the nm-applet menu or its dialog windows. Any idea how to fix this?
Comment by Suraj N. Kurapati (sunaku) - Thursday, 27 October 2011, 04:06 GMT
Never mind. I learned that nm-applet uses GTK3, for which I didn't have any theme specified. I followed the instructions at https://wiki.archlinux.org/index.php/GTK%2B#GTK.2B_3.x and specified a GTK3 theme and now nm-applet is beautiful on my system.

I have no more objections to closing this bug report. Problems solved (for me anyway).

Loading...