Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#24005 - Remove unused dependencies of a package when solving package conflicts.

Attached to Project: Pacman
Opened by Karol Błażewicz (karol) - Saturday, 30 April 2011, 22:06 GMT
Last edited by Allan McRae (Allan) - Saturday, 04 August 2012, 08:41 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.5.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

[karol@black ~]$ sudo pacman -S mplayer2
resolving dependencies...
looking for inter-conflicts...
:: mplayer2 and mplayer are in conflict. Remove mplayer? [y/N]

pacman removes just mplayer and leaves all the 'dangling' dependencies - packages that were needed by mplayer, but are not needed by mplayer2. Can this behavior be changed to 'pacman -Rns mplayer'? Can you include such an option in pacman.conf / add a flag to 'pacman -S' or are users expected to deal with this manually by periodically invoking 'pacman -Qdt'?
I know that in many cases this would result in uninstalling and reinstalling back many packages so the current way has some merit, but, as litemotiv noted [1], maybe it can be done in a more intuitive way.

[1] https://bbs.archlinux.org/viewtopic.php?pid=915037#p915037
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 04 August 2012, 08:41 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#5974
Comment by Karol Błażewicz (karol) - Monday, 02 May 2011, 21:50 GMT
It seems to be related to FS#5974.

Loading...