Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23920 - [garcon] Missing translations of menu entries

Attached to Project: Arch Linux
Opened by Laszlo Dvornik (laci) - Sunday, 24 April 2011, 19:24 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 18 June 2011, 18:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Xfce Graphics and System menu entries' translations are missing.

See these files:
/usr/share/desktop-directories/xfce-graphics.directory
/usr/share/desktop-directories/xfce-settings.directory

Something bad at packager's build environment, because if I rebuild the package with the same PKGBUILD at my machine the two files generate good. So please try to rebuild. The previous 0.1.5-1 version was good.

Additional info:
* garcon 0.1.7-1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 18 June 2011, 18:06 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Sunday, 01 May 2011, 18:45 GMT
both look fine on my system. attaching them here.
Comment by Laszlo Dvornik (laci) - Tuesday, 03 May 2011, 05:50 GMT
Hm, xfce-graphics.directory and xfce-settings.directory translations are missing only in the garcon-0.1.7-1-i686.pkg.tar.xz package, the x86_64 package (garcon-0.1.7-1-x86_64.pkg.tar.xz) is not affected.
Comment by Andreas Radke (AndyRTR) - Friday, 17 June 2011, 21:50 GMT
[root@workstation64 tmp]# pacman -Ql garcon | wc -l
203

[andyrtr@workstation64 trunk]$ tar -tvf ~/arch64/packages/garcon-0.1.7-1-i686.pkg.tar.xz | wc -l
204
[andyrtr@workstation64 trunk]$ tar -tvf ~/arch64/packages/garcon-0.1.7-1-x86_64.pkg.tar.xz | wc -l
204

Please remove your pkg, also from pkg cache and fetch a new one from a different mirror. Then all should be fine. https://www.archlinux.org/packages/extra/i686/garcon/ also shows all files included.
Comment by Laszlo Dvornik (laci) - Saturday, 18 June 2011, 05:09 GMT
You misunderstood the problem Andreas. The xfce-graphics.directory and xfce-settings.directory files are in the package, and "wc -l" only shows the number of files in package. The translations are missing from these two files in the i686 package, however the x86_64 package contains the translations.

Note: The *.directory files are platform-independent.
Note2: I tried mirrors.kernel.org and three other mirrors, none of i686 package of garcon are good in mirrors.

I'm sorry that the packager of garcon can't fix this easily solvable problem since 2 months.
Comment by Andreas Radke (AndyRTR) - Saturday, 18 June 2011, 09:12 GMT
I don't know should be broken in the i686 package when all /usr/share/locale/XX/LC_MESSAGES/garcon.mo files are included? And both are almost equal size as expected:
[root@workstation64 tmp]# ls -lha /home/andyrtr/arch64/packages/garcon-0.1.7-1-*
-rw-r--r-- 1 nobody nobody 73K 16. Apr 13:21 /home/andyrtr/arch64/packages/garcon-0.1.7-1-i686.pkg.tar.xz
-rw-r--r-- 1 nobody nobody 77K 16. Apr 13:17 /home/andyrtr/arch64/packages/garcon-0.1.7-1-x86_64.pkg.tar.xz

Sure I can do a simple -2 rebuild but why are you the only one complaining so far? So it might be your package that somehow went broken?
Comment by Laszlo Dvornik (laci) - Saturday, 18 June 2011, 10:59 GMT
Not garcon.mo files are the problem. Compare /usr/share/desktop-directories/xfce-graphics.directory and /usr/share/desktop-directories/xfce-settings.directory files in i686 and x86_64 package.

I downloaded the package with wget from 3 different mirrors and every contain bad xfce-graphics.directory and xfce-settings.directory files in i686.

Yes, I think the rebuild would solve the problem.
Comment by Andreas Radke (AndyRTR) - Saturday, 18 June 2011, 13:25 GMT
[root@workstation64 ~]# ls -lha /home/andyrtr/arch64/packages/garcon-0.1.7-*
-rw-r--r-- 1 nobody nobody 73K 16. Apr 13:21 /home/andyrtr/arch64/packages/garcon-0.1.7-1-i686.pkg.tar.xz
-rw-r--r-- 1 nobody nobody 77K 16. Apr 13:17 /home/andyrtr/arch64/packages/garcon-0.1.7-1-x86_64.pkg.tar.xz
-rw-r--r-- 1 nobody nobody 77K 18. Jun 15:21 /home/andyrtr/arch64/packages/garcon-0.1.7-2-i686.pkg.tar.xz
-rw-r--r-- 1 nobody nobody 77K 18. Jun 15:20 /home/andyrtr/arch64/packages/garcon-0.1.7-2-x86_64.pkg.tar.xz

I've checked the *.directry files and translations seem included now. No idea what happened last. Please conform 0.1.7-2 to be fixed.
Comment by Laszlo Dvornik (laci) - Saturday, 18 June 2011, 16:01 GMT
Thanks, xfce-graphics.directory and xfce-settings.directory now contains the translations in i686 package. But unfortunately now xfce-office.directory file is bad in i686 packages. The x86_64 package is ok. I don't know what's the problem. Something ni your build system perhaps?

Ps: Before commit newer packages please compare /usr/share/desktop-directories/*.directory files between i686 and x86_64 packages of garcon. Every files should have to be same sizes and contents.
Comment by Andreas Radke (AndyRTR) - Saturday, 18 June 2011, 17:11 GMT
I could reproduce the build error here on almost every 2nd build for i686. Disabling smp build seems to solve this. Please confirm it now fixed.
Comment by Laszlo Dvornik (laci) - Saturday, 18 June 2011, 17:54 GMT
Thanks, garcon-0.1.7-3 fixes the problem. Please close this bug report.

Loading...