Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23916 - [udev] keyboard/mouse not working with udev 167

Attached to Project: Arch Linux
Opened by Rémy Guillemette (Shaika-Dzari) - Sunday, 24 April 2011, 15:15 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 12 May 2011, 15:01 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
To get my keyboard and my mouse under X server, I must unplug them and plug them back.
This issue appeared after upgrading udev to 167-1.

I'm not sure but this issue may be already fixed in initscripts 2011.04.1 (which support the new /run).
initscripts in core is 2011.02.1.

My keyboard and my mouse are back to normal under X if I downgrade udev to 166


Additional info:
* udev 167-1 on Archlinux x86_64
* People with the same issue: https://bbs.archlinux.org/viewtopic.php?id=117274

Steps to reproduce:
- full system upgrade without using testing.
- reboot
- start your favorite WM with startx
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 12 May 2011, 15:01 GMT
Reason for closing:  Fixed
Comment by Vampir achtneunacht (Vamp898) - Tuesday, 26 April 2011, 23:23 GMT
Happens for me too with udev 168

also my Portable Media Player is not working since 167 and my system is not booting when this player is plugged (it hangs on udev for years)

Also appears with 2011.04.1-1 of initscripts
Comment by Andrew K. (avallac_h) - Wednesday, 27 April 2011, 13:39 GMT
It seems that installation of "udev-compat 167-1" package solves this problem. Although, I may be wrong.
Comment by h (Cdh) - Wednesday, 27 April 2011, 16:07 GMT
I have not investigated much but when the touchpad isn't working issuing
"udevadm trigger --subsystem-match=input"
enables it.

So in theoretical works and the problem is a mis-initialization somewhere.
Comment by Rémy Guillemette (Shaika-Dzari) - Wednesday, 27 April 2011, 16:21 GMT
udev-compat 167-1 did not solve the problem for me.
Comment by Ty John (sandman) - Friday, 29 April 2011, 03:21 GMT
Someone mentioned on the bbs that it seems to be motherboard specific. Not sure where that information came from but for what it's worth my motherboard is a Gigabyte GA-880GM-USB3
Comment by pedram (multiphrenic) - Saturday, 30 April 2011, 02:03 GMT
I'm also having this problem except the keyboard works fine. I posted the logs on the forums. Downgrading to udev16 fixed the problem.
https://bbs.archlinux.org/viewtopic.php?id=117823
Comment by Rémy Guillemette (Shaika-Dzari) - Saturday, 30 April 2011, 02:28 GMT
Hello everyone!

I found a fix on debian forum...

1- update your system
2- reboot
3- log as root
4- move /run folder : cd / && mv run run.bak
5- reboot

Now it's working fine.
More info : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=621036#77

Comment by Ty John (sandman) - Saturday, 30 April 2011, 08:45 GMT
This problem seems to have gone away for me. I have been getting confused between this and another problem to do with udev and my scsi DVD drive (ata_id problem) but I think the upgrade to kernel26-2.6.38.4 worked it out.
I was about to try Shaika-Dzari's solution and then realised that my keyboard and mouse is already working :P
Comment by JM (fijam) - Tuesday, 03 May 2011, 09:13 GMT
Does the problem persist for anyone else?
Comment by MvW (wessie) - Tuesday, 03 May 2011, 09:29 GMT
Shaika-Dzari's method fixes it for me.
Comment by JM (fijam) - Tuesday, 03 May 2011, 10:55 GMT
This shouldn't be necessary. It is also unknown if a next udev or filesystem update won't break it again. This bug should be confirmed and assigned.
Comment by Ty John (sandman) - Tuesday, 03 May 2011, 12:29 GMT
My apologies. This is actually still happening for me. It stopped when I switched to systemd but I can easily reproduce it by booting with Arch's initscripts.
I have not updated to the latest initscripts yet because my bandwidth has been throttled.
Comment by Ty John (sandman) - Saturday, 07 May 2011, 23:07 GMT
> pacman -Q {udev,kernel26,initscripts}
udev 167-2
kernel26 2.6.38.5-1
initscripts 2011.04.1-2

All working fine now.

Loading...