Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23914 - [gcc-4.6.0-3] - cannot build kernel26-lts-ck package

Attached to Project: Arch Linux
Opened by John (graysky) - Sunday, 24 April 2011, 13:49 GMT
Last edited by Allan McRae (Allan) - Sunday, 24 April 2011, 21:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Ever since the bump to gcc 4.6.0, I have been unable to build my kernel26-lts-ck package located here: http://aur.archlinux.org/packages.php?ID=45902. Building via makepkg works fine under the previous version of (gcc 4.5.2 20110127) contained in now outdated gcc-4.5.2-6-x86_64.pkg.tar.xz

This is true under either x86_64 or i686.

The last few lines of output are contained in the pastebin URL below. Note that that "warning: variable ‘xxx’ set but not used [-Wunused-but-set-variable]" is EVERYWHERE since 4.6.0 and I know that the warning is harmless. I should add that the error occurs in the "make modules" step of the PKGBUILD; the "make bzImage" completes without indecent.

Additional info:
* package version(s) gcc-4.6.0-3
* config and/or log files etc. http://pastebin.com/EvSJGgDj

Steps to reproduce: Attempt to build kernel26-lts-ck from the AUR using gcc-4.6.0-3
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 24 April 2011, 21:44 GMT
Reason for closing:  Not a bug
Comment by John (graysky) - Sunday, 24 April 2011, 13:50 GMT
I should add that I don't know if this is an upstream problem or one unique to the Arch packaging. Thanks for helping me sort it out.
Comment by Allan McRae (Allan) - Sunday, 24 April 2011, 13:56 GMT
Those warnings are just warnings. The actual error will be above that.

My guess is the issues is in drivers/net/igbvf/ethtool.c. See https://lkml.org/lkml/2011/3/9/226 .
Comment by Allan McRae (Allan) - Sunday, 24 April 2011, 14:03 GMT Comment by John (graysky) - Sunday, 24 April 2011, 15:03 GMT
You're the man, Allan. Added that patch and the build finishes successfully. Thanks a million!

Loading...