Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23911 - [nfs] mounting NFSv4 fails on very fast systems

Attached to Project: Arch Linux
Opened by Andreas Radke (AndyRTR) - Sunday, 24 April 2011, 10:28 GMT
Last edited by Tom Gundersen (tomegun) - Wednesday, 18 May 2011, 15:38 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Tom Gundersen (tomegun)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Mounting a NFSv4 share the "netfs" hook fails to mount it giving a "no route to host". This only happens on my fastest SandyBridge Quad core system with a SSD as boot drive. All other clients can mount it well. See also
https://bbs.archlinux.org/viewtopic.php?id=113497. Not sure if this is related to the NFS packages or because our initscripts give a return to fast before the connection is really online. Maybe there's somewhere a "&" after a call that shouldn't be there. Therefor I also assign it to our initscript maintainer.

I have to add "mount /mnt/nfs" to my rc.local that most times works at that late state.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Tom Gundersen (tomegun)
Wednesday, 18 May 2011, 15:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Probably fixed by udev-168-2. Please reopen if that's not the case.
Comment by Tom Gundersen (tomegun) - Sunday, 24 April 2011, 13:59 GMT
@AndyRTR:

What is your fstab entry?

I think one solution might be to make netcfg not fork until it has set up all connections (and dhcp has finished setting up). I thoght nfs should keep trying to connect even if there is not connection at first try though...
Comment by Andreas Radke (AndyRTR) - Sunday, 24 April 2011, 14:24 GMT
fstab entry:

192.168.0.90:/ /mnt/nfs nfs4 user 0 0

On my desktop where this fails to mount I don't use netcfg but plain rc.conf static IP adress configuration. Notebook that can mount it use netcfg and wlan.
Comment by Tom Gundersen (tomegun) - Sunday, 24 April 2011, 15:07 GMT
Ah, good to know, I misunderstood.
You are right, we probably need to wait for dhcp to finish.

However, I should point out that just because we have an IP doesn't mean you can access your server (in your case it probably does), so this is not a satisfactory solution. Have you tried giving some options to nfs in fstab to make it retry mounting until it succeeds? I'm not sure but I thought this should be possible.
Comment by Andreas Radke (AndyRTR) - Sunday, 24 April 2011, 17:47 GMT
- I don't use dhcp
- I don't know any option you mean. But I use "nofail" in my notebooks fstab.
Comment by Tom Gundersen (tomegun) - Sunday, 01 May 2011, 01:08 GMT
Sorry for the late reply, I have not been able to find a bug in the network script. It might be that ifconfig is asynchronous (I have not looked into the source yet) and that for some reason it takes a long time to set your ip.

Could you post your rc.conf?
Comment by Andreas Radke (AndyRTR) - Sunday, 01 May 2011, 16:25 GMT
attaching rc.conf
   rc.conf (3.8 KiB)
Comment by Tom Gundersen (tomegun) - Tuesday, 17 May 2011, 18:54 GMT
@Andy: could you reconfirm this with udev-168-2?
Comment by Andreas Radke (AndyRTR) - Tuesday, 17 May 2011, 20:37 GMT
Last boot with udev 168-2 went fine mounting nfsV4. I'll have an eye on this. Give me a few more reboots.
Comment by Tom Gundersen (tomegun) - Wednesday, 18 May 2011, 15:37 GMT
Cool. Please reopen if it reoccurs :-)

Loading...