Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23898 - [gcc 4.6] gcc 4.6 not compile some AUR packages, example: kompozer, gcc 4.5.2 yes

Attached to Project: Arch Linux
Opened by synflag (synflag) - Saturday, 23 April 2011, 08:19 GMT
Last edited by Allan McRae (Allan) - Saturday, 23 April 2011, 09:17 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


gcc 4.6 in stable, no compile kompozer from AUR, error:

/tmp/yaourt-tmp-synflag/aur-kompozer/src/mozilla/layout/style/nsCSSStyleSheet.cpp: En la función ‘PRBool SelectorMatches(RuleProcessorData&, nsCSSSelector*, PRInt32, nsIAtom*, PRInt8)’:
/tmp/yaourt-tmp-synflag/aur-kompozer/src/mozilla/layout/style/nsCSSStyleSheet.cpp:3346:58: aviso: la conversión de ‘PRInt8’ desde ‘int’ puede alterar su valor [-Wconversion]
make[4]: *** [nsCSSStyleSheet.o] Error 1
make[4]: se sale del directorio `/tmp/yaourt-tmp-synflag/aur-kompozer/src/obj-kompozer/layout/style'
make[3]: *** [libs] Error 2
make[3]: se sale del directorio `/tmp/yaourt-tmp-synflag/aur-kompozer/src/obj-kompozer/layout'
make[2]: *** [tier_9] Error 2
make[2]: se sale del directorio `/tmp/yaourt-tmp-synflag/aur-kompozer/src/obj-kompozer'
make[1]: *** [default] Error 2
make[1]: se sale del directorio `/tmp/yaourt-tmp-synflag/aur-kompozer/src/obj-kompozer'
make: *** [build] Error 2


With gcc 4.5.2 multilib compile fine, suggestion: restore stable gcc 4.5.2 to stable and remove 4.6.-
Only gcc 4.6 extra feature, support i7 -march, few users compile flags used to i7, and I think it is a very high cost just to have the flag for i7.

Additional info:
* package version(s)
* config and/or log files etc.
gcc 4.6 in stable

Steps to reproduce:

yaourt -S kompozer, Err, with gcc 4.6, downgrade gcc 4.5.2 and compile fine and stable software.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 23 April 2011, 09:17 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The PKGBUILD in AUR needs updated.
Comment by Ionut Biru (wonder) - Saturday, 23 April 2011, 08:28 GMT
suggestion: fix the damn code or PKGBUILD
Comment by Greg (dolby) - Saturday, 23 April 2011, 08:37 GMT
And try to reproduce with pacman, cause yaourt may also be a problem in situations like these as well.