Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23884 - [udev]boot time fsck fail

Attached to Project: Arch Linux
Opened by Jason (Meyithi) - Friday, 22 April 2011, 12:52 GMT
Last edited by Tom Gundersen (tomegun) - Friday, 22 April 2011, 16:07 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture i686
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
/ is mounted rw after upgrade to udev 167-1, hence boot time fsck fails with a warning about fsck on a mounted filesystem.

Error message:
Mounting Root Read-only [FAIL] /dev/sda4 is mounted
Checking Filesystem
warning: The filesystem is mounted if you continue you will cause severe filesystem damage
Do you really want to continue (y/n)?

Additional info:
* package version(s)
udev 167-1

Forum thread @ https://bbs.archlinux.org/viewtopic.php?id=117257

Also see https://bugs.archlinux.org/task/23845 which I believe to be same bug but not assigned to any package.

This issue is resolved by downgrading to udev 166-2.

Steps to reproduce:
1) Install udev 167-1
2) Reboot
3) fsck fails at mounted filesystem
This task depends upon

Closed by  Tom Gundersen (tomegun)
Friday, 22 April 2011, 16:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:  This is a duplicate of:  FS#23845 , please keep the discussion there.
Comment by Jason (Meyithi) - Friday, 22 April 2011, 15:46 GMT
Using grub2, the udev upgrade appears to have placed "rootflags=rw" into my grub.cfg - http://paste.pocoo.org/show/376384/ - removing the additional flags solved my problem.
   grub.cfg (1.6 KiB)

Loading...