Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23874 - [vimpager] 1.4.8-1 -- vimpager script has dos line endings causing crash.

Attached to Project: Community Packages
Opened by arielp (ajp) - Thursday, 21 April 2011, 17:53 GMT
Last edited by Florian Pritz (bluewind) - Thursday, 28 April 2011, 14:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Florian Pritz (bluewind)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: After upgrade to vimpager 1.4.8-1 vimpager stopped working with the error: "/usr/bin/vimpager: /bin/sh^M: bad interpreter: No such file or directory."


Steps to reproduce: rum vimpager from the command prompt.

Converting the /usr/bin/vimpager file to unix line endings fixed the problem. (:set ff=unix in vim)
This task depends upon

Closed by  Florian Pritz (bluewind)
Thursday, 28 April 2011, 14:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  vimpager-1.4.8-2
Comment by jwbirdsong (jwbirdsong) - Saturday, 23 April 2011, 20:53 GMT
APPARENTLY this has been fixed upstream.
A rebuild/install via ABS now yields a usable vimpager.
Tested above on x86_86 only
Comment by Nuno (quarkup) - Wednesday, 27 April 2011, 23:34 GMT
Just need to change from DOS to UNIX EOF characters.

Loading...