Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23869 - [kdelibs] VLC 1.1.9 crashes because of invalid QtDBus access

Attached to Project: Arch Linux
Opened by synflag (synflag) - Thursday, 21 April 2011, 13:48 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 01 September 2011, 23:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

libQtDBus.so.4.7.2 cause a segfault using vlc 1.1.9, version 1.1.7 no cause this bug, vlc continue playing until crash in few minutes. Playing video, music, mp3, etc

Apr 21 09:33:34 localhost kernel: vlc[3637]: segfault at 8 ip 00007f08e277995b sp 00007fffaa8fb188 error 4 in libQtDBus.so.4.7.2[7f08e2739000+77000]
Apr 21 09:36:39 localhost kernel: vlc[3940]: segfault at 8 ip 00007f19dde8195b sp 00007fff249ccba8 error 4 in libQtDBus.so.4.7.2[7f19dde41000+77000]

in /var/log/messages.log

This bug is reported in bugs.kde in year 2010-04-15, las edited 2011-04-13:

https://bugs.kde.org/show_bug.cgi?id=234484

Author of Patch suggested: http://lists.kde.org/?l=kde-core-devel&m=130268229205730&w=2

Patch's: https://git.reviewboard.kde.org/r/100577/diff/

> kio/kio/scheduler.cpp d5fab85
> kio/bookmarks/kbookmarkmanager.cc 9086fd2
> kio/kio/fileundomanager.cpp ca1cbbb

Report in Ubuntu: https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/408719
Report in VLC forum: http://forum.videolan.org/viewtopic.php?f=13&t=89519


Attached vlc.txt, contain vlc open in terminal and segfault and calls

Additional info:
* package version(s)

vlc 1.1.9
kde 4.6.2
QT 4.7.2-6
Kernel 2.6.38.3
Xorg 1.10
Nvidia 270.41.06
System all up date.
* config and/or log files etc.


Steps to reproduce:

Open vlc, open a file video, or audio, wait a few minutes, and crash.

   vlc.txt (1.3 KiB)
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 01 September 2011, 23:50 GMT
Reason for closing:  No response
Comment by Thor (thorflanders) - Sunday, 24 April 2011, 15:17 GMT
Likewise here

about VLC

VLC media player 1.1.9 The Luggage (revision exported)
VLC version 1.1.9 The Luggage (exported)
Compiled by nobody on alderaan.archlinux.org (Apr 12 2011 10:25:53)
Compiler: gcc version 4.5.2 20110127 (prerelease) (GCC)


"This program comes with NO WARRANTY, to the extent permitted by law." - interesting ;)

Xorg

X.Org X Server 1.10.0.902 (1.10.1 RC 2)
Release Date: 2011-04-08
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-ARCH i686

Gnome 2.32.1 - 11/17/2010

To reproduce : as mentioned, load some media, wait and see it crash. There's a lot of activity. Mine takes the system down with it at times. I'm positive about flv's and mp4's, mp3's seem to "behave"...though vlc sometimes "chops" the sound up...

When loaded from the console, my output is similar to the attached dump...

Thor
Comment by synflag (synflag) - Monday, 25 April 2011, 16:30 GMT
Yes i reported to vlc manteinet, but he answer "works for me", pretty answer hahaha.
I don't know if the bug is VLC or kdelibs, is reported in vlc forum that a QT bug.
While, i use the version 1.1.7 and work fine, but 1.1.9 crash and crash QT lib.
Thanks Thor for add your comment.
Comment by Malix (Malix) - Thursday, 05 May 2011, 08:47 GMT
I'm using kde, so not sure if this is related (edit: but symptoms are similar), but my vlc corrupted whole screen and even crashed whole system.

Checked qtconfig and saw I had oxygen-transparent (from aur) set as GUI style, changed it to "Destop Settings (default)" (currently oxygen) and the whole crashing/corrupting seems to have ceased completely. so possibly just a case of outdated theme?
Comment by synflag (synflag) - Saturday, 07 May 2011, 06:28 GMT
After update of qt and kde 4.6.3 this bug is parcially solved:

VLC media player 1.1.9 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x936c8fc] main libvlc: Ejecutar vlc con la interfaz predeterminada. Usa «cvlc» para usar vlc sin interfaz.
Blocked: call to setlocale(6, "")
Blocked: call to setlocale(6, "")
Blocked: call to putenv("LANGUAGE=")
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
Warning: call to srand(-1534761199)
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()
Violación de segmento




Steps:

vlc in konsole

open file

close vlc
segfault

Note: if you no click in open file, segfault is no appear.
Note2: if you ran vlc in terminal with cvlc never appear segfault, so, the bug is in the GUI of vlc
Note3: in /var/log/messages the bug persist:

May 7 03:26:25 localhost kernel: [ 3366.931791] vlc[15703]: segfault at 4 ip b11c49a5 sp bf955e60 error 4 in libQtDBus.so.4.7.3[b1185000+79000]
Comment by Hugo Lobo (eldarion) - Monday, 18 July 2011, 20:28 GMT
Could this be related to my bug report  FS#24991 . In my case, Opera crashes when opening the open/save dialog. vlc also crashes with seg fault doing the same. The strange thing that i don't see reported here is that with my system, both Opera and VLC don't apply the Oxygen style (the theme is reverted to the Windows style). Could this be a different issue?
Comment by Fabian Homborg (alfa) - Monday, 08 August 2011, 23:51 GMT
Is this still a problem with KDE (SC) 4.7 and vlc 1.1.11-3?

Loading...