Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23863 - [curl] https transfers fail through proxy

Attached to Project: Arch Linux
Opened by Dave Reisner (falconindy) - Wednesday, 20 April 2011, 23:45 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 25 April 2011, 00:03 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


curl 7.21.5 introduces a regression where https transfers will fail due to checking the incorrect internal struct after the connection is established. It was caught today and already fixed in git. Patch from curl's repo is attached.

bug report from ML:
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 25 April 2011, 00:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  curl 7.21.6-1
Comment by Skottish (skottish) - Thursday, 21 April 2011, 02:05 GMT
I can confirm the behavior with privoxy and the effectiveness of the patch. Please implement this patch.
Comment by simon (sausageandeggs) - Thursday, 21 April 2011, 06:18 GMT
Can confirm also, patch fixes things
Comment by Dave Reisner (falconindy) - Thursday, 21 April 2011, 11:01 GMT
This has turned out to be a fairly big deal. 7.21.6 will be tagged and released tomorrow. So this can probably go untouched.