Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23859 - [srcpac] fails to build same pkg twice

Attached to Project: Arch Linux
Opened by Steffen Weber (boenki) - Wednesday, 20 April 2011, 17:20 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 26 April 2011, 21:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I tried to compile a pkg twice with different configurations.
The second time I try srcpac errors:

==> ERROR: A package has already been built. (use -f to overwrite)

srcpac -Sbf or -Sfb does not work.

Additional info:
* package version(s)
Name : srcpac
Version : 0.10.4-1

Steps to reproduce:
compile the same pkg twice
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 26 April 2011, 21:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  on git
Comment by Andrea Scarpino (BaSh) - Thursday, 21 April 2011, 09:06 GMT
I cannot reproduce this. Also, the -f option is for pacman (eg. conflicting files)
Comment by Steffen Weber (boenki) - Thursday, 21 April 2011, 21:05 GMT
I can :D

I think it's because

MAKEPKGOPTS="-c -s"

should be

MAKEPKGOPTS="-c -s -f"


thanks for fixing all the bugs and feature requests I had recently so fast!
Comment by Andrea Scarpino (BaSh) - Friday, 22 April 2011, 00:16 GMT
That option is useless because the script removes the build dir after the makepkg call in each cases (build fails or build success)
Comment by Steffen Weber (boenki) - Friday, 22 April 2011, 03:26 GMT
Well I've set a custom PKGDEST in in /etc/makepkg.conf thus the pkg is not in the builddir and is not removed after build.

Also I like the idea of keeping the pkg.
Maybe add a switch to keep it somewhere?
You could use it as a local repo for pacman.

But it's too early in the morning now. I'm on the way for easter-holiday.
Comment by Andrea Scarpino (BaSh) - Friday, 22 April 2011, 08:39 GMT
If the build success, the script copies the package in the pacman cache, then delete the build dir.
Ok, I know how to reproduce this now :)

Loading...