Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23853 - apache and phpmyadmin: undefined symbol: OnUpdateLong

Attached to Project: Arch Linux
Opened by Maurel (guy-kde) - Wednesday, 20 April 2011, 09:52 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 20 April 2011, 10:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The start of http doesn't work:
/etc/rc.d/httpd restart
:: Restarting Apache Web
httpd: Syntax error on line 121 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib/php/modules/mysql.so into server: /usr/lib/php/modules/mysql.so: undefined symbol: OnUpdateLong

Additional info:
* package version(s)
apache 2.2.17-1
php 5.3.6-2
phpmyadmin 3.3.10-1
mysql 5.5.11-1
mysql-clients 5.5.11-1

* config and/or log files etc.
line 121 of /etc/httpd/conf/httpd.conf:
LoadModule mysql_module /usr/lib/php/modules/mysql.so
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 20 April 2011, 10:09 GMT
Reason for closing:  Not a bug
Additional comments about closing:  PHP modules shouldn't be loaded from apache config, but from php.ini or /etc/php/conf.d scriptlets instead.
Comment by Jan de Groot (JGC) - Wednesday, 20 April 2011, 10:09 GMT
Sorry, but that is totally not the way to load the mysql module for PHP.

Loading...