Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23813 - [kernel26]hibernate/resume : general protection fault : 0000 [#1] PREEMPT SMP

Attached to Project: Arch Linux
Opened by squal (squal) - Sunday, 17 April 2011, 20:24 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 02 July 2011, 20:03 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since the kernel upgrade to 2.6.38, x86_64,
I cannot hibernate properly, with pm-utils.
In fact I can hibernate but nerver resume ;-)

It starts the boot pocess normally, uncompresses to 100% the hibernation image,
but then it hangs. (on my laptop : caps lock and hard drive light blink)

Bellow is the message I get whith "no_console_suspend" option.


I've put back these packages to get my laptop to function properly again.
(dependencies requiring more packages than simply kernel)


kernel26-2.6.37.4-1-x86_64.pkg.tar.xz
kernel26-headers-2.6.37.4-1-x86_64.pkg.tar.xz
nvidia-260.19.44-1-x86_64.pkg.tar.xz
nvidia-utils-260.19.44-1-x86_64.pkg.tar.xz
xf86-input-evdev-2.6.0-2-x86_64.pkg.tar.xz
xf86-input-keyboard-1.6.0-1-x86_64.pkg.tar.xz
xf86-input-mouse-1.7.0-1-x86_64.pkg.tar.xz
xf86-input-synaptics-1.4.0-1-x86_64.pkg.tar.xz
xorg-server-1.9.4.901-1-x86_64.pkg.tar.xz
xorg-server-common-1.9.4.901-1-x86_64.pkg.tar.xz



Additional info:
* package version(s) : kernel2.6.38 x86_64
* config and/or log files etc.

Using "pm-suspend", with no_console_suspend I get this :

>Disable non-boot cpus
>CPU 1 is now Offline
>general protection fault : 0000 [#1] PREEMPT SMP


Steps to reproduce:

pm-hibernate
resume
wait till it hangs
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 02 July 2011, 20:03 GMT
Reason for closing:  Fixed
Comment by Jelle van der Waa (jelly) - Sunday, 17 April 2011, 22:21 GMT
please report this bug upstream, we can't fix it. Looks like a duplicate of #22265
Comment by squal (squal) - Monday, 18 April 2011, 08:18 GMT
Right then, but who do you mean by "upstream" in this case ?
pm-utils folks or kernel guys ?
(or anything else)

Comment by Jelle van der Waa (jelly) - Thursday, 16 June 2011, 10:31 GMT
i'd say it's a kernel bug, is it still the case with .39?
Comment by squal (squal) - Saturday, 02 July 2011, 10:40 GMT
Ok, I finally tried kernel 2.39,
boot / hibernate / resume : it just worked fine.

Let's consider it solved !

Loading...