Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23798 - [kernel26,b43 driver] each new page or page refresh requires disconnection followed by reconnection

Attached to Project: Arch Linux
Opened by Amitav (amitavmohanty01) - Saturday, 16 April 2011, 19:05 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 16 February 2012, 17:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I am connecting to a wireless LAN through my Broadcom wifi card using the following commands:

ifconfig wlan0 up
iwconfig wlan0 essid <name> key <10-digit-key>
iwconfig wlan0 auto
dhcpcd wlan0

My card gets assigned 192.168.1.3 on lease from 192.168.1.1. However, after opening one page when I refresh it or open another page in my browser, it fails. If I disconnect and reconnect between page refreshes I can connect fine. I have to issue the following commands before every new page fetch.

dhcpcd -k wlan0
dhcpcd wlan0

My kernel.log is filled up with martian header messages and they appear very fast. I am not sure if the martian header thing is relevant or not.

I have accessed the network a few months earlier. Now, I have the new kernel (2.6.38). It was working fine then. I used b43-fwcutter to get drivers for my wifi card.

Additional info:
* config and/or log files etc.
kernel.log is attached in case it turns out to be relevant
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 16 February 2012, 17:52 GMT
Reason for closing:  Upstream
Comment by Amitav (amitavmohanty01) - Saturday, 16 April 2011, 19:11 GMT
I attached the wrong file. Please check kernel.log in this attachment.
Comment by Jelle van der Waa (jelly) - Sunday, 17 April 2011, 10:45 GMT
looks like a driver issue, what chip are you using?
https://wiki.archlinux.org/index.php/Broadcom_wireless read the broadcom page to use a better driver
Comment by Amitav (amitavmohanty01) - Sunday, 17 April 2011, 12:23 GMT
I think the following information might be helpful to you.

from /etc/rc.conf
MODULES=(acpi-cpufreq cpufreq_ondemand cpufreq_conservative cpufreq_powersave cpufreq_performance !pcspkr !snd_pcsp !b43legacy b43)

from lspci -k
02:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 02)
Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb

I installed b43-firmware using b43-fwcutter; but that was a year ago. Does it need a firmware upgrade?
Comment by Amitav (amitavmohanty01) - Sunday, 17 April 2011, 12:25 GMT
My firmware version is 4.178.10.4.
Comment by Enjolras (enjolras) - Sunday, 17 April 2011, 14:26 GMT
Looks like an issue from your Access point. I can't reproduce with same hardware, same driver and same firmware.

30:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 02).
Comment by Amitav (amitavmohanty01) - Sunday, 17 April 2011, 16:48 GMT
Well if it were an access point problem, then how come I have no issues connecting from my Windows XP on the same laptop? I filled this report from my Windows on the same laptop only.
Comment by Amitav (amitavmohanty01) - Sunday, 05 June 2011, 08:22 GMT
The issue still persists. This time it is a different city and an altogether different network. My kernel version now is 2.6.38-ARCH.
Comment by Amitav (amitavmohanty01) - Sunday, 05 June 2011, 14:24 GMT
Another kernel.log that might shed some light on the issue.
Comment by Jelle van der Waa (jelly) - Saturday, 18 June 2011, 08:53 GMT
Then it seems to be a driver issue, report it to your driver maker.
Comment by Amitav (amitavmohanty01) - Friday, 26 August 2011, 10:48 GMT
Well on your suggestion I switched to Broadcom-wl drivers from b43 drivers and it worked fine. I have been using WPA networks with it successfully for months. However, when I tried using WEP networks, I get errors while setting the key.

[root@fool dknight]# iwconfig wlan0 essid <ssid of network>
[root@fool dknight]# iwconfig wlan0 key <10-digit key>
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.
[root@fool dknight]# iwconfig wlan0 key "<key>"
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.
[root@fool dknight]# iwconfig wlan0 key s:"<key>"
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.
[root@fool dknight]# iwconfig wlan0 key s:<key>
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.
[root@fool dknight]# iwconfig wlan0 key <10-digit key in dashed format as shown in man page>
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.

My current kernel version in 3.0. The broadcom-wl package in AUR was updated on 10th of this month. So, it is fairly updated.
Comment by Amitav (amitavmohanty01) - Tuesday, 29 November 2011, 18:24 GMT
Broadcom-wl did nothing except causing more failures. So I have switched back to b43. The wiki also suggests the same. However, I still can not connect to WEP networks.

Loading...