Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23748 - [kernel26] Kernel 2.6.38 regressions

Attached to Project: Arch Linux
Opened by Bryan (bryan) - Wednesday, 13 April 2011, 13:42 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 16 February 2012, 17:51 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Since a kernel upgrade two days ago when 2.6.38.2-1-x86_64 was available through pacman I observe several regressions:

- reboot or poweroff command does not complete and stops in a "Rebooting" or "Powering off" line on console, not going further (ACPI related ?) ;
- keyboard under X has erratic typing behaviour every few seconds. My Xorg config has not been changed (attached). ;

Nothing weird or unusual in logs (kernel, message, Xorg). Reverting to 2.6.37.5-1-x86_64 worked and restored proper behaviour.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 16 February 2012, 17:51 GMT
Reason for closing:  Upstream
Comment by Jelle van der Waa (jelly) - Thursday, 14 April 2011, 21:10 GMT
these are two bugs, could you assign them individual, also these seem to be upstream bugs. Check upstream and report it.
Comment by Kai Hendry (hendry) - Sunday, 01 May 2011, 23:03 GMT
I've since downgraded to 2.6.37, though in 2.6.38 my Xorg didn't work (nvidia) and most important my gigabit ethernet interface stopped working.

06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
Comment by Bryan (bryan) - Tuesday, 03 May 2011, 11:31 GMT
Still the same behaviour (acpi, erratic keyboard) with 2.6.38.4-1-x86_64
Comment by Bryan (bryan) - Tuesday, 03 May 2011, 11:39 GMT
Some additional data:

CPU0: Intel(R) Core(TM)2 Duo CPU L7500 @ 1.60GHz stepping 0a
Thinkpad x61s (LENOVO 766949G/766949G, BIOS 7NETC1WW (2.21 ) 10/09/2009)
Memory: 2012532k/2054848k available
scsi 2:0:0:0: Direct-Access ATA OCZ-VERTEX2 1.10 PQ: 0 ANSI: 5
sd 2:0:0:0: [sda] 234441648 512-byte logical blocks: (120 GB/111 GiB)
agpgart-intel 0000:00:00.0: Intel 965GM Chipset

Loaded modules : cryptd aes_x86_64 aes_generic ipv6 cpufreq_ondemand sierra usbserial usbhid hid ext2 ext4 jbd2 crc16 btusb bluetooth snd_hda_codec_analog i915 drm_kms_helper drm arc4 ecb snd_seq_dummy snd_seq_oss snd_seq_midi_event iwl3945 snd_seq snd_seq_device snd_hda_intel pcmcia snd_hda_codec snd_pcm_oss uhci_hcd iwlcore sbs snd_hwdep sbshc snd_mixer_oss coretemp thinkpad_acpi mac80211 snd_pcm i2c_algo_bit ecryptfs sdhci_pci acpi_cpufreq freq_table ehci_hcd i2c_i801 sdhci firewire_ohci yenta_socket snd_timer firewire_core cfg80211 pcmcia_rsrc mmc_core snd soundcore intel_agp serio_raw rfkill thermal sg pcmcia_core processor i2c_core e1000e crc_itu_t nvram battery ac usbcore snd_page_alloc button evdev psmouse video iTCO_wdt iTCO_vendor_support output pcspkr intel_gtt mperf ext3 jbd mbcache sd_mod ahci libahci ata_piix pata_acpi libata scsi_mod

with 2.6.37 of course.
Comment by JM (fijam) - Friday, 06 May 2011, 18:45 GMT
Please split this bug report into two as requested. Are those bugs reported upstream?
Comment by Bryan (bryan) - Friday, 06 May 2011, 19:39 GMT
Done, forked  FS#24132  for the poweroff/reboot issue. I keep this one for the X11/keyboard issue. (Sorry I can't edit the bug report to remove what's now in the other issue and update the title of this issue).
Comment by Bryan (bryan) - Friday, 06 May 2011, 19:39 GMT
http://lists.freedesktop.org/archives/intel-gfx/2011-March/009547.html
describe the same behaviour I have with all current 2.6.38 package available in archlinux
Comment by Bryan (bryan) - Sunday, 22 May 2011, 08:58 GMT
The X11/keyboard issue vanished with the 2.6.38.6-2 kernel package. I haven't found in the kernel logs http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.38.y.git what could have fixed this issue, so it may not be a kernel issue at all.
Comment by Diego Viola (diegoviola) - Sunday, 26 June 2011, 20:46 GMT
This issue is still present on my machine as of current date. With kernel 2.6.39-ARCH. I've reported said problem upstream: https://bugzilla.kernel.org/show_bug.cgi?id=33872

Loading...