Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23745 - Unable to boot after downgrading from 2.6.38 to 2.6.37

Attached to Project: Arch Linux
Opened by Alphazo (alphazo) - Wednesday, 13 April 2011, 08:54 GMT
Last edited by Allan McRae (Allan) - Saturday, 16 April 2011, 09:17 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After experiencing some issues with 2.6.38 and my Intel video card (external monitor support). I decided to go back to 2.6.37 for the time being.

I went into my /var/cache/pacman/pkg and typed in:

pacman -U kernel26-2.6.37-6-x86_64.pkg.tar.xz kernel26-headers-2.6.37-6-x86_64.pkg.tar.xz linux-api-headers-2.6.37-1-x86_64.pkg.tar.xz


warning: downgrading package kernel26 (2.6.38.2-1 => 2.6.37-6)
warning: downgrading package kernel26-headers (2.6.38.2-1 => 2.6.37-6)
warning: downgrading package linux-api-headers (2.6.38.1-1 => 2.6.37-1)
resolving dependencies...
looking for inter-conflicts...

Targets (3): kernel26-2.6.37-6 kernel26-headers-2.6.37-6 linux-api-headers-2.6.37-1

Total Download Size: 0.00 MB
Total Installed Size: 96.04 MB

Proceed with installation? [Y/n] y
(3/3) checking package integrity [#######################################################] 100%
(3/3) checking for file conflicts [#######################################################] 100%
(1/3) upgrading kernel26 [#######################################################] 100%
>>> Updating module dependencies. Please wait ...
>>> MKINITCPIO SETUP
>>> ----------------
>>> If you use LVM2, Encrypted root or software RAID,
>>> Ensure you enable support in /etc/mkinitcpio.conf .
>>> More information about mkinitcpio setup can be found here:
>>> http://wiki.archlinux.org/index.php/Mkinitcpio

>>> Generating initial ramdisk, using mkinitcpio. Please wait...
==> Building image "default"
==> Running command: /sbin/mkinitcpio -k 2.6.37-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26.img
:: Begin build
:: Parsing hook [base]
:: Parsing hook [udev]
:: Parsing hook [autodetect]
:: Parsing hook [pata]
:: Parsing hook [scsi]
:: Parsing hook [sata]
:: Parsing hook [uresume]
:: Parsing hook [filesystems]
:: Parsing hook [keymap]
:: Generating module dependencies
:: Generating image '/boot/kernel26.img'...SUCCESS
==> SUCCESS
==> Building image "fallback"
==> Running command: /sbin/mkinitcpio -k 2.6.37-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26-fallback.img -S autodetect
:: Begin build
:: Parsing hook [base]
:: Parsing hook [udev]
:: Parsing hook [pata]
:: Parsing hook [scsi]
:: Parsing hook [sata]
:: Parsing hook [uresume]
:: Parsing hook [filesystems]
:: Parsing hook [keymap]
:: Generating module dependencies
:: Generating image '/boot/kernel26-fallback.img'...SUCCESS
==> SUCCESS
(2/3) upgrading kernel26-headers [#######################################################] 100%
(3/3) upgrading linux-api-headers [#######################################################] 100%

Then I rebooted and to my surprise I got stuck very early during the boot process.

sda: sda1 sda2 sda3
sd 0:0:0:0 [sda] Attached SCSI disk
Waiting 10 seconds for device /dev/sda3
mount: mounting /dev/sda3 on /new_root failed: No such device
ERROR: Failed to mount the real root device

Hopefully I had a 2.6.39rc3-mainline entry in my grub so I selected it and was able to boot as before. I then upgraded from 2.6.37 back to 2.6.38 (using pacman) and guess what... still unable to boot (same message).

How can I get 2.6.37 or 2.6.38 to boot again on my system?
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 16 April 2011, 09:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  Seems "fixed", and no way to replicate.
Comment by Hok Asch (hokasch) - Wednesday, 13 April 2011, 09:00 GMT
This is not a bug report but a support question, you should take it to the forums.
Quick tip: https://wiki.archlinux.org/index.php/Persistent_block_device_naming
Comment by Alphazo (alphazo) - Wednesday, 13 April 2011, 09:35 GMT
Thanks for the pointer. I changed my menu.lst to use UUID rather than /dev/sda3 but that didn't help and I get the same error message during boot for both 2.6.37 and 2.6.38.

# kernel /vmlinuz26 root=/dev/sda3 ro
kernel /vmlinuz26 root=/dev/disk/by-uuid/0537101d-95ab-44be-8092-f3f6b8738089 ro
Comment by Jan de Groot (JGC) - Wednesday, 13 April 2011, 13:35 GMT
Does the fallback image also fail?
Comment by Alphazo (alphazo) - Wednesday, 13 April 2011, 14:10 GMT
See at the bottom of the following post for how I got it working. Sorry but I no longer have the fallback image handy.
https://bbs.archlinux.org/viewtopic.php?pid=918061#p918061

Loading...