Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23720 - [notification-daemon] Notifications doesn’t work anymore

Attached to Project: Arch Linux
Opened by Guillaume Brunerie (Fractal) - Tuesday, 12 April 2011, 11:53 GMT
Last edited by Allan McRae (Allan) - Saturday, 28 April 2012, 14:54 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 25
Private No

Details

Description:
Since the update of notification-daemon to version 0.7.1-1, notifications doesn’t work anymore, and wicd-client doesn’t run.


Steps to reproduce:
Update notification-daemon to version 0.7.1-1.
$ notify-send "a" "b"
→ nothing happens
$ wicd-client
Has notifications support True
Loading...
Connecting to daemon...
Connected.
Traceback (most recent call last):
File "/usr/share/wicd/gtk/wicd-client.py", line 1033, in <module>
main(sys.argv)
File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
return func(*args, **kwargs)
File "/usr/share/wicd/gtk/wicd-client.py", line 1005, in main
tray_icon = TrayIcon(animate, displaytray=display_app)
File "/usr/share/wicd/gtk/wicd-client.py", line 139, in __init__
self.icon_info = self.TrayConnectionInfo(self, self.tr, animate)
File "/usr/share/wicd/gtk/wicd-client.py", line 198, in __init__
self.update_tray_icon()
File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
return func(*args, **kwargs)
File "/usr/share/wicd/gtk/wicd-client.py", line 347, in update_tray_icon
self.set_wired_state(info)
File "/usr/share/wicd/gtk/wicd-client.py", line 259, in set_wired_state
'network-wired')
File "/usr/share/wicd/gtk/wicd-client.py", line 233, in _show_notification
self._last_bubble.show()
glib.GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files


Workaround:
I found the following (strange) workaround:
- downgrade to notification-daemon-0.4.0-5
- run `notify-send "a" "b"' (the notification will work)
- update notification-daemon-0.7.1-1

This makes notifications and wicd-client work, but after a reboot the problem is there again.

So it seems that the problem is not in notification-daemon-0.7.1 but somewhere else around.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 28 April 2012, 14:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Bug resolved upstream ages ago. I assume it has made its way here by now...
Comment by Jelle van der Waa (jelly) - Tuesday, 12 April 2011, 12:25 GMT
it sounds like this is an upstream issue with wicd code not ready for libnotify 0.7. Cehck and report it upstream
Comment by Guillaume Brunerie (Fractal) - Tuesday, 12 April 2011, 12:28 GMT
I don’t think so. With the workaround I found, I have notification-daemon-0.7.1-1, libnotify-0.7.2-1, and wicd-client works.
Comment by Ionut Biru (wonder) - Tuesday, 12 April 2011, 13:16 GMT
here is the catch.

they dropped the dbus activation
http://git.gnome.org/browse/notification-daemon/commit/?id=1ad20d22098bc7718614a8a87744a2c22d5438d0

if you start /usr/lib/notification-daemon-1.0/notification-daemon this manually, i guess it will work
Comment by Guillaume Brunerie (Fractal) - Tuesday, 12 April 2011, 13:29 GMT
This does not work, when I try to start /usr/lib/notification-daemon-1.0/notification-daemon manually I get this:


$ /usr/lib/notification-daemon-1.0/notification-daemon
** (notification-daemon:12500): DEBUG: Adding id 1

Gdk-CRITICAL **: gdk_visual_get_red_pixel_details: assertion `GDK_IS_VISUAL (visual)' failed
aborting...
zsh: abort /usr/lib/notification-daemon-1.0/notification-daemon


Perhaps this is another bug in /usr/lib/notification-daemon-1.0/notification-daemon?
Comment by Ionut Biru (wonder) - Tuesday, 12 April 2011, 13:34 GMT
are you fully up to date? gtk3, gdk-pixbuf2
Comment by Guillaume Brunerie (Fractal) - Tuesday, 12 April 2011, 13:37 GMT
Yes, I updated yesterday with the mirror ftp.archlinux.org (because mirrors.kernel.org seems to be broken).

$ pacman -Qi gtk3 gdk-pixbuf2 | grep Version
Version : 3.0.8-1
Version : 2.23.3-1
Comment by Daniel (aspala) - Tuesday, 03 May 2011, 20:44 GMT
Same here... had to downgrade notificatin-daemon to version 4.0-5 in order to get it working
Otherwise, had to do as described above: downgrade, run a test and update again... but after a restart of "x" it didnt work anymore
Now working fine with de downgrade

PS: i think it is all about notification-daemon, no relation with wicd or any other package
Comment by Ionut Biru (wonder) - Tuesday, 03 May 2011, 20:46 GMT
@Daniel have you tried to start manually notification-daemon?

/usr/lib/notification-daemon-1.0/notification-daemon &
Comment by Daniel (aspala) - Tuesday, 03 May 2011, 22:36 GMT
@Ionut - Thanks for the replay! Yes, I tried that, on a terminal and adding that line to autostart.sh in openbox config folder...


[daniel@daniel-arch ~]$ notify-send "j"
** (notification-daemon:17645): DEBUG: Adding id 1

Gdk-CRITICAL **: gdk_visual_get_red_pixel_details: assertion `GDK_IS_VISUAL (visual)' failed
aborting...


That is the output in terminal after starting notification-daemon manually
Comment by Jack Culhane (dioltas) - Wednesday, 04 May 2011, 21:01 GMT
Hi Guys, just want to confirm this bug.

Linux arch_hd 2.6.38-ARCH
Fluxbox 1.3.1

pacman -Qi wicd-gtk notification-daemon gtk3 gdk-pixbuf2 | grep Version
Version : 1.7.0-9
Version : 0.7.1-1
Version : 3.0.9-1
Version : 2.23.3-1


**$wicd-gtk **
Has notifications support True
Loading...
Connecting to daemon...
Connected.
Traceback (most recent call last):
File "/usr/share/wicd/gtk/wicd-client.py", line 1033, in <module>
main(sys.argv)
File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
return func(*args, **kwargs)
File "/usr/share/wicd/gtk/wicd-client.py", line 1005, in main
tray_icon = TrayIcon(animate, displaytray=display_app)
File "/usr/share/wicd/gtk/wicd-client.py", line 139, in __init__
self.icon_info = self.TrayConnectionInfo(self, self.tr, animate)
File "/usr/share/wicd/gtk/wicd-client.py", line 198, in __init__
self.update_tray_icon()
File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
return func(*args, **kwargs)
File "/usr/share/wicd/gtk/wicd-client.py", line 349, in update_tray_icon
self.set_wireless_state(info)
File "/usr/share/wicd/gtk/wicd-client.py", line 91, in wrapper
return func(*args, **kwargs)
File "/usr/share/wicd/gtk/wicd-client.py", line 289, in set_wireless_state
'network-wireless')
File "/usr/share/wicd/gtk/wicd-client.py", line 233, in _show_notification
self._last_bubble.show()
glib.GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files


**$ notify-send "a" "b"**
(Doesn't seem to do anything)


If I run:
**/usr/lib/notification-daemon-1.0/notification-daemon &**

and then wicd-gtk, wicd-gtk seems to load fine. However if I then stop wicd-gtk it gives the same error as before. notification-daemon doesn't seem to stay running. Looks like it dies after I start wicd-gtk, so I suspect wicd-client notifications might not work anyway.
Here is the output from notification-daemon when I start wicd-gtk:

$ /usr/lib/notification-daemon-1.0/notification-daemon
** (notification-daemon:789): DEBUG: Adding id 1

Gdk-CRITICAL **: gdk_visual_get_red_pixel_details: assertion `GDK_IS_VISUAL (visual)' failed
aborting...
Aborted

Here is what happens if I run notify-send after starting the daemon:

$ /usr/lib/notification-daemon-1.0/notification-daemon &
[4] 604
$ notify-send "a" "b"
** (notification-daemon:604): DEBUG: Adding id 1

Gdk-CRITICAL **: gdk_visual_get_red_pixel_details: assertion `GDK_IS_VISUAL (visual)' failed
aborting...
[4] Aborted /usr/lib/notification-daemon-1.0/notification-daemon
Comment by Raanan Elefant (badcloud) - Thursday, 05 May 2011, 17:30 GMT
I can confirm this bug
Comment by Jack Culhane (dioltas) - Thursday, 05 May 2011, 20:00 GMT
I added this to my startup script for the moment.

/usr/lib/notification-daemon-1.0/notification-daemon &
wicd-gtk &

Lets wicd-gtk start, but notifications do not work.
Comment by jackoneill (jackoneill) - Friday, 06 May 2011, 14:19 GMT
>Workaround:
>I found the following (strange) workaround:
>- downgrade to notification-daemon-0.4.0-5
>- run `notify-send "a" "b"' (the notification will work)
>- update notification-daemon-0.7.1-1

This "works" because when you run notify-send, it starts the now-downgraded notification-daemon (0.4.0-5), which then stays in the background until you reboot.

Also, wicd has nothing to do with this bug. Simply starting notification-daemon in a terminal and then running 'notify-send "summary" "body"' has the same outcome:
----------------
** (notification-daemon:26468): DEBUG: Adding id 1

Gdk-CRITICAL **: gdk_visual_get_red_pixel_details: assertion `GDK_IS_VISUAL (visual)' failed
aborting...
----------------
Package versions:
notification-daemon 0.7.1-1
gtk3 3.0.9-1
gdk-pixbuf2 2.23.3-1

I compiled notification-daemon 0.7.1-1 with !strip and -g in the C{,XX}FLAGS. The backtrace is attached. There are still some ?? in it, maybe I need to recompile some other packages as well?
Comment by jackoneill (jackoneill) - Friday, 06 May 2011, 17:40 GMT Comment by krasu-desu (krasu) - Saturday, 07 May 2011, 12:21 GMT
Not work for me too, even if start it manually:
** (notification-daemon:2986):
DEBUG: Adding id 1
Gdk-CRITICAL **: gdk_visual_get_red_pixel_details: assertion `GDK_IS_VISUAL (visual)' failed aborting...
[3]+ Exit 1 /usr/lib/notification-daemon-1.0/notification-daemon

pacman -Qi notification-daemon openbox gtk3 | grep Version
Version : 0.7.1-1
Version : 3.4.11.2-2
Version : 3.0.9-1

~/.config/autostart.sh:
...
/usr/lib/notification-daemon-1.0/notification-daemon &
...
Comment by Fernando (Captain_Yossarian) - Friday, 10 June 2011, 08:34 GMT
Same problem here.


% /usr/lib/notification-daemon-1.0/notification-daemon&
[1] 26833
% notify-send "Hello guy"
** (notification-daemon:26833): DEBUG: Adding id 1

Gdk-CRITICAL **: gdk_visual_get_red_pixel_details: assertion `GDK_IS_VISUAL (visual)' failed
aborting...
[1] + 26833 abort /usr/lib/notification-daemon-1.0/notification-daemon
Comment by Jelle van der Waa (jelly) - Friday, 10 June 2011, 09:14 GMT
check the bugreport upstream
Comment by Cedric Girard (Xdark) - Monday, 29 August 2011, 13:15 GMT
The bug has been resolved upstream. The bug was related to GtkStatusIcon not notification-daemon.

Loading...