Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23679 - XOrg + NVIDIA Drivers total freeze/crash, requires hard reboot.

Attached to Project: Arch Linux
Opened by Troy Cotter (trc) - Sunday, 10 April 2011, 18:09 GMT
Last edited by Jan de Groot (JGC) - Monday, 04 July 2011, 13:13 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description: Occasionally I will be going about doing my standard computer tasks, Kopete, text editing, Firefox, etc... and my screen will completely lock up, everything except my mouse, and I am unable to switch into a tty in order to restart. I am using the latest KDE (4.6.2)

I will attach the log below, and will post all the xorg and xf86 packages and my kernel and nvidia package versions as I can not be absolutely sure which package is responsible.

xf86dgaproto 2.1-1
xf86-input-evdev 2.6.0-2
xf86-input-synaptics 1.4.0-1
xf86vidmodeproto 2.3.1-1
xorg-bdftopcf 1.0.3-1
xorg-fonts-alias 1.0.2-1
xorg-fonts-encodings 1.0.4-1
xorg-fonts-misc 1.0.1-1
xorg-font-util 1.2.0-1
xorg-font-utils 7.6-2
xorg-mkfontdir 1.0.6-2
xorg-mkfontscale 1.0.8-1
xorg-server 1.9.4.901-1
xorg-server-common 1.9.4.901-1
xorg-setxkbmap 1.2.0-2
xorg-xauth 1.0.5-2
xorg-xkbcomp 1.2.1-2
xorg-xmessage 1.0.3-1
xorg-xprop 1.2.0-2
xorg-xset 1.2.1-2
nvidia 270.30-3
nvidia-utils 270.30-1
kernel26 2.6.37.5-1
kernel26-headers 2.6.37.5-1

Steps to reproduce: Difficult to reproduce.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 04 July 2011, 13:13 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  bug 23381 
Comment by Troy Cotter (trc) - Sunday, 10 April 2011, 18:14 GMT
Forgot to add my xorg.conf, in case anyone wanted to see it.

I also should add that the reason why Xorg.0.log.old has entries about my second display missing is because I do not have it currently plugged in. This has never effected the performance in the past.
Comment by Jelle van der Waa (jelly) - Sunday, 10 April 2011, 18:19 GMT
Check dmesg / messages.log when it happens ( or try to ssh into the machine ) , it will probably be an nvidia issue so with enough info try to report it upstream.
Comment by Tobias Powalowski (tpowa) - Monday, 11 April 2011, 05:54 GMT
We cannot fix anything in the binary blob.
Comment by Troy Cotter (trc) - Monday, 11 April 2011, 18:03 GMT
Ok, well I just got done updating nvidia and xorg so we will see if this happens again, if it does I will submit the information to NVIDIA
Comment by Bogdan (JokerBoy) - Tuesday, 12 April 2011, 08:02 GMT
duplicate https://bugs.archlinux.org/task/23381

and yes, even with 270.41.03-1 it freeze. disabling desktop effects helps.
Comment by Jef (jeagoss) - Wednesday, 13 April 2011, 15:50 GMT
I have been able to avoid this bug by downgrading just the xorg server. I'm still using the latest nvidia drivers.
Comment by Conrad Nelson (Yaro) - Monday, 18 April 2011, 16:34 GMT
I can confirm this bug.


And I suggest before Tobias Powalowski closes this bug they confirm it is indeed a bug in the driver. I remember a bug involving this driver a couple years back people assumed was in the binary blob when it actually was in Xorg.

I am also a KDE user.

Don't be so damned quick to dismiss a bug just because of the presence of a binary blob, in fact, I seem to recall nouveau crashing me up with this exact same behavior too with this version of Xorg, so please confirm the bug is not in Xorg OR KDE SC before assuming it's in the nvidia driver, as immediately blaming the binary blob is not very helpful.

Also, this isn't exactly a duplicate of that last bug. The freezes don't occur just when I resize a terminal. I can't isolate an actual condition where it freezes beyond simple normal use of KDE, Xorg, and nVidia (And possibly Nouveau.)
Comment by mattia (nTia89) - Monday, 18 April 2011, 19:46 GMT
i get same problem when i play with supertux

gnome, nvidia driver
Comment by Rob (Painless) - Monday, 25 April 2011, 22:06 GMT
I get a similar problem. I suspect flashplugin/firefox might be triggering this off in my case, but it's difficult to reproduce. I got the following entry in /var/log/errors.log around the time of the last freeze:

Apr 25 21:09:32 khitai kernel: [ 5571.546101] NVRM: Xid (0000:01:00): 13, 0001 00000000 00005097 00000548 3f800000 00000080

There is nothing suspect in /var/log/Xorg.0.log or /var/log/Xorg.0.log.old.

Using FVWM, nvidia driver. GNOME is also installed, but not used. Composite entension enabled (I used to use compiz).
Comment by Dyrver Eriksson (dyrvere) - Tuesday, 17 May 2011, 22:12 GMT
This has been happening to me as well, no logs show anything descriptive. The culprit is either VDPAU, flashplugin, firefox, konqueror or Xorg. The thing is, if you leave it be when it appears to freeze, it will sort itself within 15 min or even 30 min, enough so you can get out of the graphical interface to tty1 and kill firefox, but it will stop responding and resume to keyboard input in 1 min intervals. The weird thing is you can still use the mouse through tty7 but nothing on they keyboard will seem to respond for a long while.
Comment by Jelle van der Waa (jelly) - Wednesday, 18 May 2011, 08:52 GMT
PLEASE read what Tobias said,

Archlinux developers can't fix anything about the nvidia driver because it's an binary blob therefore you should report this bug to nvidia.
Use: nvidia-bug-report.sh
To create a bugreport
"When emailing linux-bugs@nvidia.com, please attach an nvidia-bug-report.log, which is generated by running "nvidia-bug-report.sh". "

So please take it to nvidia
Comment by Conrad Nelson (Yaro) - Wednesday, 18 May 2011, 12:47 GMT
Just because there's a binary blob present doesn't automatically mean the bug is in the binary blob. How about we check what we can check for bugs before we make the mistake of automatically blaming what we can blame, please.

There hasn't actually been anything in this bug report indicating the bug is caused or is in the nVidia driver. And the last time people tried blaming the bug on this driver nVidia ended up showing us that it wasn't.

Localize the bug before spreading blame on it, please.
Comment by Rob (Painless) - Sunday, 22 May 2011, 19:22 GMT
Since I've hashed out the line:

Option "Composite" "Enable"

in my /etc/X11/xorg.conf three weeks ago, this problem hasn't re-occurred. Not much use to many ppl who like their eye candy, but maybe a pointer to the cause?
Comment by Martin Schmidt (Blind) - Wednesday, 08 June 2011, 17:20 GMT
Ok, I had this annoying bug for a while. Turns out it actually was NVidia's bug. The fix is in the new beta driver, as announced here: http://www.nvnews.net/vbulletin/showthread.php?p=2441669

Good luck.
Comment by Soup (Soup) - Friday, 10 June 2011, 20:54 GMT
Anyone have a problem using the new beta driver recently when starting X? I say recently because I can't remember when I last rebooted this laptop, and there's been updates to many packages recently. I ended up with a black screen with a non-flashing cursor. On reboot doing a nvidia-smi -q is printed a bunch of traces. Had to roll back to the current stable version to get X running (reinstalling the previous new beta didn't help).

I know it's probably a new bug, but I thought the people that might be using the new beta would be following this and might have some insight.
Comment by Sean (finitemachine) - Friday, 01 July 2011, 04:56 GMT
I had a very similar problem with the Nvidia driver creating an entire system freeze, and requiring a hard system reboot.
It seems that the issue for me was with the Powermizer, and it's adaptive clocking of the GPU clock frequency that was causing the
total system freezes. I suggest reading up on how to configure Powermizer such that the GPU stays at one fixed frequency.
http://tutanhamon.com.ua/technovodstvo/NVIDIA-UNIX-driver/ Hope this helps others who have had similar issues!

Loading...