Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23651 - [gnome 3] gnome-system-log 3.0.0 crashes occasionally on opening logfiles

Attached to Project: Arch Linux
Opened by Arjan Nieuwenhuis (arjann) - Friday, 08 April 2011, 10:07 GMT
Last edited by Allan McRae (Allan) - Saturday, 14 July 2012, 05:52 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Logfileviewer gnome-system-log 3.0.0 crashes occasionally on opening logfiles. I can't pin point it to a specific logfile, had multiple crashes with different logfiles. After restart the attempted logfile is correctly loaded.

Additional info:
* package version(s)
I assume it is part of gnome-system-tools 3.0.0

* config and/or log files etc.
Added a backtrace and memory map of it, see backtrace.txt

Steps to reproduce:
Open logfiles and it occasionally occurs
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 14 July 2012, 05:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  Appears "fixed"
Comment by Ionut Biru (wonder) - Friday, 08 April 2011, 10:30 GMT
recompile gnome-utils having this in PKGBUILD

options=('!strip')

and in build before ./configure

export CFLAGS="$CFLAGS -g -O0"
export CXXFLAGS="$CXXFLAGS -g -O0"

then run gnome-system-log in gdb

gdb gnome-system-log

run

make it crash and type bt full
Comment by Ionut Biru (wonder) - Friday, 08 April 2011, 10:33 GMT
also submit that to bugzilla.gnome.org and paste the link here. we cannot do anything
Comment by Arjan Nieuwenhuis (arjann) - Saturday, 09 April 2011, 15:32 GMT Comment by Arjan Nieuwenhuis (arjann) - Saturday, 09 April 2011, 20:36 GMT
result of gdb gnome-system-log as wonder suggested.
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 12:09 GMT
Status?
Comment by Arjan Nieuwenhuis (arjann) - Sunday, 10 June 2012, 07:35 GMT
I haven't experienced the bug after update to 3.4.1. Although i haven't seen any changed on bugzilla.

Loading...