Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23649 - [Monodevelop] Unhandled Exception on Startup

Attached to Project: Arch Linux
Opened by Joel Sevilleja (foxdie) - Friday, 08 April 2011, 08:19 GMT
Last edited by Isenmann Daniel (ise) - Tuesday, 12 April 2011, 16:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Ionut Biru (wonder)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

I'm using Gnome-3 and the following repositories: testing, core, extra, community, multilib-testing, multilib. I' ve the system up to date as April 8th, and when I launch Monodevelop, there are a few unhandled exceptions (see the attached file)

Additional info:
extra/monodevelop-2.4.2-1
This task depends upon

Closed by  Isenmann Daniel (ise)
Tuesday, 12 April 2011, 16:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in package release -2
Comment by Jelle van der Waa (jelly) - Friday, 08 April 2011, 08:32 GMT
Can you rebuild it via ABS to check if it's just needs a rebuild. (probably after all the new gnome stuff is in [testing] )
Comment by Joel Sevilleja (foxdie) - Friday, 08 April 2011, 08:56 GMT
I've tried that and it doesn't work
Comment by Isenmann Daniel (ise) - Friday, 08 April 2011, 08:59 GMT
I will have a deeper look into that issue.
Comment by Isenmann Daniel (ise) - Monday, 11 April 2011, 05:52 GMT
@Ionut: I will try to compile it without gnome-desktop-sharp. I will inform you about the progress.
Comment by Isenmann Daniel (ise) - Monday, 11 April 2011, 10:09 GMT
gnome-desktop-sharp isn't necessary for monodevelop, so this dependency can be removed. But the problem still exists, because of gnome-sharp.
I'm in discussions with the developer of monodevelop.
Comment by Isenmann Daniel (ise) - Monday, 11 April 2011, 12:36 GMT Comment by Isenmann Daniel (ise) - Monday, 11 April 2011, 13:36 GMT
Just to be more precise I have attached the log output from startup of monodevelop. It seems that the issue is related to some glib2 changes.
   output.log (112.6 KiB)
Comment by Isenmann Daniel (ise) - Tuesday, 12 April 2011, 13:19 GMT

Loading...