Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23646 - [xf86-video-intel] xorg-server 1.10.0-1 & 1.10.0.901-1 segmentation fault

Attached to Project: Arch Linux
Opened by Liao Haohui (liaohaohui) - Friday, 08 April 2011, 06:05 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 31 May 2011, 08:20 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:

After upgrading ArchLinux with the latest testing xorg-server, the following core dump happens:

X.Org X Server 1.10.0
Release Date: 2011-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-ARCH x86_64
Current Operating System: Linux liaohaohui 2.6.38-ARCH #1 SMP PREEMPT Wed Mar 30 08:47:36 CEST 2011 x86_64
Kernel command line: root=/dev/disk/by-uuid/4d75a383-32b1-479f-92cf-b696e6607cd7 ro i915.modeset=1
Build Date: 16 March 2011 08:03:26PM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 6 23:33:36 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
[fvwm][parse_colorset]: <<WARNING>> bad colorset pixmap specifier Translucent
[fvwm][scanForPixmap]: <<WARNING>> Couldn't load image from computer.png
[fvwm][scanForPixmap]: <<WARNING>> Couldn't load image from computer_x11.png
[fvwm][scanForPixmap]: <<WARNING>> Couldn't load image from tool_wrench.png
[FvwmPager][FlocaleGetFontSet]: (5x8) Missing font charsets:
ISO8859-2, ISO8859-3, ISO8859-4, ISO8859-5, KOI8-R, ISO8859-7, ISO8859-9, ISO8859-13, ISO8859-14, ISO8859-15, JISX0208.1983-0, KSC5601.1987-0, GB2312.1980-0, JISX0201.1976-0, ISO10646-1
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 45229
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 45231
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 45233
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 45235

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x46b688]
1: /usr/bin/X (0x400000+0x5f8b9) [0x45f8b9]
2: /lib/libpthread.so.0 (0x7f23495a6000+0xf750) [0x7f23495b5750]
3: /usr/lib/libdrm_intel.so.1 (drm_intel_bo_emit_reloc+0x0) [0x7f2345ef3af0]
4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f23460fd000+0x22c5d) [0x7f234611fc5d]
5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f23460fd000+0x2ae87) [0x7f2346127e87]
6: /usr/bin/X (0x400000+0xcda05) [0x4cda05]
7: /usr/bin/X (0x400000+0xc05fd) [0x4c05fd]
8: /usr/bin/X (0x400000+0x52b01) [0x452b01]
9: /usr/bin/X (0x400000+0x2132e) [0x42132e]
10: /lib/libc.so.6 (__libc_start_main+0xed) [0x7f234852cf6d]
11: /usr/bin/X (0x400000+0x20ed9) [0x420ed9]
Segmentation fault at address (nil)

Additional info:
* package version(s)
* config and/or log files etc.

kernel26 2.6.38.2-1
dri2proto 2.3-1
intel-dri 7.10.1-2
xf86driproto 2.1.1-1
xorg-xdriinfo 1.0.4-2
glibc 2.13-5

Steps to reproduce:

The above phenomena happened when I was using djview and xpdf to read a document. The event happened randomly which I wasn't able to reproduce exactly.

I checked the internet and found that xorg-server seems to have the above problem. I had to downgrade to xorg-server-1.9.4-1 which did not core dump so far.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 31 May 2011, 08:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with xf86-video-intel 2.15.0-2.
Comment by Liao Haohui (liaohaohui) - Friday, 08 April 2011, 06:17 GMT
Is it related to this: http://www.spinics.net/lists/xorg/msg52280.html
or it is the X server and intel-drm communication problem?
Comment by Timothy Redaelli (tredaelli) - Wednesday, 13 April 2011, 15:14 GMT
No realloc here, so it's a different problem
Comment by Dilip Varma (testdude281) - Thursday, 14 April 2011, 20:03 GMT
i have a similar problem. After i upgraded my intel and xorg packages my mouse & kb stopped responding. its not a kernel panic though or a xorg crash, as i can see my desktop clock working. These are the packages i upgraded :

[2011-04-13 14:44] upgraded xf86-video-intel (2.14.0-3 -> 2.14.903-1)
[2011-04-13 14:44] upgraded xf86-video-vesa (2.3.0-4 -> 2.3.0-5)
[2011-04-13 14:44] upgraded xorg-server-common (1.9.4.901-1 -> 1.10.0.902-1)
[2011-04-13 14:44] upgraded xorg-server (1.9.4.901-1 -> 1.10.0.902-1)
[2011-04-13 14:44] upgraded xorg-xrdb (1.0.8-2 -> 1.0.9-1)

i have since downgraded my packages.
Comment by Liao Haohui (liaohaohui) - Saturday, 23 April 2011, 03:52 GMT
I upgrade to the latest testing today with

xorg-server-1.10.1-1-x86_64.pkg.tar.xz
xorg-server-common-1.10.1-1-x86_64.pkg.tar.xz
xorg-server-devel-1.10.1-1-x86_64.pkg.tar.xz

the problem still persists. It happens when I was reading a djvu document using djview. My other machine with Nvidia chip didn't have problem, so I suspect this is related to intel-drm & xf86-video-intel-2.15.0-1. I am now downgrading to xf86-video-intel 2.13.0-4 which seems to work a bit more stable (so far no crash when reading pdf or djvu files)
Comment by Antonio Muñoz (tomby) - Sunday, 24 April 2011, 09:41 GMT
I have the same problem.

I installed the 2.13.0-4 version of the X driver and the system seems much more stable.
Comment by Lyman Li (lyman) - Friday, 06 May 2011, 02:14 GMT
I found a patch in this thread, might be useful
http://lists.debian.org/debian-x/2011/04/msg00541.html
Comment by Antonio Muñoz (tomby) - Friday, 06 May 2011, 05:46 GMT
I built a package with this patch. Now I'm testing the generated package in my system.
Comment by Liao Haohui (liaohaohui) - Friday, 06 May 2011, 12:04 GMT
Not sure if the patch will be helpful to my Acer As 4740-431G32Mn I5 which has i915 intel chipset. So fixing i965 wouldn't really help me.
Comment by Antonio Muñoz (tomby) - Friday, 06 May 2011, 20:03 GMT
Probably, but the patch include a fix in a header file intel_batchbuffer.h used in other drivers. Lets give it a try. Works fine for me :)
Comment by Jelle van der Waa (jelly) - Wednesday, 18 May 2011, 08:59 GMT
Did anyone report the bug upstream?
Comment by Liao Haohui (liaohaohui) - Thursday, 19 May 2011, 15:51 GMT
@Antonio Muñoz:

Thanks for your suggestion! I installed the patch you suggested, now I can run djview and xpdf file without crashing after 2 minutes. Previously, after a few seconds, it will simply crashed with the package from Arch testing.

Try running Xorg Server + FVWM + xcompmgr, have been using djview, xpdf for a few times, so the patch seems to work for i915 as well.

A big thanks to you.

@jelle van der waa:

I searched ``xf86 intel video core dump'' on https://bugs.freedesktop.org/. Nothing is found, so may be this bug is not send to upstream. I am not too sure which category should I filed the bug. Please advise.
Comment by Antonio Muñoz (tomby) - Thursday, 19 May 2011, 16:20 GMT
@liaohaohui

You are welcome! I got the patch from the suggested link by @lyman. It references to a freedesktop bug:

https://bugs.freedesktop.org/show_bug.cgi?id=36319
Comment by Jan de Groot (JGC) - Monday, 30 May 2011, 21:46 GMT
Is this fixed with 2.15.0-2?
Comment by Dilip Varma (testdude281) - Tuesday, 31 May 2011, 04:43 GMT
just upgraded the following packages

[2011-05-31 07:33] upgraded xf86-video-intel (2.14.0-3 -> 2.15.0-2)
[2011-05-31 07:33] upgraded xorg-xauth (1.0.5-2 -> 1.0.6-1)
[2011-05-31 07:33] upgraded xorg-server-common (1.10.0.902-1 -> 1.10.2-1)
[2011-05-31 07:33] upgraded xf86-input-evdev (2.6.0-2 -> 2.6.0-3)
[2011-05-31 07:33] upgraded xorg-server (1.9.4.901-1 -> 1.10.2-1)
[2011-05-31 07:33] upgraded xorg-iceauth (1.0.4-2 -> 1.0.5-1)

i have not experienced any problems until now. everything seems to be working.

Loading...