Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23639 - [truecrypt] "broken pipe" when trying to mount newly created volume.

Attached to Project: Arch Linux
Opened by Eivind (mokkurkalve) - Friday, 08 April 2011, 00:58 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Tuesday, 11 February 2014, 21:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I was testing truecrypt, so I created a simple plain 20 Mb file with AES and FAT for volume, using the truecrypt "create volume" wizard. Truecrypt only reports "broken pipe" and nothing gets mounted. I have not been able to retrieve any more info...


Additional info:
* package version(s)
truecrypt 7.0a-2

* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Tuesday, 11 February 2014, 21:20 GMT
Reason for closing:  Upstream
Additional comments about closing:  No response since more than one year.
Comment by Eivind (mokkurkalve) - Sunday, 10 April 2011, 00:58 GMT
Just to clarify: Creating a volume goes OK. It's trying to mount it afterwards that result in nothing but a "broken pipe" message.
Comment by Eivind (mokkurkalve) - Wednesday, 08 June 2011, 03:01 GMT
Discovered something else; when starting truecrypt with `gksu truecrypt' instead of giving the administrative password after (when trying to mount the volumes) the volumes does get mounted. So it's starting the program as regular user that end in `broken pipe' message when trying to mount the volume file, while this problem does not exist while it's executed as root to begin with. I don't have this problem with truecrypt 7.0a on a different machine running Ubuntu.
Comment by Eivind (mokkurkalve) - Sunday, 10 July 2011, 14:14 GMT
Problems still there with 7.0a-3.
Comment by Eric Belanger (Snowman) - Friday, 21 October 2011, 08:15 GMT
Can you test with truecrypt 7.1-1 in testing?
Comment by suawekk (suawekk) - Sunday, 18 December 2011, 12:12 GMT
I had the same problem. I investigated a little, and found out that 'broken pipe' mysterious error was caused by /tmp mounted in RAM (as tmpfs)
(I probably enabled it at some point after reading some system optimization tips on archwiki)
After disabling fstab entry for /tmp and rebooting truecrypt started working correctly without root privileges.
Comment by Eivind (mokkurkalve) - Tuesday, 03 January 2012, 05:04 GMT
Sorry didn't see this before. I've got the same problem still with 7.1-1 and I do not have /tmp on tmpfs. However I got root, home and swap partitions as LVM2 volumes on top of a LUKS encrypted primary partition. Probably something with this setup disagrees with Truecrypt...

Comment by suawekk (suawekk) - Tuesday, 31 January 2012, 19:04 GMT
Hello again! You were right. This was not the problem with /tmp.
Please change your /etc/sudoers to look like that: (remember to backup first and use visudo or something)

root ALL=(ALL) ALL
%wheel ALL=(ALL) ALL
#includedir /etc/sudoers.d


... and reboot to be sure (sudo can cache authentication state).
Or try deleting/commenting line:
'Defaults log_output'
which was source of my problems with truecrypt being run as normal user.








Comment by Eivind (mokkurkalve) - Thursday, 02 February 2012, 14:15 GMT
Thanks! commented out all lines regarding logging thus:

## Uncomment to enable logging of a command's output, except for
## sudoreplay and reboot. Use sudoreplay to play back logged sessions.
#Defaults log_output
#Defaults!/usr/bin/sudoreplay !log_output
#Defaults!/usr/local/bin/sudoreplay !log_output
#Defaults!/sbin/reboot !log_output

and now mounting truecrypt volume as normal user finally works again. Great!
Comment by Eivind (mokkurkalve) - Thursday, 02 February 2012, 17:10 GMT
Should this finding be reported upstream?
Comment by Eric Belanger (Snowman) - Thursday, 02 February 2012, 19:35 GMT
Sure, you should report it upstream. They might be able to fix truecrypt so that it works with sudo logging.
Comment by Eivind (mokkurkalve) - Monday, 06 February 2012, 02:25 GMT
Filed bug report upstreams. So now we'll just have to see...
Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 15:50 GMT
Upstream bug report links please.
Comment by Eivind (mokkurkalve) - Sunday, 06 May 2012, 23:43 GMT
Unforunately Truecrypt bug reporting system don't seem to work like that. They only let you send them a bug report. They won't let you view your report after. Strange system indeed...

Loading...