Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23528 - [kernel26] Kernel panic after resume from disk

Attached to Project: Arch Linux
Opened by Ramses de Norre (Ramses_de_Norre) - Thursday, 31 March 2011, 09:34 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 18 April 2011, 12:17 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No


Since linux a kernel panic occurs when resuming from disk, the problem is known upstream:

I just wanted to make it known here so that we can maybe hold off putting the kernel in [core] until this is fixed, I think hibernation can be considered a core functionality used by many.

Additional info:
* package version(s): kernel26-

Steps to reproduce:
Hibernation works fine, but when resuming the kernel locks up once the resume is done. My scroll and caps lock blink indicating a kernel panic.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 18 April 2011, 12:17 GMT
Reason for closing:  Fixed
Additional comments about closing:
Comment by Ramses de Norre (Ramses_de_Norre) - Thursday, 31 March 2011, 14:24 GMT
It seems the commit causing this (e5f15b45ddf3afa2bbb) is also included in (see the changelog:, so that kernel is probably affected as well.
Comment by Anderson Medeiros Gomes (amg1127) - Friday, 01 April 2011, 22:21 GMT
Comment by Ramses de Norre (Ramses_de_Norre) - Sunday, 10 April 2011, 09:59 GMT
It appears this bug only affects x86_64.
Could any of the kernel devs comment on this one? I read on the ML you'll be moving, is that the vanilla kernel that breaks hibernation for all 64bit users?
Is it an option to patch it or ship while this isn't fixed upstream?
Comment by Stephan Wurm (Atomisirsi) - Wednesday, 13 April 2011, 07:44 GMT
I'm also affected by this bug. I'm running Arch on a laptop with x86_64 installation.
But there seems to exist a patch now, which fixes the issue:
Comment by Greg (dolby) - Wednesday, 13 April 2011, 11:31 GMT Comment by Fabio Varesano (fax8) - Thursday, 14 April 2011, 11:31 GMT
I'm also affected by this issue. I'm also on x86_64.
Comment by Fabio Varesano (fax8) - Thursday, 14 April 2011, 11:57 GMT
Reverting back to kernel26- is a workaround until this bug is fixed upstream.

You can get the older kernel using:
pacman -U
Comment by Stephan Wurm (Atomisirsi) - Thursday, 14 April 2011, 12:09 GMT
Another ability to get kernel 2.6.38 running, is to build in the above mentioned patch (see Greg's comment).

I've created a source package and attached the tarball.
Comment by Ramses de Norre (Ramses_de_Norre) - Thursday, 14 April 2011, 13:24 GMT
Another possible quick fix is to grab from ARM. I hope is released soon with a fix for this show-stopper bug.
Comment by Fabio Varesano (fax8) - Thursday, 14 April 2011, 19:23 GMT
@Ramses I wasn't able to find on ARM. Were you?

Anyone has the time to compile a package from Stephan src?
Comment by Ramses de Norre (Ramses_de_Norre) - Thursday, 14 April 2011, 19:52 GMT
@Fabio: Look in the testing dir, never came out of testing.
Comment by Fabio Varesano (fax8) - Thursday, 14 April 2011, 23:57 GMT
@Ramses thanks.

I tried compiling using Stephan patches above but it stopped with the error:
arch/x86/kernel/.x86_init.o.cmd:5: *** unterminated call to function `wildcard': missing `)'. Stop.
make[1]: *** [arch/x86/kernel] Error 2
make: *** [arch/x86] Error 2
Comment by Arthur Huillet (ahuillet) - Saturday, 16 April 2011, 09:25 GMT
I'm affected as well, and the patch makes the problem disappear (I used Stephan Wurm's PKGBUILD).

I advise this patch be applied to the Arch kernel, or the kernel version be downgraded, as the problem seems to affect many people and is quite annoying.
Comment by Greg (dolby) - Saturday, 16 April 2011, 10:19 GMT should have it applied already so the solution is to upgrade not downgrade! :p
Comment by Amitav (amitavmohanty01) - Saturday, 16 April 2011, 19:16 GMT
Is stable now or is it in testing?
Comment by James (Raziel23) - Sunday, 17 April 2011, 06:05 GMT
I have to admit that this patch is not present in kernel It is present on maling list:
but I don't see it in changelog:
Comment by Stijn (magnetra) - Monday, 18 April 2011, 09:14 GMT
In kernel26 resume from hibernation was broken (kernel lockup), upgrading to from [testing] fixed it for me.